You are not logged in.

#1 2012-08-01 23:42:11

pablox
Member
From: /home/chile/curico/
Registered: 2008-05-14
Posts: 169
Website

Problems building lib32-gstreamer0.10-base

I've been trying to build lib32-gstreamer suit, but it has been impossible. lib32-gstreamer0.10 installs without issues, but -base asks for a lot of lib32 packages (also in the AUR), most of them downloading files from ftp://ftp.archlinux/*/i686/* (which btw doesn't exist?), which are simply copying binaries.

I don't know, but it's kind of weird that it's so hard, I imagined that building these packages were going to be easy (or that they were going to be available from the multilib repo). I believed that because they are popular (and important?) packages, though I couldn't find many posts in the bbs, and the wiki article isn't very deep. 

I don't know, maybe I'm not understanding something, or the original build shouldn't relay on a package like that.

Btw, all this problem is because I'm trying to get libgstinterfaces0.10.so to play Dino Run SE :(


Geeks & Linux Atelier
An eye for an eye ... ends in making everybody blind -- Mahatma Gandhi
dotfiles

Offline

#2 2012-08-02 02:44:21

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: Problems building lib32-gstreamer0.10-base

pablox wrote:

I've been trying to build lib32-gstreamer suit, but it has been impossible. lib32-gstreamer0.10 installs without issues, but -base asks for a lot of lib32 packages (also in the AUR), most of them downloading files from ftp://ftp.archlinux/*/i686/* (which btw doesn't exist?), which are simply copying binaries.

That's the old way to do things before the multilib repo. Now the lib32 packages are built with gcc-multilib. You'll need to update the PKGBUILD for these. I don't use that multilib stuff but there's probably more info in the wiki or you could check the packages in the multilib repo for an example. Maybe if you would post the packages names, someone might be willing to update them for you.

pablox wrote:

I don't know, but it's kind of weird that it's so hard, I imagined that building these packages were going to be easy (or that they were going to be available from the multilib repo). I believed that because they are popular (and important?) packages, though I couldn't find many posts in the bbs, and the wiki article isn't very deep. 

I don't know, maybe I'm not understanding something, or the original build shouldn't relay on a package like that.

Btw, all this problem is because I'm trying to get libgstinterfaces0.10.so to play Dino Run SE sad

The multilib repo is very strict about package addition to keep the workload at a minimum.  So only the most popular packages (like wine, skype) are included.

Offline

#3 2012-08-02 02:48:38

pablox
Member
From: /home/chile/curico/
Registered: 2008-05-14
Posts: 169
Website

Re: Problems building lib32-gstreamer0.10-base

Embarrassing update:

I just found that the problem was that my wifi connection wasn't letting me to load the ftp archlinux.

Still, this is annoying because each package has a lot of other dependencies (right now, building lib32-gtk3), I don't know.... I believe it shouldn't be that complicated to install lib32-gstreamer.

@Snowman

Thanks for your comments, I'll keep that in mind smile


Geeks & Linux Atelier
An eye for an eye ... ends in making everybody blind -- Mahatma Gandhi
dotfiles

Offline

Board footer

Powered by FluxBB