You are not logged in.

#26 2012-07-25 21:07:04

nTia89
Banned
From: varese, italy
Registered: 2008-12-22
Posts: 1,230

Re: [EFI 32-bit problem] archiso doesn't boot on macbook

arch config:                     http://pastebin.com/VJx8giJH
chakra config:                 http://pastebin.com/GTPqPXPS

differences are very much ! *i915* and *apple* are the same, what should i compare? since we aren't sure about the problem/s?

Last edited by nTia89 (2012-07-25 21:25:56)


+pc: custom | AMD Opteron 175 | nForce4 Ultra | 2GB ram DDR400 | nVidia 9800GT 1GB | ArchLinux x86_64 w/ openbox
+laptop: Apple | MacBook (2,1) | 2GB ram | Mac OS X 10.4 -> DIED
+ultrabook: Dell | XPS 13 (9343) | 8GB ram | 256GB ssd | FullHD display | Windows 8.1 64bit ArchLinux x86_64 w/ Gnome

Offline

#27 2012-07-27 13:38:39

nTia89
Banned
From: varese, italy
Registered: 2008-12-22
Posts: 1,230

Re: [EFI 32-bit problem] archiso doesn't boot on macbook

tried with following parameters, and some their combinations:

xforcevesa, modprobe.blacklist=i915, nomodeset, noapic, noapci, i915.modeset=1

but no luck

and also tried with testing repo packages i have not luck

now i have three ideas:
- try ARCHBANG
- how to build an ISO with graphical environment (startx) ?
- is possible to switch from syslinux to grub2 (seen that chakra ISO works)?and how ?

EDIT: archbang works, then..... ?

Last edited by nTia89 (2012-07-27 14:02:08)


+pc: custom | AMD Opteron 175 | nForce4 Ultra | 2GB ram DDR400 | nVidia 9800GT 1GB | ArchLinux x86_64 w/ openbox
+laptop: Apple | MacBook (2,1) | 2GB ram | Mac OS X 10.4 -> DIED
+ultrabook: Dell | XPS 13 (9343) | 8GB ram | 256GB ssd | FullHD display | Windows 8.1 64bit ArchLinux x86_64 w/ Gnome

Offline

#28 2012-07-30 19:49:43

nTia89
Banned
From: varese, italy
Registered: 2008-12-22
Posts: 1,230

Re: [EFI 32-bit problem] archiso doesn't boot on macbook

i'm in a deadlock. the point:

- official ISO doesn't work either in EFI mode and BIOS-compatible mode

now the only idea is to build an iso with graphical environment, a graphical live-cd, is enough that startx works, because i've noticed that archbang and chakra (arch-based distro) work, the only big difference between them and arch is the working graphical environment

can someone help me to build that iso ?


+pc: custom | AMD Opteron 175 | nForce4 Ultra | 2GB ram DDR400 | nVidia 9800GT 1GB | ArchLinux x86_64 w/ openbox
+laptop: Apple | MacBook (2,1) | 2GB ram | Mac OS X 10.4 -> DIED
+ultrabook: Dell | XPS 13 (9343) | 8GB ram | 256GB ssd | FullHD display | Windows 8.1 64bit ArchLinux x86_64 w/ Gnome

Offline

#29 2012-07-30 21:05:47

progandy
Member
Registered: 2012-05-17
Posts: 2,143

Re: [EFI 32-bit problem] archiso doesn't boot on macbook

Did you try the archboot iso? If that works you shouldn't bother creating your own iso.

Offline

#30 2012-07-30 21:07:40

nTia89
Banned
From: varese, italy
Registered: 2008-12-22
Posts: 1,230

Re: [EFI 32-bit problem] archiso doesn't boot on macbook

i've tried with own archiso build, see previous post in this thread; do you mean those ?


+pc: custom | AMD Opteron 175 | nForce4 Ultra | 2GB ram DDR400 | nVidia 9800GT 1GB | ArchLinux x86_64 w/ openbox
+laptop: Apple | MacBook (2,1) | 2GB ram | Mac OS X 10.4 -> DIED
+ultrabook: Dell | XPS 13 (9343) | 8GB ram | 256GB ssd | FullHD display | Windows 8.1 64bit ArchLinux x86_64 w/ Gnome

Offline

#31 2012-07-30 21:08:31

progandy
Member
Registered: 2012-05-17
Posts: 2,143

Re: [EFI 32-bit problem] archiso doesn't boot on macbook

nTia89 wrote:

i've tried with own archiso build, see previous post in this thread; do you mean those ?

I mean this project: https://wiki.archlinux.org/index.php/Archboot

Offline

#32 2012-07-30 21:11:26

nTia89
Banned
From: varese, italy
Registered: 2008-12-22
Posts: 1,230

Re: [EFI 32-bit problem] archiso doesn't boot on macbook

then no, i tried with "official" archiso tool


+pc: custom | AMD Opteron 175 | nForce4 Ultra | 2GB ram DDR400 | nVidia 9800GT 1GB | ArchLinux x86_64 w/ openbox
+laptop: Apple | MacBook (2,1) | 2GB ram | Mac OS X 10.4 -> DIED
+ultrabook: Dell | XPS 13 (9343) | 8GB ram | 256GB ssd | FullHD display | Windows 8.1 64bit ArchLinux x86_64 w/ Gnome

Offline

#33 2012-08-03 02:47:32

ArchVillian
Member
Registered: 2012-08-01
Posts: 21

Re: [EFI 32-bit problem] archiso doesn't boot on macbook

Hey guys did any of those solutions work?  I'm in the same boat? I've been searching and trying to figure out this for the past 12 hours. Any help would be appreciated. I'm going to try the Archboot i686iso now.

Nope that didn't work either.

Last edited by ArchVillian (2012-08-03 02:56:37)

Offline

#34 2012-08-03 07:56:13

nTia89
Banned
From: varese, italy
Registered: 2008-12-22
Posts: 1,230

Re: [EFI 32-bit problem] archiso doesn't boot on macbook

unfortunately no

if you try a solution post it here, please !!!


+pc: custom | AMD Opteron 175 | nForce4 Ultra | 2GB ram DDR400 | nVidia 9800GT 1GB | ArchLinux x86_64 w/ openbox
+laptop: Apple | MacBook (2,1) | 2GB ram | Mac OS X 10.4 -> DIED
+ultrabook: Dell | XPS 13 (9343) | 8GB ram | 256GB ssd | FullHD display | Windows 8.1 64bit ArchLinux x86_64 w/ Gnome

Offline

#35 2012-08-03 20:06:47

ArchVillian
Member
Registered: 2012-08-01
Posts: 21

Re: [EFI 32-bit problem] archiso doesn't boot on macbook

Hey man I remember a similar issue I had when I was
trying to install Windows 7 64bit I kept getting the error select
boot type and this fixed worked great. I tried this already for arch Linux  but rushed
it since I had to work so I might have skipped some steps. You need a windows machine or vm for this. http://jowie.com/blog/post/Select-CD-RO … -file.aspx

Edit: No, I tried it step by step, and this time my mac booted to a blinking cursor. This issue is really getting annoying.

Last edited by ArchVillian (2012-08-03 23:22:27)

Offline

#36 2012-08-03 20:13:09

nTia89
Banned
From: varese, italy
Registered: 2008-12-22
Posts: 1,230

Re: [EFI 32-bit problem] archiso doesn't boot on macbook

interesting, i don't known that was a windows problem too !

i'm reading here and there your link...


+pc: custom | AMD Opteron 175 | nForce4 Ultra | 2GB ram DDR400 | nVidia 9800GT 1GB | ArchLinux x86_64 w/ openbox
+laptop: Apple | MacBook (2,1) | 2GB ram | Mac OS X 10.4 -> DIED
+ultrabook: Dell | XPS 13 (9343) | 8GB ram | 256GB ssd | FullHD display | Windows 8.1 64bit ArchLinux x86_64 w/ Gnome

Offline

#37 2012-08-04 03:29:08

the.ridikulus.rat
Member
From: Indiana, USA
Registered: 2011-10-04
Posts: 765

Re: [EFI 32-bit problem] archiso doesn't boot on macbook

Offline

#38 2012-08-11 07:19:11

the.ridikulus.rat
Member
From: Indiana, USA
Registered: 2011-10-04
Posts: 765

Re: [EFI 32-bit problem] archiso doesn't boot on macbook

Offline

#39 2013-03-02 15:52:44

NgoHuy
Member
Registered: 2011-10-27
Posts: 23

Re: [EFI 32-bit problem] archiso doesn't boot on macbook

Hi all !

I just rebuild gummiboot ( on i686 machine) from freedesktop git. It boots fine with EFI on 32bit machine.
You should use gummiboot from git not from Arch repo.
Maybe help you.

Kind regars,
Ngo Huy.

Offline

Board footer

Powered by FluxBB