You are not logged in.

#26 2012-08-06 09:21:58

Registered: 2012-08-06
Posts: 19

Re: Cannot upgrade libcanberra and pyqt

I've got the same problem.


pacman -Syu --ignore glibc,curl

Gives me:

:: Starting full system upgrade...
warning: curl: ignoring package upgrade (7.25.0-1 => 7.27.0-1)
:: Replace dbus-python with extra/python2-dbus? [Y/n] y
warning: glibc: ignoring package upgrade (2.15-10 => 2.16.0-2)
:: Replace libusb with core/libusbx? [Y/n] y
:: Replace udev with core/systemd-tools? [Y/n] y
        ... (cut)
warning: ignoring package glibc-2.16.0-2
warning: cannot resolve "glibc>=2.16", a dependency of "gcc-libs"
:: The following packages cannot be upgraded due to unresolvable dependencies:
      accountsservice  at-spi2-core  automake  avidemux-cli  avidemux-gtk  avr-gcc  avr-libc  baobab  binutils  blender  bluez  boost  boost-libs  ca-certificates  ca-certificates-java  cairo  cairo-perl
      cifs-utils  cloog  clutter  clutter-gst  cogl  colord  consolekit  coreutils  cronie  cryptsetup  cups  db  dbus  dbus-core  dbus-glib  python2-dbus  dconf  desktop-file-utils  device-mapper  e2fsprogs
      empathy  eog  evolution-data-server  faac  fakeroot  ffmpeg  file-roller  filesystem  firefox  flashplugin  foomatic-db  foomatic-db-engine  foomatic-filters  gc  gcalctool  gcc  gcc-libs  gedit  gegl
      gimp  glew  glib-networking  glib-perl  glib2  glibmm  gmime  gmp  gnome-bluetooth  gnome-control-center  gnome-desktop  gnome-keyring  gnome-menus  gnome-panel  gnome-screensaver  gnome-session
      gnome-settings-daemon  gnome-shell  gnome-themes-standard  gnome-user-docs  gnutls  grep  gsettings-desktop-schemas  gstreamer0.10-bad-plugins  gtk-engines  gtk2  gtk2-perl  gtk3  gtksourceview3  gvfs
      gvfs-obexftp  gvim  hplip  hyphen  icu  imagemagick  initscripts  inkscape  iproute2  iputils  krb5  ldns  libatasmart  libcanberra-pulse  libcups  libevent  libimobiledevice  libldap  liblrdf  libmp4v2
      libproxy  libpulse  libpurple  libreoffice-calc  libreoffice-common  libreoffice-gnome  libreoffice-impress  libreoffice-math  libreoffice-writer  libssh2  libtool  libtracker-sparql  libva  libvncserver
      libwacom  libwnck3  linux  logrotate  lvm2  mencoder  mesa  mkinitcpio  mpfr  mplayer  mx  nautilus  nautilus-sendto  net-snmp  nettle  networkmanager  nvidia  nvidia-cg-toolkit  nvidia-utils
      obexd-client  ogre  openimageio  openjdk6  openssh  openssl  pam  pango  pango-perl  pcre  perl  perl-anyevent  perl-async-interrupt  perl-common-sense  perl-ev  perl-event  perl-guard  perl-libintl-perl
      perl-xml-parser  perl-xml-simple  pkg-config  polkit  poppler  poppler-glib  ppl  pulseaudio  pyqt  python2-matplotlib  python2-pyqt  qt  qtwebkit  raptor  rasqal  samba  sane  shadow  smbclient  sudo
      syslog-ng  sysvinit  taglib  telepathy-mission-control  texlive-bibtexextra  texlive-bin  texlive-core  texlive-fontsextra  texlive-formatsextra  texlive-games  texlive-genericextra  texlive-htmlxml
      texlive-humanities  texlive-langcjk  texlive-langcyrillic  texlive-langextra  texlive-langgreek  texlive-latexextra  texlive-music  texlive-pictures  texlive-plainextra  texlive-pstricks
      texlive-publishers  texlive-science  thunderbird  tomboy  totem  totem-plparser  totem-plugin  transcode  systemd-tools  udisks  udisks2  upower  util-linux  vim-runtime  vino  virtualbox
      virtualbox-modules  vlc  vte3  wpa_supplicant  xorg-server  yelp

Do you want to skip the above packages for this upgrade? [y/N] y
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: libcanberra-pulse: requires libcanberra=0.28-4
:: pyqt: requires python-sip

The previous posts of this thread havn't really helped me. I don't dare to be to explorative either since this is my office computer. Please help!

BTW, I really think this is the most serious problem in Arch's history. Hope Arch Linux won't end up like Gentoo. Users fleeing due to upgrade breakages. sad


#27 2012-09-29 21:30:53

Registered: 2012-09-29
Posts: 3

Re: Cannot upgrade libcanberra and pyqt

It might be a little late, but for me this fixed it:

pacman -Sy
pacman -S sip python-sip

Then follow the upgrade steps in … iki:usrlib

Last edited by Coz (2012-09-29 21:31:40)


Board footer

Powered by FluxBB