You are not logged in.

#451 2012-08-08 18:53:51

maevius
Member
From: Greece
Registered: 2009-09-10
Posts: 132
Website

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

I don't know about modesetting, if you have a clue please do edit the wiki. I used your trick to change backlight with xbindkeys, pretty neat smile
I have plugged an external monitor but the resolution was 800x600 and a big part of the screen was missing. I played with xrandr but didn't achieve anything...
Btw which package provides notify-send?

Last edited by maevius (2012-08-08 19:04:09)

Offline

#452 2012-08-08 20:26:28

min
Member
Registered: 2011-05-14
Posts: 46

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

libnotify is the one that provides notify-send.

Regarding the modesetting, I first know it from here https://bbs.archlinux.org/viewtopic.php?id=141270. I tried playing a bit with it and install it. After creating Xorg.conf, if I do "xrandr", it will give option of the output, not just one like I have with default fbdev one. That being said when I am using it, the mouse cursor dissapeared and the screen flickered a bit (for example moving between menu quickly). That makes me back to fbdev one. If I fixes that issue and have external monitor working, I'll update the wiki. Currently when I connect with external monitor, it will only duplicate the screen,

Offline

#453 2012-08-08 20:35:20

Gusar
Member
Registered: 2009-08-25
Posts: 3,399

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

fbdev doesn't provide modesetting. There's a driver that does though, aptly named xf86-video-modesetting, it's in AUR. Should work with gma500_gfx. In theory smile

Edit: Oops, I see now the thread you linked to actually discusses the modesetting driver cool. Weird that it has issues though. It's a very simple driver, no acceleration or anything, the CPU does all the drawing. So from this perspective, it's no different than fbdev.

Last edited by Gusar (2012-08-08 21:47:01)

Offline

#454 2012-08-08 21:45:33

min
Member
Registered: 2011-05-14
Posts: 46

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

I had built and instaled that package. And I had problem with the screen. The mouse cursor dissapearing (become a block of line). And the screen a bit choppy when refreshing too fast (for example moving between menu quickly). Might be something wrong with my Xorg.conf.

Offline

#455 2012-08-08 21:49:39

Gusar
Member
Registered: 2009-08-25
Posts: 3,399

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Well, as I said in my edit above (talk about timing fail smile), it's weird that it has issues, as the CPU does all the drawing. I'm gonna try it on my machine. No I don't have poulsbo (thank FSM for that smile), but it works with all KMS drivers.

Edit: Works great here:

[189518.294] (II) LoadModule: "modesetting"
[189518.294] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[189518.294] (II) Module modesetting: vendor="X.Org Foundation"
[189518.294] 	compiled for 1.12.3, module version = 0.4.0
[189518.294] 	Module class: X.Org Video Driver
[189518.294] 	ABI class: X.Org Video Driver, version 12.0
[189518.294] (II) modesetting: Driver for Modesetting Kernel Drivers: kms

...

[189518.297] (II) modeset(0): ShadowFB: preferred YES, enabled YES

Last edited by Gusar (2012-08-08 21:57:55)

Offline

#456 2012-08-09 00:43:21

min
Member
Registered: 2011-05-14
Posts: 46

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

121:[ 30304.260] (II) modeset(0): ShadowFB: preferred NO, enabled NO

That probably what causing mine to flicker a bit. How do i set that one in Xorg?

Edit:
I solved the dissapearng cursor using

Option "SWCursor"           "on"

No luck on flickering though. It is not that bad, but sometime annoying. I Guess i will stay using modesetting for the time being. When using an 8" screen, the ability to switch between 1600x768 and 1256x600 with a button click(xrandr + xbindkeys) is really appreciated wink

Last edited by min (2012-08-09 01:50:04)

Offline

#457 2012-08-09 08:00:32

Gusar
Member
Registered: 2009-08-25
Posts: 3,399

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

min wrote:
121:[ 30304.260] (II) modeset(0): ShadowFB: preferred NO, enabled NO

That probably what causing mine to flicker a bit. How do i set that one in Xorg?

It should be on by default, I didn't configure anything beyond Driver "modesetting". You can explicitly set it though, so give this a try:

Section "Device"
    Identifier  "poulsbo crap"
    Driver      "modesetting"
    Option      "ShadowFB"    "on"
EndSection

I didn't even know the driver has anything but shadowfb.

Last edited by Gusar (2012-08-09 08:05:49)

Offline

#458 2012-08-09 10:06:20

min
Member
Registered: 2011-05-14
Posts: 46

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

That option will give

121:[ 30304.260] (II) modeset(0): ShadowFB: preferred NO, enabled YES

I give up the modesetting for the moment, still a bit flickering. Maybe flickering is the wrong term. WHat happens is if I move between menu quickly, it will display the highlighter/popup-ed menu half rendered half not. I think the correct term might be tearing.

As it don;t happen with fbdev, I am guessing that it is something related to default setting of fbdev compared to modesetting. I just don't know what it is.

Offline

#459 2012-10-03 11:14:56

min
Member
Registered: 2011-05-14
Posts: 46

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Update: I recompile the modesetting driver this week and try using it again. The flickering is gone and I can now connect my vaio p to full hd external monitor using xrandr. I need to arrange it top/bottom [1600x900 + 1920x1080] instead of left and right because of viewport limitation (2048x2048).

Offline

#460 2012-10-03 11:31:19

maevius
Member
From: Greece
Registered: 2009-09-10
Posts: 132
Website

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Great news! I'll test it in the first chance.

Offline

#461 2012-10-03 16:09:16

Jristz
Member
From: America/Santiago
Registered: 2011-06-11
Posts: 904

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

ok I have a gma500 this pkgbuild for xf86-modesseting work in 64bits, I ask this because the last time that I test this one simply the X refuse to start

EDIT:
I respond to myself work, but  I need add the 90-monitor to xorg.conf.d to force using modeseting

and I upload a stable xf86-video-modesetting 0.5.0 to AUR


UPDATE: not compile against xorg 1.13 not the stable neither the git

Last edited by Jristz (2012-10-14 04:51:30)


Well, I suppose that this is somekind of signature, no?

Offline

#462 2012-10-16 21:35:39

min
Member
Registered: 2011-05-14
Posts: 46

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

I can confirm that modesetting driver doesn't compile with Xorg 1.13. Fbdev driver work though.

Edit: Update wiki to mention it breaks on Xorg 1.13

Last edited by min (2012-10-16 21:41:40)

Offline

#463 2012-10-17 00:35:09

Jristz
Member
From: America/Santiago
Registered: 2011-06-11
Posts: 904

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Now compile, the problem are a dependency

but you need make a custom rule in xorg.con.d for force the use of modesetting


Well, I suppose that this is somekind of signature, no?

Offline

#464 2012-10-20 10:51:50

javuchi
Member
Registered: 2010-01-21
Posts: 9

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

I'm now using the modesetting driver compiled for my processor and with -ffast-math and -fomit-frame-pointer.
Now it feels very smooth and fast.

But I always have the same problem when trying to use mplayer: randomly it freezes and I have to press a key or move the mouse to make it work again.
It seems that it is not mplayer fault, as the entire screen freezes, and even sound playback enter into a loop.

I've checked that it is not my ALSA driver as some suggests, just by turning it off and using a dumb sound driver. What happens is very simple: as long as I use the mouse or keyboard offen, no freezes happen.

Any suggestions?

Offline

#465 2012-11-02 13:54:41

ToJa92
Member
From: ~
Registered: 2012-08-31
Posts: 9
Website

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

min wrote:

Update: I recompile the modesetting driver this week and try using it again. The flickering is gone and I can now connect my vaio p to full hd external monitor using xrandr. I need to arrange it top/bottom [1600x900 + 1920x1080] instead of left and right because of viewport limitation (2048x2048).

Hi, what Xorg settings do you use? Is the package you compiled "xf86-video-modesetting-git"?
I also have a Vaio P(the 2nd-gen) and my screen flickers. I compiled "xf86-video-modesetting-git" from AUR and have the following settings in a Xorg configuration file:

Section "Device"
Identifier "gma500_gfx"
Option "ShadowFB" "on"
Option "SWCursor" "on"
EndSection

but my screen flickers a lot anyway.
Like in one of your previous posts, this message appears as well:

[ 5.112] (II) modeset(0): ShadowFB: preferred NO, enabled YES

If your configuration file differs, I'd be grateful if you could post it.

EDIT: I found the-now deleted AUR entry for the "xf86-video-modesetting" package, downloaded the PKGBUILD and it worked perfectly(had to generate a new md5sum though).
The flickering is still noticeable sometimes, namely when in SLiM(with its default background) and also sometimes when it's showing solid colors. Otherwise, no issues.

Last edited by ToJa92 (2012-11-02 16:29:40)

Offline

#466 2012-11-02 16:34:54

maevius
Member
From: Greece
Registered: 2009-09-10
Posts: 132
Website

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

xf86-video-modesetting is in [extra]

Offline

#467 2012-11-02 18:31:52

min
Member
Registered: 2011-05-14
Posts: 46

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Section "Screen"
    Identifier    "Screen0"
    Device        "gma500_gfx"
    Monitor       "VAIO-LVDS"
    DefaultDepth  24
    SubSection    "Display"
        Depth      24
        Modes     "1600x768"
        ViewPort   0 0
    EndSubsection
EndSection

Section "Monitor"
    Identifier "VAIO-LVDS"
    VendorName "SNY"
    ModelName " SNY:fa09"
    Modeline "1600x768"  100.25  1600 1688 1848 2096  768 771 781 798 -hsync +vsync
    Modeline "1256x600"   60.00  1256 1312 1432 1608  600 603 613 624 -hsync +vsync	
    Modeline "1280x614"   62.25  1280 1328 1456 1632  614 617 627 639 -hsync +vsync
    Modeline "1368x676"   74.25  1368 1432 1568 1768  676 679 689 703 -hsync +vsync
    Option "DPMS"
EndSection

# Primary (First/only) display
Section "Device"
    Identifier "gma500_gfx"
    Driver     "modesetting"
    Option     "ShadowFB"       "off"
    Option     "SWCursor"       "on" 
EndSection

#Section "DRI"
#	Mode	0666
#EndSection

section "module"
    Load "dbe"
    Load "extmod"
    Load "glx"
    Load "record"
    Load "dri"
    Load "dri2"
endSection

Like Maevious said, the old aur pkg is now included in extra. So it would be better removing the aur one and install the one from extra. The one I used was the git one which i built (coicidentally) at 20 October, same as the one currently in extra. I will install the one from extra later on today.

That problem was actually menu/button half rendered/updated and half not. I get a bit flickering on light blueish background (like the one for thread post number here), but not that bad for me.

Offline

#468 2012-11-03 00:56:05

Jristz
Member
From: America/Santiago
Registered: 2011-06-11
Posts: 904

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

I need change 2 times te resolution for take effect if is high than actual
ex: 640x480 first time, no work, retry again (trow GUI) work, same for a custom one maked for 1280x750 (1.7066 aspect ratio here)

the original xrandr work

and as for mplayer, not try run 1080i videos....seriously, they run slow, wver throw mplayer -framedrop -hardframedrop -sws 0 -audiosync 30
really slow, but small (640x480) run aceptable


Well, I suppose that this is somekind of signature, no?

Offline

#469 2013-05-30 08:36:24

seletskiy
Member
Registered: 2012-08-31
Posts: 14

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Does anyone experience same problems, that are described in https://bbs.archlinux.org/viewtopic.php?id=152753, but with gma500_gfx driver?

I've been experiencing this bug on my laptop (Samsung NC110) with using latest gma500_gfx, xf86-video-modesetting and xorg-server.

This thread claims, that there is a bug in pixman (and, maybe in nvidia driver). On my desktop computer I've saw same problem (with nvidia driver), but in up to date xorg (and pixman) it seems to be fixed.

Additionally, described bug in pixman correlates with new glyph cache API and its usage in video drivers.

Is there a chance of there is a bug in gma500_gfx or xf86-video-modesetting, that cause this chromium bug to reappear while using latest xorg-server+pixman?

BTW, downgrading xorg-server (with pixman, xf86-input-evdev, xf86-video-modesetting and couple of hacks around libpng) fixes issue, but I don't like this solution at all.

Offline

#470 2013-05-30 11:07:30

maevius
Member
From: Greece
Registered: 2009-09-10
Posts: 132
Website

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Not experiencing this (I am using [testing] if that matters).

linux 3.9.4-1
pixman 0.30.0-1
xorg-server 1.14.1-1
xf86-video-modesetting 0.7.0-1
xf86-input-evdev 2.8.0-1

Offline

#471 2013-05-30 16:04:40

seletskiy
Member
Registered: 2012-08-31
Posts: 14

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

maevius wrote:

Not experiencing this (I am using [testing] if that matters).

Hmm... What version of chromium are you using? I've upgraded to testing and issue is still here...

Offline

#472 2013-05-30 19:42:03

Jristz
Member
From: America/Santiago
Registered: 2011-06-11
Posts: 904

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

I have that problem but I finally switch to Firefox again...again... and in that browser I not experience that problem
I'm not running testing
but I cannot run SDL app at full screen (Upstream bug filed by me)


Well, I suppose that this is somekind of signature, no?

Offline

#473 2013-05-31 18:49:29

maevius
Member
From: Greece
Registered: 2009-09-10
Posts: 132
Website

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

seletskiy wrote:
maevius wrote:

Not experiencing this (I am using [testing] if that matters).

Hmm... What version of chromium are you using? I've upgraded to testing and issue is still here...

Latest chromium 27.0.1453.93-3

ggV9ylt.png

I am using xfce btw. Is there a chance this is related to gtk theming etc?

Last edited by maevius (2013-06-01 05:09:43)

Offline

#474 2013-05-31 23:09:05

min
Member
Registered: 2011-05-14
Posts: 46

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

This is what it looks like on mine. I don't know whether this is one is considered normal or not. (I mainly use firefox)

MIzJYCWs.png

Xfce + i3

Offline

#475 2013-10-13 18:38:45

maevius
Member
From: Greece
Registered: 2009-09-10
Posts: 132
Website

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Since some kernels upgrade, I have no camera using skype. Did anyone else experience it?

Offline

Board footer

Powered by FluxBB