You are not logged in.

#1 2012-08-08 20:46:04

kodiak
Member
Registered: 2012-04-26
Posts: 61

[solved]Nimbus Sans L looks squashed

Hello, since some month I have squashed / condensed Nimubs Sans L font in libreoffice. I had the same issue on another machine running Mint Lisa. I found a bug report here on Launchpad . I followed the advice of Andrey Barrientos M, removed the gs-fonts, run dpkg-reconfigure fontconfig an reinstalled the fonts. So this did actually work on Ubuntu. How can I redo the same on Arch? Just reinstalling did not do the job.

Cheers Kodiak

Last edited by kodiak (2013-04-17 17:32:31)

Offline

#2 2012-08-08 21:04:48

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: [solved]Nimbus Sans L looks squashed

Were I you, I would do exactly the same:

pacman -Rdd gsfonts
pacman -S gsfonts

Just check if the Arch version is the one that solved your problem in Mint.


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#3 2012-08-08 21:52:07

kodiak
Member
Registered: 2012-04-26
Posts: 61

Re: [solved]Nimbus Sans L looks squashed

Arch shows: 1.0.7pre44-3
Ubuntu uses: gsfonts 1:8.11+urwcyr1.0.7~pre44-4.2ubuntu1 ( I double check that 2morow at work on my other PC)

Your commands did not work for me. I found it odd that I have the same misbehave on an Arch i386 and Mint 11 64bit on different PC´s.

Offline

#4 2012-08-08 22:08:09

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: [solved]Nimbus Sans L looks squashed

Well, they are not my commands, but pacman's: the first one lets you remove a package even if it's required as a dependency (and thus impossible to be removed with pacman -R), while the other simply installs a package. You may consider the two an equivalent of the apt-get / dpkg stuff. That's why try to be more specific when something doesn't work as expected, e.g. paste the output of a command you have run, a relevant piece of a log file, etc. Both pacmans, yours and mine, speak the same language. wink

Last edited by bohoomil (2012-08-08 22:08:40)


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#5 2012-08-08 23:04:24

kodiak
Member
Registered: 2012-04-26
Posts: 61

Re: [solved]Nimbus Sans L looks squashed

Removing and reinstalling the fonts worked as supposed to. What did not change was the look of Nimbus itself.
I know that the letters are squashed because I can compare old PDF´s with the original content. And a friend of mine was sending me the other day some odt´s from Ubuntu 12.04 which look different on my PC.

It seems to affect not all versions of Nimbus letters. Bold letters do fine, iterative letters again do not.
http://imagepaste.nullnetwork.net/img/1 … titled.png

sudo pacman -Rdd gsfonts
Password: 

Targets (1): gsfonts-1.0.7pre44-3

Total Removed Size:     4.45 MiB

Do you want to remove these packages? [Y/n] y
(1/1) removing gsfonts                             [######################] 100%
Updating font cache... done.
sudo pacman -S gsfonts
resolving dependencies...
looking for inter-conflicts...

Targets (1): gsfonts-1.0.7pre44-3

Total Installed Size:   4.45 MiB

Proceed with installation? [Y/n] y
(1/1) checking package integrity                   [######################] 100%
(1/1) loading package files                        [######################] 100%
(1/1) checking for file conflicts                  [######################] 100%
(1/1) checking available disk space                [######################] 100%
(1/1) installing gsfonts                           [######################] 100%
Updating font cache... done.

Update just checked the version on Mint 12: 1:8.11+urwcyr1.0.7~pre44-4.2ubuntu1


-- mod edit: read the Forum Etiquette and only post thumbnails http://wiki.archlinux.org/index.php/For … s_and_Code [jwr] --

Last edited by kodiak (2012-10-10 06:24:08)

Offline

#6 2012-11-25 18:24:26

kodiak
Member
Registered: 2012-04-26
Posts: 61

Re: [solved]Nimbus Sans L looks squashed

This one really annoys me, since I have a few documents written with nimbus. Libreoffice is up to date. Something seems to be weird. I installed gnome-font-viewer and I could not find Nimbus Sans L, I found Nimbus Sans L Regular.
This font is however not listed in Libreoffice. Libreoffice in the meantime (something must have changed between my first post and now), offers only Nimbus Sans L with the option condensed.
Fair enough, I typed it straight into the font field of Libreoffice and the font look changed. Not condensed but stretched. Have a look onto the screenshot. The font shown in the gnome-font-viewer does not match any of them in the office document. The top one is using standard Nimbus Sans L (with the condensed option), the one down under is using Nimbus Sans L Regular typed into the font field of Libreoffice.
http://imagepaste.nullnetwork.net/img/1 … :09:54.png

What I need is the font width which the Font Viewer does show me. Please help!


-- mod edit: read the Forum Etiquette and only post thumbnails http://wiki.archlinux.org/index.php/For … s_and_Code [jwr] --

Last edited by kodiak (2012-11-25 18:27:17)

Offline

#7 2013-04-10 22:07:56

kodiak
Member
Registered: 2012-04-26
Posts: 61

Re: [solved]Nimbus Sans L looks squashed

Offline

#8 2013-04-11 01:43:09

brebs
Member
Registered: 2007-04-03
Posts: 3,456

Re: [solved]Nimbus Sans L looks squashed

Check that the fonts are installed, and available to fontconfig.

My system is not Arch, and has the old 2010 texlive, so these are just examples:

$ cd /usr/share/texmf-dist/fonts/type1/urw/helvetic ; for f in `ls -A` ; do fc-query $f 2>/dev/null | grep -qi "nimbus sans l" && echo $f && fc-query $f | grep style: ; done
uhvb8ac.pfb
	style: "Bold Condensed"(s)
uhvb8a.pfb
	style: "Bold"(s)
uhvbo8ac.pfb
	style: "Bold Condensed Italic"(s)
uhvbo8a.pfb
	style: "Bold Italic"(s)
uhvboc8a.pfb
	style: "Bold Condensed Italic"(s)
uhvbrc8a.pfb
	style: "Bold Condensed"(s)
uhvr8a-105.pfb
	style: "Regular"(s)
uhvr8ac.pfb
	style: "Regular Condensed"(s)
uhvr8a.pfb
	style: "Regular"(s)
uhvro8a-105.pfb
	style: "Regular Italic"(s)
uhvro8ac.pfb
	style: "Regular Condensed Italic"(s)
uhvro8a.pfb
	style: "Regular Italic"(s)
uhvroc8a.pfb
	style: "Regular Condensed Italic"(s)
uhvrrc8a.pfb
	style: "Regular Condensed"(s)

And to make these available to texlive, put in /etc/fonts/conf.d/09-texlive-fonts.conf e.g.:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>

    <dir>/usr/share/texmf-dist/fonts/truetype</dir>

    <!-- Avoiding the many in type1/public, which make abiword slow -->
    <dir>/usr/share/texmf-dist/fonts/type1/adobe</dir>
    <dir>/usr/share/texmf-dist/fonts/type1/bitstrea</dir>
    <dir>/usr/share/texmf-dist/fonts/type1/urw</dir>

</fontconfig>

Offline

#9 2013-04-17 17:31:49

kodiak
Member
Registered: 2012-04-26
Posts: 61

Re: [solved]Nimbus Sans L looks squashed

Finaly solved it. Thanks to brebs I took a look at FontConfig and Font with Xorg.

In detail I installed ms-fonts, google-web-fonts, foss-fonts and fontconfig-infinality-ultimate, and set up /etc/X11/xorg.conf to my fonts. I have no idea what acutally fixed it, and therefore I do not think it was a clean solution. But I can live with it.

It also fixed this. X)

Last edited by kodiak (2013-04-17 17:37:23)

Offline

Board footer

Powered by FluxBB