You are not logged in.

#1 2012-08-09 20:54:02

Registered: 2011-09-29
Posts: 184

crystalhd driver keeps giving error "Firmware image signature failure"

Usually after rebooting there's a certain chance that the crystalhd driver will no longer work and dmesg will show this error message:

[  162.831515] Loading crystalhd v3.10.0
[  162.831638] crystalhd 0000:04:00.0: Starting Device:0x1615
[  162.837846] crystalhd 0000:04:00.0: irq 45 for MSI/MSI-X
[  195.409801] crystalhd 0000:04:00.0: Opening new user[0] handle
[  196.086934] crystalhd 0000:04:00.0: [crystalhd_flea_download_fw]: step 7. Error bit occured. RetVal:c00018
[  196.086966] crystalhd 0000:04:00.0: [crystalhd_flea_download_fw]: step 7. Firmware image signature failure.
[  196.086993] crystalhd 0000:04:00.0: Firmware Download Failure!! - -1
[  196.214372] crystalhd 0000:04:00.0: Closing user[0] handle via ioctl with mode 10200

When that happens I have to reboot once more and it's usually fine again.
However, now I just rebooted 5 times and I still get this error.
So I think this issue really needs an actual solution instead of just rebooting and hoping for the best.

I tried both firmware blobs (bcm70015fw.bin) from
which are both from AUR, and the two firmware files should actually be identical anyway, to no avail.
I think the only thing I changed before this reboot was changing the hwclock to UTC, nothing that should actually affect the crystalhd driver in any way.

I was able to get it going again by _shutting down_ instead of just warm-rebooting, so the notebook was turned off completely in between.
I don't think this counts as SOLVED though. =P

Last edited by Jindur (2012-08-10 04:12:03)


Board footer

Powered by FluxBB