You are not logged in.

#1 2012-08-12 09:49:58

litemotiv
Forum Fellow
Registered: 2008-08-01
Posts: 5,026

[Solved] Boot from EFI system partition: fsck.vfat not found

I'm trying out using the ESP as /boot partition, which seems to work fine but complains about missing fsck on startup (systemd). I found this relevant Red Hat bugreport:

https://bugzilla.redhat.com/show_bug.cgi?id=806648

Does anyone know how this would translate to Arch?

[edit] i seriously don't know what's wrong with me..

# pacman -S dosfstools

Last edited by litemotiv (2012-08-12 13:28:45)


ᶘ ᵒᴥᵒᶅ

Offline

#2 2012-08-14 09:31:36

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [Solved] Boot from EFI system partition: fsck.vfat not found

I believe what it is probably wants is for there to be fsck.vfat in the initramfs.  When you run mkinitcpio -p linux, do you have the EFI system partition mounted?  If not, it would probably be best to add /sbin/fsck.vfat in BINARIES of mkinitcpio.conf.  Otherwise it does not have access to it while it is trying to run the fsck during boot.

Offline

#3 2012-08-14 09:43:52

litemotiv
Forum Fellow
Registered: 2008-08-01
Posts: 5,026

Re: [Solved] Boot from EFI system partition: fsck.vfat not found

WonderWoofy wrote:

I believe what it is probably wants is for there to be fsck.vfat in the initramfs.  When you run mkinitcpio -p linux, do you have the EFI system partition mounted?  If not, it would probably be best to add /sbin/fsck.vfat in BINARIES of mkinitcpio.conf.  Otherwise it does not have access to it while it is trying to run the fsck during boot.

Yes good call WonderWoofy, i hadn't regenerated the initramfs yet with the EFI partition mounted. I did have the fsck hook enabled, but a quick glance at it's code suggests that it only includes fsck files for the root volume. Manually including fsck.vfat through BINARIES seems like the safest way to make sure it's included.


ᶘ ᵒᴥᵒᶅ

Offline

Board footer

Powered by FluxBB