You are not logged in.

#1 2012-08-07 09:51:39

4on6
Member
Registered: 2011-10-05
Posts: 166

[SOLVED] No more UTF-8 on Console?

After upgrading yesterday, I see that, on the console, the German Umlaute ä,ü,ö as well as ß are not printed anymore in the output but replaced by some strange symbols (while I'm still able to type them).

Also the delimiters of tmux windows have turned into some special symbols.

On X11, everything seems allright though.

I guess, this is related to the changes around rc.conf, but I don't know in what way.

Last edited by 4on6 (2012-08-07 18:24:13)

Offline

#2 2012-08-07 10:35:22

stlarch
Member
From: hell
Registered: 2010-12-25
Posts: 1,250

Re: [SOLVED] No more UTF-8 on Console?

You can still use your old rc.conf.

Offline

#3 2012-08-07 10:41:37

4on6
Member
Registered: 2011-10-05
Posts: 166

Re: [SOLVED] No more UTF-8 on Console?

stlarch wrote:

You can still use your old rc.conf.

Ok, I will move rc.conf.pacnew to ~/junk before shutting down next time to see if the strange symbols still appear after booting again.

Offline

#4 2012-08-07 10:56:07

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: [SOLVED] No more UTF-8 on Console?

It could be related to DAEMON_LOCALE : https://bbs.archlinux.org/viewtopic.php?id=145829

Offline

#5 2012-08-07 11:31:25

4on6
Member
Registered: 2011-10-05
Posts: 166

Re: [SOLVED] No more UTF-8 on Console?

karol wrote:

It could be related to DAEMON_LOCALE : https://bbs.archlinux.org/viewtopic.php?id=145829

In my old rc.conf I find:

DAEMON_LOCALE="no"

so it might well be the reason, have to try it out when rebooting.
Where would this be configured in the new config files?

Offline

#6 2012-08-07 17:05:07

tomegun
Developer
From: France
Registered: 2010-05-28
Posts: 661

Re: [SOLVED] No more UTF-8 on Console?

This issue is likely not related to the config file change. We simply have an issue with DAEMON_LOCALE. We have been trying out different ways of handling it and every time a new bug appears. I'll likely have to revamp the whole thing for the next release. To get utf-8 console, set an utf-8 locale and set DAEMON_LOCALE=yes. This means that also your bootmessages will be in your locale (which is the other issue we have been struggling with).

Offline

#7 2012-08-07 18:23:56

4on6
Member
Registered: 2011-10-05
Posts: 166

Re: [SOLVED] No more UTF-8 on Console?

tomegun wrote:

This issue is likely not related to the config file change. We simply have an issue with DAEMON_LOCALE. We have been trying out different ways of handling it and every time a new bug appears. I'll likely have to revamp the whole thing for the next release.

Ok, since this is (at least for me) not really a critical issue, I could just leave my settings and wait for the next release to get the former behaviour again - right?

So I will mark this thread a solved - thanks for the help.

Offline

#8 2012-08-08 08:39:25

Thanoulis
Member
From: Thessaloniki, Greece
Registered: 2009-05-03
Posts: 31
Website

Re: [SOLVED] No more UTF-8 on Console?

I had the same problem (with Greek letters).
Here is my workaround:

~/.bash_profile (i use bash)

[[ -x /usr/bin/unicode_start && $(tty) = /dev/tty? ]] && unicode_start

That way, every time i load a new terminal console (not an X one) unicode characters appear as they should be.


-- Beware of he who would deny you access to information, for in his heart he dreams himself your master.

Offline

#9 2012-08-08 14:40:01

4on6
Member
Registered: 2011-10-05
Posts: 166

Re: [SOLVED] No more UTF-8 on Console?

@Thanoulis

Nice tip - thanks!

Offline

#10 2012-08-09 11:20:34

GordonGR
Member
From: Thessaloniki, Greece
Registered: 2011-11-07
Posts: 232

Re: [SOLVED] No more UTF-8 on Console?

Thanoulis, what font do you use for console? I have a lot of files with polytonic letters (eg. Ἡ μουσική μου) and those characters don't show.


Intel(R) Celeron(R) CPU E3400 @ 2.60GHz, 1878 MB, XFCE 4.12, x86_64. AURs.

“No one without the knowledge of geometry may enter.“ Plato.

Offline

#11 2012-08-10 07:33:53

Thanoulis
Member
From: Thessaloniki, Greece
Registered: 2009-05-03
Posts: 31
Website

Re: [SOLVED] No more UTF-8 on Console?

I don't use polytonic. After all, modern Greek language is monotonic.
My font is ter-v16b (community/terminus-font).


-- Beware of he who would deny you access to information, for in his heart he dreams himself your master.

Offline

#12 2012-08-12 11:04:48

RealGecko
Member
Registered: 2012-01-04
Posts: 29

Re: [SOLVED] No more UTF-8 on Console?

I had the same problem and solved it by commenting "DEAMON_LOCALE=no" in rc.conf. However it is not clear for me what was the source of the problem. I`m noob smile

Last edited by RealGecko (2012-08-12 11:06:19)

Offline

#13 2012-08-22 12:41:26

4on6
Member
Registered: 2011-10-05
Posts: 166

Re: [SOLVED] No more UTF-8 on Console?

[deleted - misunderstanding]

Last edited by 4on6 (2012-08-22 22:37:23)

Offline

Board footer

Powered by FluxBB