You are not logged in.

#1 2012-08-04 17:43:51

farnoy
Member
From: Poland
Registered: 2011-07-15
Posts: 11

GNOME Shell crashes periodically

Hello,

I've been having this problem for a month now, maybe more. It's not related to nvidia drivers, which caused shell to hang on Overlay -> Applications menu (like mentioned some time ago on this forum).

It happens after a while when I log in. Whether I'm just browsing web, coding, etc. or watching videos from hard drive with no other windows open. I think it's gnome shell's crash, since immediately after this crash occurs, i see my pointer in the top left corner and once again I see a gdm login screen. I can provide logs, but I don't know where gnome-shell logs this stuff. Tried searching /var/log/gdm but I found only some entries which to me looked like gdm searching for it's session in various locations, then finally found one but then reporting:

Aug  4 19:11:15 localhost gdm-simple-slave[23425]: WARNING: Child process 23462 was already dead.

I know the time of the last crash so I can probably extract something useful, but I need locations of logs.

Those are not fatal crashes, I just have to re-log and reopen all the windows.

Thanks.

Edit
Don't know if it's of any use, but I can run xbmc (or any other X session probably) for a long time with no problems.

Last edited by farnoy (2012-08-04 17:46:03)

Offline

#2 2012-08-13 16:31:30

farnoy
Member
From: Poland
Registered: 2011-07-15
Posts: 11

Re: GNOME Shell crashes periodically

Happens still after reinstalling whole system. I'm suspecting gnome-shell extensions now, but I have no idea how to use gjs or where to check for logs.

Offline

#3 2012-08-14 10:47:19

thebluesgnr
Member
Registered: 2012-04-02
Posts: 18

Re: GNOME Shell crashes periodically

If your entire session is crashing it means the culprit is either gnome-session or, much more likely, the Xorg server. Try investigating the Xorg logs in /var/log. When gnome-shell crashes it's automatically restarted by gnome-session.

Last edited by thebluesgnr (2012-08-14 10:47:52)

Offline

#4 2012-08-16 11:47:07

farnoy
Member
From: Poland
Registered: 2011-07-15
Posts: 11

Re: GNOME Shell crashes periodically

I'm very confused by this problem. At first I thought GDM was crashing, but now I've found these interesting lines in /var/log/errors.log (time matches recent crash)

Aug 16 13:21:43 localhost pulseaudio[1026]: [pulseaudio] bluetooth-util.c: org.bluez.Manager.ListAdapters() failed: org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 1
Aug 16 13:24:05 localhost pulseaudio[1143]: [pulseaudio] bluetooth-util.c: org.bluez.Manager.ListAdapters() failed: org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 1
Aug 16 13:24:06 localhost pulseaudio[1179]: [pulseaudio] pid.c: Daemon already running.

If it's bluez fault, then how do I turn it off permanently? I can't remove it, since gnome-shell depends on it. If I can't, then how do I order pulseaudio to stop looking for headsets or anything on bluetooth?

Offline

#5 2012-10-12 02:46:23

mpz
Member
Registered: 2010-10-14
Posts: 48

Re: GNOME Shell crashes periodically

farnoy wrote:

I'm very confused by this problem. At first I thought GDM was crashing, but now I've found these interesting lines in /var/log/errors.log (time matches recent crash)

Aug 16 13:21:43 localhost pulseaudio[1026]: [pulseaudio] bluetooth-util.c: org.bluez.Manager.ListAdapters() failed: org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 1
Aug 16 13:24:05 localhost pulseaudio[1143]: [pulseaudio] bluetooth-util.c: org.bluez.Manager.ListAdapters() failed: org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 1
Aug 16 13:24:06 localhost pulseaudio[1179]: [pulseaudio] pid.c: Daemon already running.

If it's bluez fault, then how do I turn it off permanently? I can't remove it, since gnome-shell depends on it. If I can't, then how do I order pulseaudio to stop looking for headsets or anything on bluetooth?

Bringing up from the dead because I encountered same problem.

Offline

Board footer

Powered by FluxBB