You are not logged in.

#1 2012-08-17 22:29:22

.:B:.
Forum Fellow
Registered: 2006-11-26
Posts: 5,819

[Systemd] Disable pesky warning beep :(

So. After the devs decided that they'd move to systemd, I dove in and installed systemd on my laptop. Configuration is nearly done, but one thing keeps bugging me: that annoying system beep. I thought pcspkr had gotten loaded somehow, but lsmod says it's not. Yet I get tons of those annoying beeps (e.g. if Firefox wants me to know that some word I'm searching for on a web page is not there).

So how do I turn this off with systemd?

I feel like I'm back running on a Pentium, somehow. Cue Weird Al Yankovich.

Last edited by .:B:. (2012-08-17 22:30:45)


Got Leenucks? :: Arch: Power in simplicity :: Get Counted! Registered Linux User #392717 :: Blog thingy

Offline

#2 2012-08-17 23:37:55

ataraxia
Member
From: Pittsburgh
Registered: 2007-05-06
Posts: 1,537

Re: [Systemd] Disable pesky warning beep :(

Is it actually ringing the system bell? I don't know how you turned it off previously, but I'd suggest either "xset -b" in .xinitrc, or just muting the ALSA control called "Beep" (if you have it).

Offline

#3 2012-08-18 09:24:22

.:B:.
Forum Fellow
Registered: 2006-11-26
Posts: 5,819

Re: [Systemd] Disable pesky warning beep :(

Thanks, will check that. Previously just blacklisting/unloading the pcspkr module did the trick.

Edit: xset -b seems to work. I wonder how switching to systemd causes that behaviour... I just muted the Beep control as well, going to see how that plays out.

I did see that stuff in the wiki, but I figured since it had been disabled before, it wouldn't work. Should have tried tongue.


Got Leenucks? :: Arch: Power in simplicity :: Get Counted! Registered Linux User #392717 :: Blog thingy

Offline

#4 2012-08-19 21:02:03

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: [Systemd] Disable pesky warning beep :(

I found that

setterm -blength 0

was more effective than xset -b. However, it doesn't kill the insanely annoying visual bell in screen.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#5 2012-10-09 21:20:36

Dolmio
Member
Registered: 2012-10-09
Posts: 4

Re: [Systemd] Disable pesky warning beep :(

Same thing happend to me after switching to systemd. Annoying, loud beeps all the time (including at boot).

amixer set 'Beep' 0% mute

did the trick for me. No more annoying beeps but the sound still works in xfce :-)

Offline

#6 2012-10-14 10:47:30

graysky
Member
From: /run/user/1000
Registered: 2008-12-01
Posts: 8,524
Website

Re: [Systemd] Disable pesky warning beep :(

Gone are the days of blacklisting pcspkr I guess hmm

On my laptop, in multi-user not graphical I still get a loud as hell beep.

Last edited by graysky (2012-10-14 10:48:10)


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

Board footer

Powered by FluxBB