You are not logged in.

#1 2012-08-18 10:08:55

karabaja4
Member
From: Croatia
Registered: 2008-09-14
Posts: 848

Urbanterror problems since 4.2 update

Since Urbanterror was updated to 4.2, a bunch of custom Arch patches in the package have been dropped. Related to that or not, some problems were introduced:

1) there is no UI visible in the game showing HP, ammo and radar.
2) There is a delay when firing a weapon, especially noticable when simultaneously running and firing a Remington SR8 sniper.

Anyone knows a solution to this?


pie!

Offline

#2 2012-08-18 10:26:01

grimi
Member
Registered: 2009-12-27
Posts: 26

Re: Urbanterror problems since 4.2 update

Hi.
1) edid ~/.q3a/q3ut4/q3config.cfg, and change cg_draw2D to "1"
2) sad ...
Regards

Offline

#3 2012-08-18 10:36:31

Psykorgasm
Member
From: England, UK
Registered: 2011-11-24
Posts: 158

Re: Urbanterror problems since 4.2 update

4.2 is a beta, use it at your own risk smile

I also see that 4.1 has been removed as if 4.2 is an update to 4.1 in the Arch packages... this should not have been done imo, both should be available.

Offline

#4 2012-08-19 00:25:40

pierrebe
Member
Registered: 2012-08-19
Posts: 4

Re: Urbanterror problems since 4.2 update

Hi. Thanks Grimi
The police is horrible. Do you know if it's possible to do it better?

Last edited by pierrebe (2012-08-19 00:27:48)

Offline

#5 2012-08-19 04:13:01

Svenstaro
Developer
From: Germany
Registered: 2008-11-19
Posts: 366

Re: Urbanterror problems since 4.2 update

If you guys have suggestion on how I should package urbanterror, why do you put it on the forums where I will unlikely see it (though I did)? Why not post a bug report?

My reasoning for updating it over 4.1 is that they know feature 4.2 as THE release even though it is beta. They don't say: "This is 4.2, it's beta, don't use it, use 4.1 instead." They actually dropped the links to 4.1. I figured this means that 4.2 is to be preferred. I'm sorry if this is causing you guys trouble but I'm basically just rolling with upstream (UrT devs) here.

I think you should likely delete your old configuration in order to fix problems. Also, the Arch patches were dropped because they are now supplying their own openly developed and well-supported version of ioquake directly from: https://github.com/Barbatos/ioq3-for-UrbanTerror-4

The patching was horrible and now it's not necessary anymore. Overall, I'm fairly happy with 4.2.

If you think there is a problem with that, report a bug.

Things that are not packaging bugs but bugs with the game should reported directly to the devs, of course!

Offline

#6 2012-08-19 15:33:47

pierrebe
Member
Registered: 2012-08-19
Posts: 4

Re: Urbanterror problems since 4.2 update

Hallo Sventaro.
Habe ich richtig verstanden? Du hast Urbanterror from  https://github.com/Barbatos/ioq3-for-UrbanTerror-4 installiert. Wenn Ja kannst du bitte mir sagen was ich machen soll. Danke

Offline

#7 2012-08-19 23:33:44

Svenstaro
Developer
From: Germany
Registered: 2008-11-19
Posts: 366

Re: Urbanterror problems since 4.2 update

Keep it English. Also, actually read what I wrote.

Offline

#8 2012-08-20 00:16:58

karabaja4
Member
From: Croatia
Registered: 2008-09-14
Posts: 848

Re: Urbanterror problems since 4.2 update

I was hesistant to report a bug that might be something specfic to UrT and not Arch.

Svenstaro, you didn't anwser if you experience the bug number 2) from the first post? Do you play the game?

grimi's solution worked for 1), but 2) remains. It could very well be an UrT issue...


pie!

Offline

#9 2012-08-20 00:35:00

Svenstaro
Developer
From: Germany
Registered: 2008-11-19
Posts: 366

Re: Urbanterror problems since 4.2 update

I do not get a delay. I do get the missing 2D elements (GUI) on a clean .urbanterror dir though.

Offline

#10 2012-08-20 18:01:04

andre.vmatos
Member
Registered: 2010-07-28
Posts: 19

Re: Urbanterror problems since 4.2 update

Thnx, @grimi, resolved 1) here too.
But I have another bug: at x86_64, I can't log in with urbanterror.info authkey. In i686, inserting my authkey into UT interface, or editing ~/.q3a/q3ut4/authkey give me a message at UT home screen, telling me I'm logged at urbanterror credentials, but in x86_64, there's no message, and terminal are filled with tons of this message:

--------------------------------------
------ Urban Terror Auth System ------
--------------------------------------
------ Urban Terror Auth System ------
--------------------------------------
------ Urban Terror Auth System ------
auth: the authserver can't be contacted.
--------------------------------------
------ Urban Terror Auth System ------
--------------------------------------
------ Urban Terror Auth System ------
--------------------------------------

Offline

#11 2012-08-20 19:32:03

Svenstaro
Developer
From: Germany
Registered: 2008-11-19
Posts: 366

Re: Urbanterror problems since 4.2 update

If you check their forums you will find that this is an extremely common problem on x86_64.

Offline

#12 2012-08-23 08:37:09

using_GNU
Member
Registered: 2012-07-30
Posts: 32

Re: Urbanterror problems since 4.2 update

Well it works very well on my 64 bit system.

Did you update the urbanterror-data package?

because you must update urbanterror and urbanterror-data in order to make it work.

Last edited by using_GNU (2012-08-23 08:37:50)

Offline

Board footer

Powered by FluxBB