You are not logged in.

#1 2010-05-06 01:20:47

cbwcjw
Member
Registered: 2010-05-06
Posts: 5

SLiM Keyboard Layout

Hello! I am a dvorak user with a fresh install of arch, and I have installed X11, etc all with the dvorak key layout. However, the SLiM login manager does not have any visible means of changing it's layout, causing it to feel terribly inconsistent.

Is anyone aware of how to change the keyboard layout in SLiM?

Offline

#2 2010-05-07 13:21:04

cbwcjw
Member
Registered: 2010-05-06
Posts: 5

Re: SLiM Keyboard Layout

I didnt want to bump, but its been more than a day.

Offline

#3 2010-05-07 21:32:44

joe.koenig
Member
Registered: 2010-05-06
Posts: 13

Re: SLiM Keyboard Layout

Don't know about the "SLiM login manager".  Is it essential for you to be able to choose the layout from within the login manager?  You might as well change the layout anytime you want from within a running Xorg-session. e.g.:

$ setxkbmap some_layout_whatsoever

If your loginmanager supports it, you should be able to specify all possible layout options via /usr/share/X11/xkb/rules/evdev.xml.  The layouts itself are located in /usr/share/X11/xkb/symbols.

Further reading:
http://wiki.archlinux.org/index.php/Xor … d_settings
http://people.uleth.ca/~daniel.odonnell … n-linuxx11


What I did myself is this: I had a custom keyboard layout (with german umlauts) laid down.  After installing ArchLinux with the default "us" layout I replaced that one with my custom us_de layout.  Then I included the default "us".  e.g.:

    xkb_symbols "us_de" {
        include "us.backup"

that way I didn't have to fool around with evdev.xml.  Oh, disclaimer: make backups wink

Offline

#4 2010-05-09 19:09:29

cbwcjw
Member
Registered: 2010-05-06
Posts: 5

Re: SLiM Keyboard Layout

The issue with this is that SLiM is different from X. The layout is already dvorak in X11 and setxkbmap dvorak is run in the .xinitrc file. I can't figure out how to change the layout of the actual login manager.

Offline

#5 2010-05-10 01:38:28

rockin turtle
Member
From: Montana, USA
Registered: 2009-10-22
Posts: 218

Re: SLiM Keyboard Layout

Try editing the /etc/slim.conf file to set the command line arguments to the Xorg server.

    xserver_arguments -layout dvorak

I don't know if this will work or not.

Offline

#6 2010-05-10 10:09:41

jib2
Member
From: Paris, France
Registered: 2009-08-13
Posts: 85

Re: SLiM Keyboard Layout

I had the same problem: keyboard layout would fall back to qwerty in SLiM instead of azerty.
The reason was there was a typo in my /etc/hal/fdi/policy/10-keymap.fdi

Maybe you could post the file here so it could be double-checked.

Offline

#7 2010-05-12 11:20:17

Bonzodog
Member
From: Leicester, UK
Registered: 2008-02-14
Posts: 106

Re: SLiM Keyboard Layout

I use SLiM, and it uses my dvorak layout. That is only specified in two places - the fdi file, as pointed to in the post above, and in my /etc/rc.conf.

The problem is probably in your /etc/hal/fdi/policy/10-keymap.fdi . This is mine:

<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keymap">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
    </match>

    <match key="info.capabilities" contains="input.keys">
      <merge key="input.xkb.rules" type="string">base</merge>

      <!-- If we're using Linux, we use evdev by default (falling back to
           keyboard otherwise). -->
      <merge key="input.xkb.model" type="string">keyboard</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.xkb.model" type="string">evdev</merge>
      </match>

      <merge key="input.xkb.layout" type="string">dvorak</merge>
      <merge key="input.xkb.variant" type="string">gb</merge>
    </match>
  </device>
</deviceinfo>

Offline

#8 2010-05-24 02:51:09

cbwcjw
Member
Registered: 2010-05-06
Posts: 5

Re: SLiM Keyboard Layout

<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keymap">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
    </match>

    <match key="info.capabilities" contains="input.keys">
      <merge key="input.xkb.rules" type="string">base</merge>

      <!-- If we're using Linux, we use evdev by default (falling back to
           keyboard otherwise). -->
      <merge key="input.xkb.model" type="string">keyboard</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.xkb.model" type="string">evdev</merge>
      </match>

      <merge key="input.xkb.layout" type="string">dvorak</merge>
      <merge key="input.xkb.variant" type="string">us</merge>
    </match>
  </device>
</deviceinfo>

Here's this, Still no luck.

Offline

#9 2010-05-24 05:58:12

jib2
Member
From: Paris, France
Registered: 2009-08-13
Posts: 85

Re: SLiM Keyboard Layout

Is hal running ?

Offline

#10 2010-05-24 21:33:15

dubzii
Member
Registered: 2010-05-13
Posts: 4

Re: SLiM Keyboard Layout

you should change the layout value to 'us' and the variant to 'dvorak' instead of the other way around. Or at least, that's how i got Colemak running in SLiM.

Offline

#11 2010-05-25 01:58:21

cbwcjw
Member
Registered: 2010-05-06
Posts: 5

Re: SLiM Keyboard Layout

jib2 wrote:

Is hal running ?

Almost Positive. It's under Daemons.

dubzii wrote:

you should change the layout value to 'us' and the variant to 'dvorak' instead of the other way around. Or at least, that's how i got Colemak running in SLiM.

Did that, no luck.

Last edited by cbwcjw (2010-05-25 01:58:50)

Offline

#12 2010-06-23 18:49:28

KBM
Member
From: Guadalajara, Jal
Registered: 2010-05-18
Posts: 11

Re: SLiM Keyboard Layout

I had the same problem with SLIM. Left my /etc/hal/fdi/policy/10-keymap.fdi as it was, I have latinamerican layout, so the line in 10-keymap.fdi would look something like this:

<merge key="input.xkb.layout" type="string">latam</merge>
 <merge key="input.xkb.variant" type="string" />

The magic was in /etc/X11/xorg.conf.d/10-evdev.conf
There is a particular section to change, this is my configuration

Section "InputClass"
        Identifier "evdev keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        
        # Keyboard layouts
        Option "XkbLayout" "latam"
EndSection

Found the solution here
http://wiki.archlinux.org/index.php/Xor … evdev.conf
http://pastebin.com/raw.php?i=4mPY35Mw

Hope this helps!

Last edited by KBM (2010-06-23 19:05:28)

Offline

#13 2010-06-26 02:53:40

DeltaXFX
Member
From: USA
Registered: 2006-08-01
Posts: 74

Re: SLiM Keyboard Layout

I was having the same problem with slim after my last update. KBM's post fixed it!


The Internet...? Is that thing still around?

Offline

#14 2010-12-24 14:38:03

Kielo
Member
Registered: 2010-08-28
Posts: 29

Re: SLiM Keyboard Layout

Thanks to KBM, worked fine for me smile

Offline

#15 2011-05-01 09:22:58

Gnux
Member
Registered: 2006-09-27
Posts: 26

Re: SLiM Keyboard Layout

Hi
Many thx KBM, works fine for me smile

Offline

#16 2012-08-18 19:38:38

I.M.O.G.
Member
Registered: 2009-10-16
Posts: 16

Re: SLiM Keyboard Layout

KBM's fix worked for me too, thanks.

Offline

#17 2012-08-18 23:37:11

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,115

Re: SLiM Keyboard Layout

Okay.  For the last 2 years KBM's fix worked with no new details or problems.

Time to close the topic.
https://wiki.archlinux.org/index.php/Fo … Bumping.22


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Offline

Board footer

Powered by FluxBB