You are not logged in.

#1 2005-09-24 22:33:16

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Totem-xine 1.2.0 cannot start

When I try to start totem-xine from the Testing repo, it exits a few seconds after starting, with a vague error message to the effect that it couldn't be started. Anyone else have this problem?

Offline

#2 2005-09-25 00:10:38

keevn7
Member
From: Lancaster, OH, US
Registered: 2005-06-09
Posts: 206
Website

Re: Totem-xine 1.2.0 cannot start

Well... it is in the testing repository.... tongue I would test it to see if it did the same to me, but I would rather not shift to testing to try it. So I will just say that you should post the exact output, to get the help thing started. wink

Offline

#3 2005-09-25 00:24:09

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: Totem-xine 1.2.0 cannot start

From the terminal:

[proteus@localhost ~]$ totem

(totem:11499): libglade-WARNING **: could not find widget creation function

(totem:11499): libglade-WARNING **: could not find widget creation function

(totem:11499): libglade-WARNING **: could not find widget creation function

(totem:11499): GLib-GObject-WARNING **: gsignal.c:1716: signal `value-changed' is invalid for instance `0x81c0f68'

(totem:11499): GLib-GObject-WARNING **: invalid cast from `GtkLabel' to `BaconVolumeButton'

(totem:11499): Gtk-CRITICAL **: gtk_range_set_value: assertion `GTK_IS_RANGE (range)' failed

(totem:11499): GLib-GObject-WARNING **: invalid cast from `GtkLabel' to `BaconVolumeButton'

(totem:11499): Gtk-CRITICAL **: gtk_range_set_value: assertion `GTK_IS_RANGE (range)' failed

(totem:11499): GLib-GObject-WARNING **: invalid cast from `GtkLabel' to `TotemStatusbar'

** (totem:11499): CRITICAL **: totem_statusbar_set_time_and_length: assertion `TOTEM_IS_STATUSBAR (statusbar)' failed

(totem:11499): GLib-GObject-WARNING **: invalid cast from `GtkLabel' to `TotemStatusbar'

The GUI's error message:

The Application "totem" has quit unexpectedly.

You can inform the developers of what happened to help them fix it.  Or you can restart the application right now.

The above accompanied by 'Restart' and 'Close' buttons of course.

Offline

#4 2005-09-25 03:10:55

omgpro
Member
From: Connecticut USA
Registered: 2005-08-26
Posts: 42

Re: Totem-xine 1.2.0 cannot start

are you all synchronized with the testing repo? i tried using testing once, updated everything, and then just ended up having problems and realized it wasn't worth it. had to individially revert everything i updated to it's old version.  anyways, testing tends to be pretty buggy a lot of the time, i doubt there's much you can do except report it and wait....

Offline

#5 2005-09-25 06:19:00

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: Totem-xine 1.2.0 cannot start

From the error message, it looks like an upstream issue. Maybe totem-xine has problem with latest gtk.  Check the (Arch) bug tracker to see if it has been reported.

Offline

#6 2005-09-25 17:22:36

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: Totem-xine 1.2.0 cannot start

Switched back to Current.

(There ought to be a new dev team in charge of Current... Some packages really, really need to be updated.)

Offline

#7 2005-09-25 19:51:40

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: Totem-xine 1.2.0 cannot start

I think that the problem is that you cannot switch back and forth from testing to current easily.  Unless, you have 2 systems or (unlikely ) 2 AL installs on one system. Probably all the dev with 1 system have switched to the testing repo to do the gcc4/libtool stuff, hence they cannot build any package for the stable repos.

Offline

#8 2005-09-25 20:30:41

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: Totem-xine 1.2.0 cannot start

No, I mean that I did the copy-format-reinstall shuffle. I had a system that used the Testing repo, and now I've got one that uses Current. When I had this problem with totem-xine, I was using Testing, had not at any point disabled the Testing repo, and had in fact enabled the Testing repo and updated from it immediately after installation.

Offline

#9 2005-09-25 20:45:37

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: Totem-xine 1.2.0 cannot start

I was referring to:

Gullible Jones wrote:

(There ought to be a new dev team in charge of Current... Some packages really, really need to be updated.)

Sorry for not being very clear.  I wanted to point out  a possible reason why, for example, there was a  "security-fixed" firefox 1.07 in the testing repo but no "security-fixed" firefox 1.07 in the current repo for peple not using testing.
It's possible to go from testing to current but I don't think a dev will go from testing to current to build a package for current and then upgrade to testing to continue with  the gcc4/libtool stuff.

Offline

#10 2005-09-25 23:01:39

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: Totem-xine 1.2.0 cannot start

Ahh, yes... You'd be correct. Thus separate teams for Testing and Current.

(A better solution would probably to switch everything over to GCC 4, and then do libtool-slay... Might take a bit longer, but would prevent Current from stagnating.)

Offline

#11 2005-09-25 23:33:47

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: Totem-xine 1.2.0 cannot start

Gullible Jones wrote:

Ahh, yes... You'd be correct. Thus separate teams for Testing and Current.

There is still some activity in current/extra so I assume some dev still have current. I think Arch doesn't have enough dev to make 2 separate teams.  And a lot of packages go to current/extra without going to testing first.

Gullible Jones wrote:

(A better solution would probably to switch everything over to GCC 4, and then do libtool-slay... Might take a bit longer, but would prevent Current from stagnating.)

Maybe they wanted to do the 2 things at the same time as most packages were already in testing. Maybe the libtool slay is taking more time than they originally thought and they are asking themselves the same question: "Why didn't we moved gcc4 to current before libtool-slay?", but now, it's too late to go back.

Offline

#12 2005-09-28 22:02:27

JGC
Developer
Registered: 2003-12-03
Posts: 1,659

Re: Totem-xine 1.2.0 cannot start

Plans are to move the whole testing stuff to current/extra next week smile
In fact, this whole stuff in testing is more than just operation libtool-slay and GCC 4.0:

- new QT that forced recompilation of most KDE stuff
- new GNOME
- new KDE release
- structural changes in KDE
- firefox/mozilla/thunderbird updates

Next step on the todo list is Xorg modularization, but that will be backwards compatible, so we can move everything safely to current/extra before that.

Offline

#13 2005-09-28 23:07:43

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: Totem-xine 1.2.0 cannot start

JGC wrote:

Plans are to move the whole testing stuff to current/extra next week

Kick ass. :twisted:

n fact, this whole stuff in testing is more than just operation libtool-slay and GCC 4.0:

- new QT that forced recompilation of most KDE stuff
- new GNOME
- new KDE release
- structural changes in KDE
- firefox/mozilla/thunderbird updates

Oh... forgot about the whole business with KDE. :oops: Explains a lot, that.

Offline

#14 2005-09-30 06:32:22

kasa
Member
From: Italy
Registered: 2005-07-21
Posts: 48

Re: Totem-xine 1.2.0 cannot start

JGC wrote:

Plans are to move the whole testing stuff to current/extra next week smile
In fact, this whole stuff in testing is more than just operation libtool-slay and GCC 4.0:

- new QT that forced recompilation of most KDE stuff
- new GNOME
- new KDE release
- structural changes in KDE
- firefox/mozilla/thunderbird updates

Next step on the todo list is Xorg modularization, but that will be backwards compatible, so we can move everything safely to current/extra before that.

Great news !!! 8)

Offline

#15 2005-10-02 03:29:35

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: Totem-xine 1.2.0 cannot start

I had an epiphany when testing out the new version of Epihany(!). Remember my old AUR build of totem-xine 1.1.x? Well, that depended on iso-codes. I'll bet that totem-xine 1.2.x still needs that package!

Edit: Nope, that ain't the problem. Too bad... :?

Offline

#16 2005-10-02 21:10:30

ozar
Member
From: USA
Registered: 2005-02-18
Posts: 1,681

Re: Totem-xine 1.2.0 cannot start

Fresh install from current/extra repo here, and I'm getting the same errors as you, Gullible.  It starts, then goes away within a second, or two:

(totem:6892): libglade-WARNING **: could not find widget creation function

(totem:6892): libglade-WARNING **: could not find widget creation function

(totem:6892): libglade-WARNING **: could not find widget creation function

(totem:6892): GLib-GObject-WARNING **: gsignal.c:1716: signal `value-changed' is invalid for instance `0x81abb78'

(totem:6892): GLib-GObject-WARNING **: invalid cast from `GtkLabel' to `BaconVolumeButton'

(totem:6892): Gtk-CRITICAL **: gtk_range_set_value: assertion `GTK_IS_RANGE (range)' failed

(totem:6892): GLib-GObject-WARNING **: invalid cast from `GtkLabel' to `BaconVolumeButton'

(totem:6892): Gtk-CRITICAL **: gtk_range_set_value: assertion `GTK_IS_RANGE (range)' failed

(totem:6892): GLib-GObject-WARNING **: invalid cast from `GtkLabel' to `TotemStatusbar'

** (totem:6892): CRITICAL **: totem_statusbar_set_time_and_length: assertion `TOTEM_IS_STATUSBAR (statusbar)' failed

(totem:6892): GLib-GObject-WARNING **: invalid cast from `GtkLabel' to `TotemStatusbar'

===================================

Edit:  Found a bug report number and details:

http://bugs.archlinux.org/index.php?id=3179&do=details


oz

Offline

Board footer

Powered by FluxBB