You are not logged in.

#1 2012-08-27 09:24:30

gonX
Member
From: Denmark
Registered: 2009-08-16
Posts: 108

[SOLV] NetworkManager 0 bars, iwconfig unassociated. Still ok. Systemd

Hey guys,

I have a Lenovo L530 with a Realtek RTL8188CE WiFi adapter. It works at times, but lately after I've switched to the testing repo, NM reports that it's still connected, but it does not show any connection strength.
It's not such a huge issue, but when I use iwconfig it tells me that it's unassociated (which is weird since I'm typing this on the connection right now). I'm connected to a 802.11x network if it makes any difference. It uses TTLS+PAP.

The device in question:

06:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter [10ec:8176] (rev 01)

Here's a pastie:
https://gist.github.com/3486874 (disregard the omitted data. I realize I didn't get all of it)

I use systemd.

Anyone who can help resolve this? Basically I can't see signal strength, which I suppose doesn't really matter since I always sit at the same spot in class, but it's convenient whenever I'm troubleshooting connection issues.

Thanks

*EDIT*

SOLUTION: This is a systemd-specific issue, and happens once you convert to systemd (pure or not). The solution is to disable network.service:

systemctl disable network.service

Last edited by gonX (2012-08-27 11:20:10)


since 2009

Offline

#2 2012-08-27 09:42:05

d33n
Member
From: The Netherlands
Registered: 2010-12-06
Posts: 8

Re: [SOLV] NetworkManager 0 bars, iwconfig unassociated. Still ok. Systemd

I ran into a similar problem, after the last initscripts update.
After checking systemd by using systemctl, I saw a network.service and the NetworkManager.service running.
after disabling network.service and removing initscripts everything worked as intended.

Offline

#3 2012-08-27 11:09:49

gonX
Member
From: Denmark
Registered: 2009-08-16
Posts: 108

Re: [SOLV] NetworkManager 0 bars, iwconfig unassociated. Still ok. Systemd

Thanks, that solved it. All I did was:

systemctl disable network.target
systemctl stop network.target

and rebooted. Once rebooted, the bars were showing again, and my network performance even increased smile It seems like I was limited to ~200kB/s before, but now it's just pulling whatever it can.

Thanks!


since 2009

Offline

Board footer

Powered by FluxBB