You are not logged in.

#1 2012-08-28 14:48:57

blackout23
Member
Registered: 2011-11-16
Posts: 780

XFCE4 Custom Window decoration messed up

Hello,

I'm using the exact same setup and packages on my laptop without problems. Every custom theme for XFCE
that I install ends up with incomplete title bar. This is a fresh arch install. Anyone has an idea on how to fix this?

Kind regards,

blackout23

tepaa9zs.png

Offline

#2 2012-08-28 14:56:45

oboedad55
Member
From: Baku
Registered: 2011-04-05
Posts: 389

Re: XFCE4 Custom Window decoration messed up

blackout23 wrote:

Hello,

I'm using the exact same setup and packages on my laptop without problems. Every custom theme for XFCE
that I install ends up with incomplete title bar. This is a fresh arch install. Anyone has an idea on how to fix this?

Kind regards,

blackout23

http://s14.directupload.net/images/120828/temp/tepaa9zs.png

I'm having the same issue using the Greybird theme. The strange thing is that this was working a few days ago, but after a new install of Xfce I've now got the same problem.


Registered Linux user #436067

Offline

#3 2012-08-28 17:56:51

Usul
Member
Registered: 2007-05-17
Posts: 31

Re: XFCE4 Custom Window decoration messed up

Same here, but I didn't install anything, just did a simple update (yaourt -Syua) yesterday. This packages were updated:

[2012-08-27 17:52] starting full system upgrade
[2012-08-27 17:52] upgraded gc (7.2-1 -> 7.2.c-1)
[2012-08-27 17:52] upgraded hspell (1.1-2 -> 1.2-1)
[2012-08-27 17:52] upgraded hwids (20120730-1 -> 20120815-1)
[2012-08-27 17:52] upgraded initscripts (2012.08.2-1 -> 2012.08.3-1)
[2012-08-27 17:52] upgraded libatasmart (0.18-2 -> 0.19-1)
[2012-08-27 17:52] upgraded libgssglue (0.3-1 -> 0.4-1)
[2012-08-27 17:52] upgraded udisks (1.0.4-4 -> 1.0.4-5)
[2012-08-27 17:52] upgraded xorg-server-common (1.12.3.901-1 -> 1.12.4-1)
[2012-08-27 17:52] upgraded xorg-server (1.12.3.901-1 -> 1.12.4-1)
[2012-08-27 17:52] upgraded xorg-server-xvfb (1.12.3.901-1 -> 1.12.4-1)

Maybe the xorg-packages are in charge? I've choosen the easy way, selecting another theme smile

Offline

#4 2012-08-28 18:08:52

z0id
Member
From: Romania
Registered: 2010-02-02
Posts: 121

Re: XFCE4 Custom Window decoration messed up

Same here with elementary theme. I think a bug report is in order.
EDIT: FS#31323

Last edited by z0id (2012-08-28 18:19:17)


/usr/bin/drinking

Offline

#5 2012-08-28 19:27:01

sbfreak
Member
Registered: 2010-06-06
Posts: 149

Re: XFCE4 Custom Window decoration messed up

Older xfwm themes and the default one seem to work fine.

Offline

#6 2012-08-28 20:04:27

blackout23
Member
Registered: 2011-11-16
Posts: 780

Re: XFCE4 Custom Window decoration messed up

OK now I have the same on my Laptop after rebooting it for the first time in a few days.

My lasts updates

[2012-08-27 18:53] starting full system upgrade
[2012-08-27 18:53] upgraded hspell (1.1-2 -> 1.2-1)
[2012-08-27 18:53] upgraded libatasmart (0.18-2 -> 0.19-1)
[2012-08-27 18:53] upgraded libgssglue (0.3-1 -> 0.4-1)
[2012-08-27 18:53] upgraded systemd-arch-units (20120704-2 -> 20120704-5)
[2012-08-27 18:53] upgraded udisks (1.0.4-4 -> 1.0.4-5)
[2012-08-27 18:53] upgraded xorg-server-common (1.12.3.901-1 -> 1.12.4-1)
[2012-08-27 18:53] upgraded xorg-server (1.12.3.901-1 -> 1.12.4-1)

I also think that it's caused by the xorg update. Anything else would not make any sense.
Anyone has the previous package still and can try a downgrade?

Last edited by blackout23 (2012-08-28 20:11:48)

Offline

#7 2012-08-28 20:18:23

AaronBP
Member
Registered: 2012-08-06
Posts: 142
Website

Re: XFCE4 Custom Window decoration messed up

I'm using the latest packages and am not seeing this issue. What drivers are you guys using?

Offline

#8 2012-08-28 20:43:46

oboedad55
Member
From: Baku
Registered: 2011-04-05
Posts: 389

Re: XFCE4 Custom Window decoration messed up

AaronBP wrote:

I'm using the latest packages and am not seeing this issue. What drivers are you guys using?

I'm using Nvidia GT430 with driver 304.43-1. I don't think it's the driver as I had the same problem with the previous one.


Registered Linux user #436067

Offline

#9 2012-08-28 21:25:32

AaronBP
Member
Registered: 2012-08-06
Posts: 142
Website

Re: XFCE4 Custom Window decoration messed up

May be that the latest Xorg changed the ABI some. I remember reading something about that recently. Try Nouveau.

Last edited by AaronBP (2012-08-28 21:26:37)

Offline

#10 2012-08-28 22:12:02

blackout23
Member
Registered: 2011-11-16
Posts: 780

Re: XFCE4 Custom Window decoration messed up

Indeed everything works with nouveau.
I was also using the latest NVIDIA Driver.

EDIT: Just filled a bug report at Nvidia.

Last edited by blackout23 (2012-08-28 22:21:08)

Offline

#11 2012-08-30 02:47:39

futuremonkey
Member
Registered: 2009-02-28
Posts: 49

Re: XFCE4 Custom Window decoration messed up

Same problem here, recent update of the nvidia driver seems to be the common element.

Offline

#12 2012-08-30 02:48:50

oboedad55
Member
From: Baku
Registered: 2011-04-05
Posts: 389

Re: XFCE4 Custom Window decoration messed up

Mine seems to be fixed, am using the greybird theme and it looks normal after today's updates.


Registered Linux user #436067

Offline

#13 2012-08-30 08:56:14

blackout23
Member
Registered: 2011-11-16
Posts: 780

Re: XFCE4 Custom Window decoration messed up

oboedad55 wrote:

Mine seems to be fixed, am using the greybird theme and it looks normal after today's updates.

What was updated? Could you post your pacman.log?

Nothing changed on my end.

Last edited by blackout23 (2012-08-30 09:14:13)

Offline

#14 2012-08-30 09:33:12

foutrelis
Developer/TU
From: Athens, Greece
Registered: 2008-07-28
Posts: 675
Website

Re: XFCE4 Custom Window decoration messed up

blackout23 wrote:
oboedad55 wrote:

Mine seems to be fixed, am using the greybird theme and it looks normal after today's updates.

What was updated? Could you post your pacman.log?

Nothing changed on my end.

A workaround was added to the greybird theme; the underlying bug remains: https://bugs.archlinux.org/task/31323

Offline

#15 2012-08-30 10:56:18

blackout23
Member
Registered: 2011-11-16
Posts: 780

Re: XFCE4 Custom Window decoration messed up

Ok so his update installed a new version of greybird theme. Only update for me today was glibc.

I'll try to patch my themes too as I don't think Nvidia will fix this very soon.

EDIT: Notified nvidia in my bug submission of the patches made by greybird theme, might help
them pin down what's wrong.

Last edited by blackout23 (2012-08-30 11:07:37)

Offline

#16 2012-08-30 18:06:57

onexused
Member
Registered: 2009-10-07
Posts: 55

Re: XFCE4 Custom Window decoration messed up

Here's the Xorg bug report: https://bugs.freedesktop.org/show_bug.cgi?id=54168 that linked me here.

Offline

#17 2012-09-01 12:05:39

soerenbnoergaard
Member
From: Denmark
Registered: 2012-09-01
Posts: 1
Website

Re: XFCE4 Custom Window decoration messed up

This problem CAN be fixed by stretching the 1 px wide image files for your theme (title-1-active.png for example) to 2 pixels in width.

Offline

Board footer

Powered by FluxBB