You are not logged in.

#1 2012-07-25 22:21:31

karol
Archivist
Registered: 2009-05-06
Posts: 25,424

[solved] DAEMON_LOCALE and UTF in tty

DAEMON_LOCALE=yes makes (among other things) part of the early boot localized and I don't want this.

Wed Jul 25 23:34:06 2012: :: Configuring virtual consoles    [BUSY] %G(K   [DONE] 
Wed Jul 25 23:34:06 2012: :: Bringing up loopback interface    [BUSY]    [DONE] 
Wed Jul 25 23:34:06 2012: :: Checking filesystems    [BUSY] /dev/sda1: czysty, 46/26208 plików, 24201/104420 bloków
Wed Jul 25 23:34:06 2012: /dev/sda4: czysty, 31003/1941504 plików, 5245297/7755378 bloków(sprawdzenie za 2 montowań)

I want English

Wed Jul 25 04:15:56 2012: :: Configuring virtual consoles    [BUSY] %@(K   [DONE] 
Wed Jul 25 04:15:56 2012: :: Bringing up loopback interface    [BUSY]    [DONE] 
Wed Jul 25 04:15:56 2012: :: Checking filesystems    [BUSY] /dev/sda1: clean, 46/26208 files, 24201/104420 blocks
Wed Jul 25 04:15:56 2012: /dev/sda4: clean, 28740/1941504 files, 5366267/7755378 blocks (check in 3 mounts)

Unfortunately with DAEMON_LOCALE=no I get garbage in the console (in tty, outside of X - inside X is fine) when drawing boxes and lines, e.g. 'pstree -U' or 'findmnt'.

https://bugs.archlinux.org/task/30228 is marked fixed, but https://bbs.archlinux.org/viewtopic.php?id=143433 [1], https://bbs.archlinux.org/viewtopic.php?id=143088 and probably a few others were OK with setting DAEMON_LOCALE=yes so I don't know if this is meant to be the fix?
I don't understand Tom's last comment: https://bugs.archlinux.org/task/30228#comment95966

No this will not work. Either everything has to be in an utf8 locale, or everything has to be in a non-utf8 locale.

What exactly do you mean by "everything"?


Part of rc.conf:

CONSOLEFONT="Lat2-Terminus16"
LOCALE="pl_PL.UTF-8"

running initscripts 2012.07.4-1, i915 inside the ramdisk (early KMS).


[1] I'm with Leonid.I on this one.

Last edited by karol (2012-08-29 20:56:33)

Offline

#2 2012-08-16 14:44:59

karol
Archivist
Registered: 2009-05-06
Posts: 25,424

Re: [solved] DAEMON_LOCALE and UTF in tty

Update:
https://bugs.archlinux.org/task/30228 has been reopened and Tom will try to fix this issue.

It's not a huge deal, but it's irritating ;P

Offline

#3 2012-08-29 20:56:13

karol
Archivist
Registered: 2009-05-06
Posts: 25,424

Re: [solved] DAEMON_LOCALE and UTF in tty

Seems to be fixed in initscripts 2012.08.3-2. See https://plus.google.com/114015603831160 … zKCcnTWDpa for details.

Thanks, Tom :-)

Offline

#4 2012-09-21 06:09:21

msx
Member
From: solar.system/earth/ar/bue/mdp
Registered: 2010-08-08
Posts: 184
Website

Re: [solved] DAEMON_LOCALE and UTF in tty

Oh man, I was going insane because this glitch! O_o  see here: http://mailman.archlinux.org/pipermail/ … 31099.html and here https://plus.google.com/u/0/photos/1117 … 8977532193.
Luckily the DAMEON_LOCALE="yes" did it - I'm gonna feed back to the bugtracker right now.

Last edited by msx (2012-09-21 06:20:01)


Enjoying i3wm w/ lifebar + j4-dmenu-desktop + tab_windows / fish shell / Emacs / tmux / Konsole / KDE apps
Arch + Linux-libre kernel: ParabolaGNULinux.org

Offline

Board footer

Powered by FluxBB