You are not logged in.

#1 2012-09-02 08:05:51

Ventil1
Member
Registered: 2010-03-17
Posts: 123

dhcpcd wlan0 err with udev enabled.OK with udev disabld but no carrier

I can not get wifi to work. I have a Intel Mini PCI 3945abg card. I tried

#modprobe iwl3945

and the drivr loads. But then when I want to

#netcfg "MyEssid

i get this:

iwlwifi-3945-2.ucode firmware file req failed: -2
iwlwifi-3945-1.ucode firmware file req failed: -2
Could not read microcode: -2
Could not set interface 'wlan0' flags: No such file or directory
nl80211: Could not set interface 'wlan0' UP

I searched all over google and arch forums but I didnt' find my answer.
I typed the output by hand cause I can not get my monitor to work either so I disabled udev. See my display topic here.

Last edited by Ventil1 (2012-09-28 18:06:14)

Offline

#2 2012-09-02 13:50:02

mosquitogang201
Member
Registered: 2012-06-19
Posts: 33

Re: dhcpcd wlan0 err with udev enabled.OK with udev disabld but no carrier

Are you sure disabling udev is the best thing to do? Per the wiki, udev automatically loads the driver.

https://wiki.archlinux.org/index.php/Wi … 000-series

On my computer using the same iwl3945 wireless card, all I had to do from the command line to make it work was:

wpa_passphrase NETWORKNAME "PASSWORD" > /etc/wifi.conf
ip link set wlan0 up
wpa_supplicant -i wlan0 -c /etc/wifi.conf -B
dhcpcd wlan0

This is for a WPA2 network so yours might be a little different. There was no special configuring after I got KDE installed - it just worked.

Offline

#3 2012-09-02 18:17:20

Ventil1
Member
Registered: 2010-03-17
Posts: 123

Re: dhcpcd wlan0 err with udev enabled.OK with udev disabld but no carrier

If I don't disable udev I can see anything on my monitor after boot. That's why it's disabled. See the topic about my display here..

Last edited by Ventil1 (2012-09-02 18:18:18)

Offline

#4 2012-09-18 17:16:03

Ventil1
Member
Registered: 2010-03-17
Posts: 123

Re: dhcpcd wlan0 err with udev enabled.OK with udev disabld but no carrier

It's been a month since I bought my new mini server components. I still don't have screen or wlan connection. I want to set at least wlan up. I don't really care about screen much.  Can someone help me please? I don't know what to do.

Offline

#5 2012-09-18 20:52:23

Wilco
Member
Registered: 2008-11-09
Posts: 431

Re: dhcpcd wlan0 err with udev enabled.OK with udev disabld but no carrier

Install linux-firmware:

pacman -S linux-firmware

Reload the wireless module and you should be good to go

Offline

#6 2012-09-19 06:17:53

Ventil1
Member
Registered: 2010-03-17
Posts: 123

Re: dhcpcd wlan0 err with udev enabled.OK with udev disabld but no carrier

Wilco wrote:

Install linux-firmware:

pacman -S linux-firmware

Reload the wireless module and you should be good to go

I allready tried that, but with no luck.

iwlwifi-3945-2.ucode firmware file req failed: -2
iwlwifi-3945-1.ucode firmware file req failed: -2
Could not read microcode: -2
Could not set interface 'wlan0' flags: No such file or directory
nl80211: Could not set interface 'wlan0' UP

I think it can't find those files.

Last edited by Ventil1 (2012-09-19 06:18:35)

Offline

#7 2012-09-19 08:25:18

Wilco
Member
Registered: 2008-11-09
Posts: 431

Re: dhcpcd wlan0 err with udev enabled.OK with udev disabld but no carrier

You can set your wireless name to wlan0 using udev rules, it's probably called eth1 now.

Offline

#8 2012-09-19 09:01:50

Ventil1
Member
Registered: 2010-03-17
Posts: 123

Re: dhcpcd wlan0 err with udev enabled.OK with udev disabld but no carrier

Wilco wrote:

You can set your wireless name to wlan0 using udev rules, it's probably called eth1 now.

I think wlan0 is still wlan0 not eth1.

$ip link

gives me:

1: lo <LOOPBACK,UP,LOWER_UPT> mtu 16436 qdisc noqueue state UNKNOWN mode DEFAULT qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: wlan0 <BROADCAST, MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT qlen 1000
3: eth0 <BROADCAST, MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT qlen 1000



$ip link set wlan0 up

shows me:

iwlwifi-3945-2.ucode firmware file req failed: -2
iwlwifi-3945-1.ucode firmware file req failed: -2
Could not read microcode: -2
RTNETLINK answers: No such file or directory

Last edited by Ventil1 (2012-09-19 09:06:49)

Offline

#9 2012-09-19 09:45:05

Gusar
Member
Registered: 2009-08-25
Posts: 3,472

Re: dhcpcd wlan0 err with udev enabled.OK with udev disabld but no carrier

I see two possibilities:
a) You have ipw3945 in the initramfs. Rebuild the initramfs without it.
b) You have a messed up system where /lib isn't a symlink to /usr/lib. So un-mess your system.

Offline

#10 2012-09-28 13:23:30

Ventil1
Member
Registered: 2010-03-17
Posts: 123

Re: dhcpcd wlan0 err with udev enabled.OK with udev disabld but no carrier

I have linux-lts kernel installed now. I don't get black screen now with udev enabled on this kernel.
If I disable udev I get the same error messages seen in my first post as on the newest kernel 3.5.4-1. But If I enable udev everything is fine. But I get different error now.

#ip link set wlan0 up
#wpa_supplicant -i wlan0 -c /etc/wifi.conf -B
#dhcpcd wlan0
dhcpcd[894]: version 5.6.2 starting
dhcpcd[894]: wlan0: waiting for carrier
dhcpcd[894]: timed out

Offline

Board footer

Powered by FluxBB