You are not logged in.

#1 2012-09-02 15:15:20

graysky
Member
From: The worse toilet in Scotland
Registered: 2008-12-01
Posts: 8,813
Website

GRUB_GFXMODE not honored with grub-efi-x86_64 [SOLVED]

Just converted my system from grub-bios to grub-efi-x86_64.  Everything is fine except for the resolution of grub.  I have it set to 1920x1080x32 but it is displayed as something less given how big and blocky the grub menu is to my eyes.

$ sed '/#/d' /etc/default/grub
GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Arch"
GRUB_CMDLINE_LINUX_DEFAULT="quiet init=/bin/systemd"
GRUB_CMDLINE_LINUX=""
GRUB_PRELOAD_MODULES="part_gpt part_msdos"
GRUB_TERMINAL_INPUT=console
GRUB_GFXMODE=1920x1080x32
GRUB_GFXPAYLOAD_LINUX=keep
GRUB_DISABLE_RECOVERY=true
GRUB_COLOR_NORMAL="light-blue/black"
GRUB_COLOR_HIGHLIGHT="light-cyan/blue"
GRUB_BACKGROUND="/boot/grub/genesis.png"

My grub.cfg is indeed updated based on these.

$ sudo grub-mkconfig -o /boot/grub/grub.cfg
Generating grub.cfg ...
Found background: /boot/grub/genesis.png
Found linux image: /boot/vmlinuz-linux-ck
Found initrd image: /boot/initramfs-linux-ck.img
Found memtest86+ image: /boot/memtest86+/memtest.bin
done

Finally, this is a valid mode for my Intel 4000 HD:

$ sudo hwinfo --framebuffer                          
02: None 00.0: 11001 VESA Framebuffer                           
  [Created at bios.459]
  Unique ID: rdCR.QgFYtsmQZBC
  Hardware Class: framebuffer
  Model: "Intel(R) Sandybridge/Ivybridge Graphics Controller"
  Vendor: "Intel Corporation"
  Device: "Intel(R) Sandybridge/Ivybridge Graphics Controller"
  SubVendor: "Intel(R) Sandybridge/Ivybridge Graphics Chipset Accelerated VGA BIOS"
  SubDevice: 
  Revision: "Hardware Version 0.0"
  Memory Size: 255 MB + 960 kB
  Memory Range: 0xe0000000-0xeffeffff (rw)
  Mode 0x0307: 1280x1024 (+1280), 8 bits
  Mode 0x031a: 1280x1024 (+2560), 16 bits
  Mode 0x031b: 1280x1024 (+5120), 24 bits
  Mode 0x0305: 1024x768 (+1024), 8 bits
  Mode 0x0317: 1024x768 (+2048), 16 bits
  Mode 0x0318: 1024x768 (+4096), 24 bits
  Mode 0x0312: 640x480 (+2560), 24 bits
  Mode 0x0314: 800x600 (+1600), 16 bits
  Mode 0x0315: 800x600 (+3200), 24 bits
  Mode 0x0301: 640x480 (+640), 8 bits
  Mode 0x0303: 800x600 (+832), 8 bits
  Mode 0x0311: 640x480 (+1280), 16 bits
  Mode 0x037d: 1920x1080 (+1920), 8 bits
  Mode 0x037e: 1920x1080 (+3840), 16 bits
  Mode 0x037f: 1920x1080 (+7680), 24 bits
  Config Status: cfg=new, avail=yes, need=no, active=unknown

Thank you in advance for any suggestions.

Last edited by graysky (2012-11-17 18:35:25)


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#2 2012-09-05 01:45:05

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,675

Re: GRUB_GFXMODE not honored with grub-efi-x86_64 [SOLVED]

I use

set gfxmode="1366x768x32;1366x768x24;1024x768x32;1024x768x24;auto"

I'm not sure this is quite right. I think that the first mode (which is really correct) isn't supported and it is actually falling back to one of the 1024x768 modes. But it does improve things quite a lot. So you might see if adding some different possibilities helps at all. I'm not actually sure that "auto" wouldn't work just as well in my case, to be honest.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#3 2012-11-17 18:35:14

graysky
Member
From: The worse toilet in Scotland
Registered: 2008-12-01
Posts: 8,813
Website

Re: GRUB_GFXMODE not honored with grub-efi-x86_64 [SOLVED]

Thought I would update this thread.  The problem is not with grub but with the BIOS.  One needs to disable compatibility mode for EFI/BIOS boot options (at least on my board) to access higher resolutions.


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

Board footer

Powered by FluxBB