You are not logged in.

#1 2012-08-12 23:20:17

CloudN9ne
Member
Registered: 2012-01-09
Posts: 7

OpenJDK6 and jdk are in conflict

Hello,

When I attempt to upgrade my system I always get a conflict between Openjdk6 and jdk, which results in the option to remove jdk.
At first I just ignored the openjdk6 package, but the conflict comes back with each upgrade.
I really don't want to remove jdk. Is there any way I can find out what's causing this conflict and remove it?

Offline

#2 2012-08-12 23:38:40

fsckd
Forum Moderator
Registered: 2009-06-15
Posts: 3,551

Re: OpenJDK6 and jdk are in conflict

Why do you need both?


aur S & M :: forum rules :: Community Ethos
Resources for Women, POC, LGBT*, and allies

Offline

#3 2012-08-13 19:52:12

CloudN9ne
Member
Registered: 2012-01-09
Posts: 7

Re: OpenJDK6 and jdk are in conflict

I don't need both. I removed openjdk6 a while ago. I'm not sure why I'm getting this conflict when I try upgrading.

Offline

#4 2012-09-07 04:56:08

MisterAnderson
Member
Registered: 2011-09-04
Posts: 284

Re: OpenJDK6 and jdk are in conflict

I'm getting this too, I removed openjdk6 ages ago and installed jre and jdk. I think there's some package that has it listed as a dependency to install?

EDIT: icedtea-web seems to require it and wants to install it. What is wrong with the jre and jdk?

Last edited by MisterAnderson (2012-09-07 04:57:21)


D:

Offline

#5 2012-09-07 05:10:02

MisterAnderson
Member
Registered: 2011-09-04
Posts: 284

Re: OpenJDK6 and jdk are in conflict

Ok it seems that icedtea-web is for openjdk while oracle packages provide their own browser plugin: https://bbs.archlinux.org/viewtopic.php … 5#p1003915

So I removed icedtea-web and pacman -Syu works perfectly now.


D:

Offline

Board footer

Powered by FluxBB