You are not logged in.

#1 2012-09-08 06:38:55

pushakk
Member
Registered: 2011-09-29
Posts: 49

gnome init fail after 3.5.91-1 upgrade

Hi all,

I have upgrade gnome to 3.5.91 from gnome-unstable repos and now I get this error when I run startx.

gnome-session[2651]: CRITICAL: gsm_manager_set_phase: assertion `GSM_IS_MANAGER (manager)' failed
gnome-session[2651]: Gtk-CRITICAL: gtk_main_quit: assertion `main_loops != NULL' failed

gdm don't start at all, it's show the wallpaper and the mouse cursor freeze on clock way.

Thank you.

Offline

#2 2012-09-08 09:29:57

JGC
Developer
Registered: 2003-12-03
Posts: 1,659

Re: gnome init fail after 3.5.91-1 upgrade

That's because you shouldn't use the repository until it's been announced. All of these packages are still work in progress. Right now I have to rebuild a lot of packages for a gnome-desktop soname bump, so half of GNOME is broken because of that.

To use the packages in the current state, you'll need to copy the libgnome-desktop.so.* files from the gnome-desktop package in extra to /usr/lib and downgrade mutter to the version from extra. So far only gedit seems to be unstable.

Offline

#3 2012-09-08 09:38:52

pushakk
Member
Registered: 2011-09-29
Posts: 49

Re: gnome init fail after 3.5.91-1 upgrade

Um, excuse me.

Anyway I have downgrade gnome so It's go fine again, I post the fail just triying help.

sorry again and thank you.

Offline

#4 2012-09-08 11:19:17

Jodell
Member
Registered: 2009-10-09
Posts: 285

Re: gnome init fail after 3.5.91-1 upgrade

As JGC said above. Don't use it until they announce it. wink

Offline

#5 2012-09-08 17:49:23

geoffm
Member
Registered: 2012-01-15
Posts: 30

Re: gnome init fail after 3.5.91-1 upgrade

Oh crap, I just ran the upgrade and accepted those packages. Now I'm scared to reboot smile

Offline

#6 2012-09-08 19:20:44

geoffm
Member
Registered: 2012-01-15
Posts: 30

Re: gnome init fail after 3.5.91-1 upgrade

JGC wrote:

That's because you shouldn't use the repository until it's been announced. All of these packages are still work in progress. Right now I have to rebuild a lot of packages for a gnome-desktop soname bump, so half of GNOME is broken because of that.

To use the packages in the current state, you'll need to copy the libgnome-desktop.so.* files from the gnome-desktop package in extra to /usr/lib and downgrade mutter to the version from extra. So far only gedit seems to be unstable.

I did the above and when I downgraded mutter, I got the following message:

warning: undefined reference to <schema id='org.gnome.settings-daemon.plugins.updates'/>
ldconfig: /usr/lib/libgnome-desktop-3.so.2 is not a symbolic link

Edit: I rebooted, Gnome works fine (or at least as well as usual)
No noticable changes though

Last edited by geoffm (2012-09-08 23:00:37)

Offline

#7 2012-09-13 08:41:40

josephg
Member
From: Brazil
Registered: 2009-09-28
Posts: 90

Re: gnome init fail after 3.5.91-1 upgrade

FWIW, the workaround provided by JGC works fine.

Also, for those that want to test GNOME, even if not in Archlinux, there is a Live Image available.

http://ftp.gnome.org/pub/gnome/misc/tes … iveUSB.iso

how to put it in USB, see: http://www.gnome.org/getting-gnome/

Offline

#8 2012-09-21 19:13:24

thanos
Member
From: Greece
Registered: 2008-11-22
Posts: 22

Re: gnome init fail after 3.5.91-1 upgrade

Can we use the unstable repo ?

Offline

#9 2012-09-21 19:35:56

nierro
Member
From: Milan, Italy
Registered: 2011-09-02
Posts: 811

Re: gnome init fail after 3.5.91-1 upgrade

No, you'll see an announce in "Announcements, Package & Security Advisories" here in the forum.
Since on 26 september it will be released, we are likely to have it next week.

Offline

#10 2012-10-26 09:59:26

Nightsorrow
Member
From: Brno, Czech Republic
Registered: 2012-10-26
Posts: 2

Re: gnome init fail after 3.5.91-1 upgrade

I have same problem with [testing] repository now. Anybody facing this problem too?

Offline

#11 2012-10-26 10:28:40

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: gnome init fail after 3.5.91-1 upgrade

what do you mean with the same problem? the problem described in here never existed since he used a repo that wasn't ready.


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#12 2012-11-01 14:31:00

Nightsorrow
Member
From: Brno, Czech Republic
Registered: 2012-10-26
Posts: 2

Re: gnome init fail after 3.5.91-1 upgrade

Sorry I didn't respond. My problem was that I didn't install systemd and something was wrong, also some keyboard shortcuts stop working. Something with dbus? So I walk through systemd installation [1] and everything works now.


[1] https://wiki.archlinux.org/index.php/Systemd

Offline

Board footer

Powered by FluxBB