You are not logged in.

#1 2012-09-15 17:19:18

Nikorasu
Member
Registered: 2009-09-26
Posts: 28

[Solved] PCManFM "Not Authorized" when mounting internal drive

Hello all,

I recently installed Arch and was setting up PCManFM, but I have run into a few problems. At first, I had no icons, and couldn't see the other internal drives on my system, but thanks to the PCManFM wiki page, I managed to sort those problems out. However, now I am left with the problem where, if I try to open one of the other partitions, PCManFM spawns an error dialog that just says this:

"Not authorized to perform operation"

To summarize what I have done / tried:

  • I am using SLiM as my login manager, and have the following as my login_cmd

    /exec ck-launch-session dbus-launch /bin/zsh -l ~/.xinitrc %session
  • Installed gamin, polkit-gnome, and gvfs

  • Created /etc/polkit-1/localauthority/50-local.d/55-myconf.pkla as root, as described in the wiki page (even though it should not be necessary, according to the wiki)

None of the above seem to work. I have also taken a look at these threads, but the users seem to have different problems.

Also, I am able to mount a drive manually using mount

Any help would be greatly appreciated as to why I am receiving this error.

Thanks smile

Last edited by Nikorasu (2012-10-12 02:01:01)

Offline

#2 2012-09-15 18:33:30

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,721

Re: [Solved] PCManFM "Not Authorized" when mounting internal drive

Default rules does not allow mounting/umounting of internal devices for security reasons. I would suggest just permamounting in fstab instead.


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#3 2012-09-15 20:47:24

Nikorasu
Member
Registered: 2009-09-26
Posts: 28

Re: [Solved] PCManFM "Not Authorized" when mounting internal drive

While I'm not opposed to setting things up in the fstab, I thought that setting up the .pkla was what overrode the security settings?

Also, one of the internal drives is in a swappable drive bay, so I would rather not set things up in the fstab if possible.

Offline

#4 2012-09-15 20:48:33

Lennie
Member
From: Sweden
Registered: 2011-10-12
Posts: 146

Re: [Solved] PCManFM "Not Authorized" when mounting internal drive

Slim takes care of consolekit, so delete 'ck-launch-session' from .xinitrc. Otherwise it is started twice and that gives permission problems.

Offline

#5 2012-09-15 21:05:16

Nikorasu
Member
Registered: 2009-09-26
Posts: 28

Re: [Solved] PCManFM "Not Authorized" when mounting internal drive

I should clarify a bit. My .xinitrc looks like this...

#!/bin/sh
#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)

if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x "$f" ] && . "$f"
  done
  unset f
fi

[[ -f ~/.Xresources ]] && xrdb -merge ~/.Xresources

# exec gnome-session
# exec startkde
# exec startxfce4
# ...or the Window Manager of your choice

DEFAULT_SESSION=awesome
case $1 in
  awesome|wmii|xmonad) exec $1 ;;
  *) exec $DEFAULT_SESSION ;;
esac

And it was my /etc/slim.conf that had the ck-launch-session line. It now looks like this:

login_cmd           exec dbus-launch /bin/zsh -l ~/.xinitrc %session

However, the problem remains.

Offline

#6 2012-09-16 00:01:39

apikalegusta
Member
Registered: 2012-09-15
Posts: 2

Re: [Solved] PCManFM "Not Authorized" when mounting internal drive

I found the solution! First I don't speak English very well so forgive me spelling mistakes.

First of all, install polkit-gnome. Next you have to remove the dbus-launch and ck-launch-session option in .xinitrc or slim.conf

slim.conf:
login_cmd           exec /bin/zsh -l ~/.xinitrc %session
.xinitrc:
exec openbox-session

If with /bin/zsh don't work, use the default login_cmd ( login_cmd           exec /bin/bash -login ~/.xinitrc %session )

And add this to your ~/.config/openbox/autostart or /etc/xdg/openbox/autostart (or autostart.sh in old openbox versions). HAVE TO BE FULL PATH!

/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 &

logout, login and ¡Magic!

Maybe you have to install gvfs to, I don't know because clementine needs it so I can't remove it u.u

Last edited by apikalegusta (2012-09-16 00:03:00)

Offline

#7 2012-09-16 08:20:13

Lennie
Member
From: Sweden
Registered: 2011-10-12
Posts: 146

Re: [Solved] PCManFM "Not Authorized" when mounting internal drive

Are polkit-gnome-authentication-agent running? Check with 'ps x | grep polkit'

$ ps x | grep polkit
 1517 ?        Sl     0:00 /usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1
 1977 pts/0    S+     0:00 grep polkit

I had problem with that when I used Slim, that it wasn't running although it should have been started (I also tried autostart, as apikalegusta suggested), and on one machine I just couldn't make it work, so I finally had to give up and remove Slim. Slim is tricky, strange bugs that only show up on some machines.

Offline

#8 2012-09-16 10:10:45

tydell
Member
From: actually: Hannover, DE
Registered: 2009-07-26
Posts: 102
Website

Re: [Solved] PCManFM "Not Authorized" when mounting internal drive

I can confirm, You have to run polkit-gnome-authentication-agent, so add this to .xinitrc or anything else properly to desktop env you are running

/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 &

Offline

#9 2012-09-16 16:20:45

apikalegusta
Member
Registered: 2012-09-15
Posts: 2

Re: [Solved] PCManFM "Not Authorized" when mounting internal drive

tydell wrote:

I can confirm, You have to run polkit-gnome-authentication-agent, so add this to .xinitrc or anything else properly to desktop env you are running

/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 &

No in .xinitrc, in your autostart config file!!
I forgot, also remove any line of D-Bus in the enviroment file.

Offline

#10 2012-10-12 02:00:36

Nikorasu
Member
Registered: 2009-09-26
Posts: 28

Re: [Solved] PCManFM "Not Authorized" when mounting internal drive

Polkit was not running (even though /etc/xdg/autostart/polkit-gnome-authentication-agent-1.desktop existed).

The trick was to add the following to my .xinitrc (before starting the awesome session) as suggested.

/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 &

Offline

Board footer

Powered by FluxBB