You are not logged in.

#1 2012-09-17 17:15:44

sam_tech
Member
From: Milky Way
Registered: 2012-08-06
Posts: 9

I can't get my headphones to work

Hello,

My sound works perfectly through the speakers, but I can't get the headphones to work. The headphones  work perfectly on Windows 7.
Please just tell me if you need some information about my hardware.

Cheers,
Sam.


“Standards are always out of date.  That’s what makes them standards.”
– Alan Bennett

Offline

#2 2012-09-17 17:34:43

ximun
Member
From: Montreal, QC
Registered: 2012-08-14
Posts: 26

Re: I can't get my headphones to work

Are they unmuted in alsamixer?


"The problem is, after a week of intense googling, we’ve started to burn out on knowing the answer to everything. God must feel that way all the time. I think people in the year 2020 are going to be nostalgic for the sensation of feeling clueless." Douglas Coupland - jPod

Offline

#3 2012-09-17 17:42:13

sam_tech
Member
From: Milky Way
Registered: 2012-08-06
Posts: 9

Re: I can't get my headphones to work

Yes they are.


“Standards are always out of date.  That’s what makes them standards.”
– Alan Bennett

Offline

#4 2012-09-17 18:12:29

2ManyDogs
Member
Registered: 2012-01-15
Posts: 1,708

Re: I can't get my headphones to work

Please tell us what you've done to try to fix this problem. Have you been through this wiki topic: https://wiki.archlinux.org/index.php/Ad … chitecture paying particular attention to the sections that discuss headphones? Have you searched the forum and wiki for other topics discussing headphones? That should at least give you an idea of what kind of information would be useful to people trying to help you.

The output of the following commands might help us figure out what the problem could be:

lspci | grep -i audio
lsmod | grep snd
aplay -l

Do you have a file at ~/.asoundrc? If you do, what is in it?

Last edited by 2ManyDogs (2012-09-17 18:12:43)

Offline

#5 2012-09-17 19:43:13

sam_tech
Member
From: Milky Way
Registered: 2012-08-06
Posts: 9

Re: I can't get my headphones to work

Thanks for the reply.

I do have a ~/.asoundrc file, here it is:

defaults.pcm.card 1
defaults.pcm.device 3
defaults.ctl.card 1

Here is the lspci | grep -i audio output:

00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Redwood HDMI Audio [Radeon HD 5000 Series]

Here is the lsmod | grep snd output:

snd_hda_codec_hdmi     21248  1 
snd_hda_codec_realtek    51810  1 
snd_hda_intel          20208  1 
snd_hda_codec          80733  3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
snd_pcm                61237  3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd_page_alloc          5901  2 snd_pcm,snd_hda_intel
snd_hwdep               4746  1 snd_hda_codec
snd_timer              14902  1 snd_pcm
snd                    44394  9 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_hda_codec,snd_hda_intel
soundcore               4378  1 snd

And finally, here is the aplay -l output:

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC887-VD Digital [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Hope this helps to give useful data.

Cheers,
Sam.


“Standards are always out of date.  That’s what makes them standards.”
– Alan Bennett

Offline

#6 2012-09-17 19:48:26

2ManyDogs
Member
Registered: 2012-01-15
Posts: 1,708

Re: I can't get my headphones to work

Thank you. It would also be helpful if you answer my first question -- what have you done to try to fix this problem? (Telling us what you've already tried will keep us from having to play "twenty questions" to find out what didn't work.)

And my second question -- have you gone through the wiki topic on alsa? https://wiki.archlinux.org/index.php/Ad … chitecture
Did you try anything based on what you read there?

Did you create the .asoundrc file? If you did, why? Did you read this section of the alsa topic: https://wiki.archlinux.org/index.php/Ad … sound_card ?

Are your headphones connected to your hdmi ouput? Are your speakers?

Last edited by 2ManyDogs (2012-09-17 19:56:59)

Offline

#7 2012-09-18 16:57:46

sam_tech
Member
From: Milky Way
Registered: 2012-08-06
Posts: 9

Re: I can't get my headphones to work

Thanks again.

I tinkered with the different bars, like PCM etc, but I couldn't get the headhphones to work. So, my sound goes through a HDMI wire connected to the monitor. The headphones are connected via mini-jacks, to the front of my computer. When I plug them in I hear a beep with very high frequency.

When I execute pgrep alsa I get nothing, but when executing pgrep pulseaudio I get a number, which indicates it is running.

I did read those wiki articles, but the only sound I get, comes from the monitor speakers.

Cheers,
Sam.

Last edited by sam_tech (2012-09-18 16:58:33)


“Standards are always out of date.  That’s what makes them standards.”
– Alan Bennett

Offline

#8 2012-09-18 17:05:42

2ManyDogs
Member
Registered: 2012-01-15
Posts: 1,708

Re: I can't get my headphones to work

sam_tech wrote:

The headphones are connected via mini-jacks, to the front of my computer.

This may be the problem. Your .asoundrc says that the hdmi device is the default, so it is unlikely that the jack on the computer will work (sound is being routed to the hdmi output, not the panel jacks). Does the monitor have a headphone output, or just speakers? What happens if you temporarily disable your .asoundrc (mv .asoundrc .asoundrc.bak and reboot) -- does the computer headphone output work then? What if you specify device 0 or 1 instead of device 3 for the default in .asoundrc?

If you run alsamixer, are you able to switch sound card with F6? Try this both with and without .asoundrc.

It also may be a pulseaudio issue; I don't know anything about pulseadio.

Last edited by 2ManyDogs (2012-09-18 17:06:16)

Offline

#9 2012-09-18 17:38:56

sam_tech
Member
From: Milky Way
Registered: 2012-08-06
Posts: 9

Re: I can't get my headphones to work

Okay, so I renamed .asoundrc to .asoundrc.bak and unmuting the master channel makes audio work with the headphones, but not through the speakers of the monitor. The quality of the sound through the headphones is bad as each second or more (randomly) it makes like a peak and noise, and the volume of the master channel is constantly moving down and up, with no interaction from my part. Also if I change a setting in alsamixer, the audio gets off, but for example, if I listen to a song, the song stops playing but I can still hear a constant noise, with peaks of course.

If I run alsamixer, It allows me to switch between HDA Intel and HD-Audio Generic. It seems HD audio generic is the one where I can control the master volume of the headphones.

I tried with different possibilies in my ~/.asoundrc file, like 1 and 0, but no luck, with 0 and 1 I can at least hear something, but peaks, and weird stuff going on, like pulseaudio and alsa are fighting or something.

Also, an interesting thing ; when I plug in my microphone mini-jack, I can hear myself in the headphones with no peaks, I can hear myself perfectly.

Cheers,
Sam.

Last edited by sam_tech (2012-09-18 17:54:05)


“Standards are always out of date.  That’s what makes them standards.”
– Alan Bennett

Offline

Board footer

Powered by FluxBB