You are not logged in.

#1 2012-09-18 11:50:10

pogeymanz
Member
Registered: 2008-03-11
Posts: 1,020

Ugh. MBR->GPT headaches

So, this isn't really an installation issue, but I thought this would be a good place to post this. I actually just backed up, converted my disk, and dumped the files back to it.

By converting the disk, I mean I popped a LiveCD in:
1. Open Gparted
2. Delete all partitions
3. Make new partition table (GPT)
4. Make new partitions including a 2MB unformatted one. (I didn't do the usual MBR->GPT guides because I change my partition layout a little)
5. Set the grub_bios flag on the 2MB unformatted partition.

Then...

6. Transfer files back from external hard drive
7. arch-chroot
8. Edit fstab, mkinitcpio.conf, /etc/default/grub (I'm no longer using LVM, so I needed to update everything)
9. grub-install --target=i386-pc --recheck --debug /dev/sda                   finishes with no errors
10. grub-mkconfig -o /boot/grub/grub.cfg
11. mkinitcpio -p linux
12. Reboot

Aaaand nothing. Grub doesn't load. No error messages, just a blank screen with a blinking cursor.

So, I pop in the LiveCD again, and if I choose the option "boot existing OS" my Arch install boots right up! I'm in it right now. It just can't find itself when I boot...
All the configs seem fine.

Any idea what is happening here?

Does the grub_bios partition have to be the first partition on the disk? Because mine isn't...

Last edited by pogeymanz (2012-09-18 11:51:13)

Offline

#2 2012-09-18 12:04:58

windingload
Member
From: JP
Registered: 2012-09-04
Posts: 17

Re: Ugh. MBR->GPT headaches

Hi pogeymanz,

Did you try syslinux? It works GPT fine. I had same trouble about my laptop. It's very easy to do.

# arch-chroot /mnt
# pacman -S syslinux gptfdisk # gptfdisk solves legacy boot partition
# syslinux-install_update -iam
# nano /boot/syslinux/syslinux.conf # edit your APPEND root=/<your root>

That's it! If your problem is continues did you check your /boot drive? When you create new partition you need do like this (http://tincman.wordpress.com/2011/01/20 … os-system/)

Hope this helps.


Sincerely,

tongue

Offline

#3 2012-09-18 14:43:31

lmsguerr
Member
From: Loulé-Algarve-Portugal
Registered: 2008-05-20
Posts: 46

Re: Ugh. MBR->GPT headaches

Did you make a partition for boot? If so, you didn mention that you mount /boot before you chroot. Like windingload said, maybe your /boot is empty!

Last edited by lmsguerr (2012-09-18 14:43:49)


Linux /  4.1.6-1-ARCH-ck / x86_64 / AMD Phenom(tm) II X4 955 Processor

Offline

#4 2012-09-18 14:44:51

pogeymanz
Member
Registered: 2008-03-11
Posts: 1,020

Re: Ugh. MBR->GPT headaches

For some reason, it does the same thing.

Actually, it's worse because when I do try to boot with syslinux from a LiveCD, it just prints endless periods "...................." on my screen...

I've decided to give up and go back to MBR. It wasn't broke, so I shouldn't have tried to fix it.

EDIT: My /boot is not empty. It was properly filled with both Grub stuff and Syslinux stuff when I installed either of them. It is on a separate partition.

Last edited by pogeymanz (2012-09-18 14:52:14)

Offline

#5 2012-09-18 15:02:44

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: Ugh. MBR->GPT headaches

Actually, it's worse because when I do try to boot with syslinux from a LiveCD, it just prints endless periods "...................." on my screen...

Sounds like you used this method.

It's fine, it's just loading the ISO image into RAM. The article assumes that you're clever enough to figure it out. They represent the loading process


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#6 2012-09-18 15:05:26

pogeymanz
Member
Registered: 2008-03-11
Posts: 1,020

Re: Ugh. MBR->GPT headaches

But that isn't at all what I did...

I set it up almost completely default. I changed root=/dev/sda1 because that's my root partition. That's it...

My system normally takes ~20 seconds to boot and I let it sit there printing dots for over a minute before I gave up on it.

Offline

#7 2012-09-18 15:22:11

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: Ugh. MBR->GPT headaches

Post your syslinux.cfg and your fstab then.


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#8 2012-09-18 15:23:26

pogeymanz
Member
Registered: 2008-03-11
Posts: 1,020

Re: Ugh. MBR->GPT headaches

I don't have my computer with me right now, but I will when I get home this evening.

Offline

#9 2012-09-19 07:35:12

the.ridikulus.rat
Member
From: Indiana, USA
Registered: 2011-10-04
Posts: 765

Re: Ugh. MBR->GPT headaches

What system do you have? UEFI with BIOS fallback support. Some of these systems (mainly Phoenix Secure Core Tiano firmwares) refuse to BIOS boot GPT disks, unless the GPT Protective MBR's 0xEE partition is marked as 'active' using fdisk.

Offline

#10 2012-09-19 12:14:07

pogeymanz
Member
Registered: 2008-03-11
Posts: 1,020

Re: Ugh. MBR->GPT headaches

Hi Ridikulus Rat. I just have a regular BIOS laptop from Toshiba. It just refused to boot from GPT anyway. I'm pretty sure at this point that it's just a shitty BIOS, because I did everything I could find via google.

When I installed Syslinux, it marked my /boot partition with the legacy_boot flag, which might be the same as what you're saying with 'active'?

Anyway, I reconverted to MBR (took all damn day to move my partitions around in GParted) and it boots fine now.

DSpider, here is my syslinux.cfg:

# Config file for Syslinux -
# /boot/syslinux/syslinux.cfg
#
# Comboot modules:
#   * menu.c32 - provides a text menu
#   * vesamenu.c32 - provides a graphical menu
#   * chain.c32 - chainload MBRs, partition boot sectors, Windows bootloaders
#   * hdt.c32 - hardware detection tool
#   * reboot.c32 - reboots the system
#   * poweroff.com - shutdown the system
#
# To Use: Copy the respective files from /usr/lib/syslinux to /boot/syslinux.
# If /usr and /boot are on the same file system, symlink the files instead
# of copying them.
#
# If you do not use a menu, a 'boot:' prompt will be shown and the system
# will boot automatically after 5 seconds.
#
# Please review the wiki: https://wiki.archlinux.org/index.php/Syslinux
# The wiki provides further configuration examples

DEFAULT arch
PROMPT 1        # Set to 1 if you always want to display the boot: prompt 
TIMEOUT 50
# You can create syslinux keymaps with the keytab-lilo tool
#KBDMAP de.ktl

# Menu Configuration
# Either menu.c32 or vesamenu32.c32 must be copied to /boot/syslinux 
UI menu.c32
#UI vesamenu.c32

# Refer to http://syslinux.zytor.com/wiki/index.php/Doc/menu
MENU TITLE Arch Linux
#MENU BACKGROUND splash.png
MENU COLOR border       30;44   #40ffffff #a0000000 std
MENU COLOR title        1;36;44 #9033ccff #a0000000 std
MENU COLOR sel          7;37;40 #e0ffffff #20ffffff all
MENU COLOR unsel        37;44   #50ffffff #a0000000 std
MENU COLOR help         37;40   #c0ffffff #a0000000 std
MENU COLOR timeout_msg  37;40   #80ffffff #00000000 std
MENU COLOR timeout      1;37;40 #c0ffffff #00000000 std
MENU COLOR msg07        37;40   #90ffffff #a0000000 std
MENU COLOR tabmsg       31;40   #30ffffff #00000000 std

# boot sections follow
#
# TIP: If you want a 1024x768 framebuffer, add "vga=773" to your kernel line.
#
#-*

LABEL arch
	MENU LABEL Arch Linux
	LINUX ../vmlinuz-linux
	APPEND root=/dev/sda1 ro
	INITRD ../initramfs-linux.img

LABEL archfallback
	MENU LABEL Arch Linux Fallback
	LINUX ../vmlinuz-linux
	APPEND root=/dev/sda1 ro 
	INITRD ../initramfs-linux-fallback.img

LABEL hdt
        MENU LABEL HDT (Hardware Detection Tool)
        COM32 hdt.c32
 
LABEL reboot
        MENU LABEL Reboot
        COM32 reboot.c32
 
LABEL off
        MENU LABEL Power Off
        COMBOOT poweroff.com

I actually really like Syslinux's HDT, so if I could get this to work, that would be cool.

I haven't tried Syslinux since I moved back to MBR, so maybe it'll work now by magic. I'll update later.

EDIT: Oh, and fstab:

# 
# /etc/fstab: static file system information
#
# <file system>	<dir>	<type>	<options>	<dump>	<pass>
tmpfs		/tmp	tmpfs	nodev,nosuid,noexec	0	0
/dev/sda2	/home ext4 defaults,noatime,noauto,comment=systemd.automount 0 2
/dev/sda1	/ ext4 defaults,noatime 0 1
/dev/sda6	swap swap defaults 0 0
/dev/sda5	/var ext4 defaults,noatime 0 2
/dev/sda4	/boot ext4 defaults,noatime 0 2

Last edited by pogeymanz (2012-09-19 12:18:46)

Offline

#11 2012-09-19 13:01:12

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: Ugh. MBR->GPT headaches

Syslinux.cfg looks like the default with just the root partition edited.

Fstab looks good too, I guess... I don't know what "comment=systemd.automount" is supposed to be. I would probably align it like in the fstab wiki page examples, tho.


For HDT to work, you need the "/boot/syslinux/hdt.c32" file to be present. But if you used the "syslinux-install_update" script, it's probably there already.

Last edited by DSpider (2012-09-19 13:01:29)


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#12 2012-09-19 13:57:26

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,670

Re: Ugh. MBR->GPT headaches

You may want:

comment=x-systemd.automount

rather than the option you're using.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

Board footer

Powered by FluxBB