You are not logged in.

#1 2012-09-20 02:40:15

gh403
Member
Registered: 2012-09-15
Posts: 22

[laptop-mode-tools] not respecting SATA powersave settings

I configured my installation of Laptop Mode Tools to enable SATA powersave at all times, because the fan runs at maximum speed without it on.  When I unplug the power connector, it works great--SATA powersave is on (as reported by powertop).  But when the laptop is plugged in, SATA powersave turns off, even though I (see config file below) explicitly told it to stay on!  What am I doing wrong?  So far laptop-mode-tools has been quite frustrating...  Thanks for any help!

#
# Configuration file for Laptop Mode Tools module intel-sata-powermgmt.
#
# For more information, consult the laptop-mode.conf(8) manual page.
#


###############################################################################
# Intel SATA power management settings
# ------------------------------------
#
# If you enable this setting, laptop mode tools will automatically enable the
# link power management mode of Intel AHCI compliant SATA chipsets.
#
###############################################################################

# Enable debug mode for this module
# Set to 1 if you want to debug this module
DEBUG=0

# Control Intel SATA chipset power management?
# Set to 0 to disable
#CONTROL_INTEL_SATA_POWER=1
CONTROL_INTEL_SATA_POWER="auto"

# Handle power management of the Intel SATA deivce under specific circumstances
BATT_ACTIVATE_SATA_POWER=1
LM_AC_ACTIVATE_SATA_POWER=1
NOLM_AC_ACTIVATE_SATA_POWER=1

Offline

#2 2012-09-20 10:27:26

sano
Member
Registered: 2012-02-11
Posts: 114

Re: [laptop-mode-tools] not respecting SATA powersave settings

There's a setting for HD power management in /etc/laptop-mode/laptop-mode.conf

It looks like this

#
# Power management for HD (hdparm -B values)
#
BATT_HD_POWERMGMT=1
LM_AC_HD_POWERMGMT=254
NOLM_AC_HD_POWERMGMT=254

Change it to your liking.

Offline

Board footer

Powered by FluxBB