You are not logged in.

#1 2012-09-21 13:09:18

kazikas
Member
Registered: 2012-02-18
Posts: 5

Keyboard and mouse doesn't work

In tray appears only network icon - no volume icon. Keyboard, mouse and touchpad, sound, wifi and network not working.

Last edited by kazikas (2012-09-21 22:43:50)

Offline

#2 2012-09-21 16:08:08

nTia89
Banned
From: varese, italy
Registered: 2008-12-22
Posts: 1,230

Re: Keyboard and mouse doesn't work

I think it is very dangerous put all that is below the

#Samsung stuff

in the rc.conf, delete them! or better move them...


+pc: custom | AMD Opteron 175 | nForce4 Ultra | 2GB ram DDR400 | nVidia 9800GT 1GB | ArchLinux x86_64 w/ openbox
+laptop: Apple | MacBook (2,1) | 2GB ram | Mac OS X 10.4 -> DIED
+ultrabook: Dell | XPS 13 (9343) | 8GB ram | 256GB ssd | FullHD display | Windows 8.1 64bit ArchLinux x86_64 w/ Gnome

Offline

#3 2012-09-21 20:55:19

kazikas
Member
Registered: 2012-02-18
Posts: 5

Re: Keyboard and mouse doesn't work

nTia89 wrote:

I think it is very dangerous put all that is below the

#Samsung stuff

in the rc.conf, delete them! or better move them...

Nothing changes. It looks that nothing is working - my conky shows: Battery:0% WiFi:off Volume:0

Offline

#4 2012-09-21 21:25:18

nTia89
Banned
From: varese, italy
Registered: 2008-12-22
Posts: 1,230

Re: Keyboard and mouse doesn't work

one things per time:
keyboard: try to post the output of dmesg after that you plug in the keyboard


+pc: custom | AMD Opteron 175 | nForce4 Ultra | 2GB ram DDR400 | nVidia 9800GT 1GB | ArchLinux x86_64 w/ openbox
+laptop: Apple | MacBook (2,1) | 2GB ram | Mac OS X 10.4 -> DIED
+ultrabook: Dell | XPS 13 (9343) | 8GB ram | 256GB ssd | FullHD display | Windows 8.1 64bit ArchLinux x86_64 w/ Gnome

Offline

#5 2012-09-21 21:33:39

kazikas
Member
Registered: 2012-02-18
Posts: 5

Re: Keyboard and mouse doesn't work

nTia89 wrote:

one things per time:
keyboard: try to post the output of dmesg after that you plug in the keyboard

I'm using netbook. And I can't post any outputs, because nothing works.

Offline

#6 2012-09-21 22:29:58

nlights
Member
Registered: 2009-12-10
Posts: 8

Re: Keyboard and mouse doesn't work

I may have the same problem ( or a similar one )

Installed arch to a SSD drive on a IBM T60 laptop today. 
Touchpad and Keyboard is non operational under Xorg, on the other hand the stick embedded in the keyboard is working...
Stick is detected by evdev in Xorg.0.log, there is nothing regarding keyboard or touchpad in the log at all.

Required Xorg input packages are installed, and keyboard seems to be working fine if tested with /lib/udev/keymap

Installed arch on the same laptop ( but with another drive ) the day before yesterday, and at that time everything was working fine.
In my case some package(s) seems to have broken input via evdev in Xorg the last couple of days...

Offline

#7 2012-09-21 22:42:27

kazikas
Member
Registered: 2012-02-18
Posts: 5

Re: Keyboard and mouse doesn't work

Few days of reading, editing various configuration files, downgrading and installing packages, kernel upgrades I'm back. Sometimes I hate Arch, then suddenly everything works, but reason is unknown. On other hand thats why I love it.

Offline

#8 2012-09-23 06:59:47

lordblackfox
Member
Registered: 2012-07-15
Posts: 2

Re: Keyboard and mouse doesn't work

I've got the same problem on a computer here, after a big update (not online for two weeks). The keyboard and mouse doesn't work, Xorg.0.log doesn't mention Synaptics at all (xf86-input-synaptics and config file installed), and mention an internal initialization of xkeyboard (as others stuffs). Plugging a mouse or a keyboard doesn't work either on X.

Kazikas, can you say what exactly you've done? thx

Offline

#9 2012-09-24 21:14:11

nlights
Member
Registered: 2009-12-10
Posts: 8

Re: Keyboard and mouse doesn't work

After a couple of nights trying various ways to get keyboard and mouse back I took a longshot and decided to try switching init to systemd.
To my surprise, my headache was cured in an instant.  Keyboard and mouse is back again, and I can continue with the rest of the setup smile

Probably not the cure for the real problem, but at least a workaround for the time being...

Offline

#10 2012-09-28 18:12:31

walterjwhite
Member
Registered: 2011-05-01
Posts: 207

Re: Keyboard and mouse doesn't work

Hi,

I had a similar issue and have a similar issue now.  I switch between Gentoo and Arch ...  The problem went away in Arch when I booted with systemd; however, when I used systemd, my sound wouldn't work as well as some other services.  I have not yet pinpointed the problem, but it appears to be something with how Arch boots up.  It is different than Gentoo (I don't have that problem there).  However, with Gentoo, every upgrade might lead to a broken system.

Does anyone have any ideas as to where else to look?

Walter

Offline

Board footer

Powered by FluxBB