You are not logged in.

#1 2012-09-22 05:51:33

testdude281
Member
From: Vizag, India
Registered: 2011-03-04
Posts: 75

System Not Booting After systemd Update [Solved]

hi,

    After upgrading my system this morning, i got the following error upon reboot

[5.550095] systemd[1]: segfault at 7d ip b755b7b7 sp bf9798b8 error 4 in libc-2.16.so[b74dc000+1a4000]
[5.550399] systemd[1]: caught <SEGV> , core dump failed.

  Checking the log, showed that systemd was updated. i have checked the net for possible solutions, but no one has reported it. Can somebody help?

Last edited by testdude281 (2012-09-22 09:42:31)

Offline

#2 2012-09-22 05:54:29

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: System Not Booting After systemd Update [Solved]

What version of systemd are you using?


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#3 2012-09-22 06:02:22

testdude281
Member
From: Vizag, India
Registered: 2011-03-04
Posts: 75

Re: System Not Booting After systemd Update [Solved]

Systemd was upgraded from 189-4 -> 191-1

Offline

#4 2012-09-22 06:02:26

bhante
Member
Registered: 2008-05-20
Posts: 22

Re: System Not Booting After systemd Update [Solved]

Downgrade package

  Boot with live media
  arch-chroot /mnt
  pacman -U /var/cache/pacman/pkg/systemd-189-4-i686.pkg.tar.xz

Offline

#5 2012-09-22 06:05:23

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: System Not Booting After systemd Update [Solved]

...and disable [testing] repositories. (BTW, why did you enable [testing] in the first place?)


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#6 2012-09-22 06:15:17

testdude281
Member
From: Vizag, India
Registered: 2011-03-04
Posts: 75

Re: System Not Booting After systemd Update [Solved]

No need for live media. i have sysvnit on fallback. in fact in am writing on it. i have already downgraded it.

As for [testing], guess i want to live on the edge.

Thanks.

Offline

#7 2012-09-22 06:39:23

opensrcrox
Member
Registered: 2012-08-10
Posts: 32

Re: System Not Booting After systemd Update [Solved]

Since systemd-191 is in testing, a more appropriate place to discuss it is the testing repo subforum.
I guess a mod will move it there soon.
I can confirm the same issue with systemd-191 on i686.
Best thing to do is to report it on the bugtracker ... don't you think? smile

Offline

#8 2012-09-22 07:03:37

megadriver
Member
From: Spain
Registered: 2010-02-03
Posts: 58
Website

Re: System Not Booting After systemd Update [Solved]

Same problem here, also on i686.

Offline

#9 2012-09-22 07:17:14

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,839

Re: System Not Booting After systemd Update [Solved]

No problems with the upgrade here, on x86_64 - maybe the problem is in the i686 package only.

Offline

#10 2012-09-22 07:20:36

testdude281
Member
From: Vizag, India
Registered: 2011-03-04
Posts: 75

Re: System Not Booting After systemd Update [Solved]

Offline

#11 2012-09-22 07:43:21

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,839

Re: System Not Booting After systemd Update [Solved]

"Bug affects only x86 systems" is meaningless - you need to specify i686.

Offline

#12 2012-09-22 08:28:59

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,430
Website

Re: System Not Booting After systemd Update [Solved]

Removed the package from i686 [testing]

Offline

#13 2012-09-22 10:31:03

opensrcrox
Member
Registered: 2012-08-10
Posts: 32

Re: System Not Booting After systemd Update [Solved]

Maybe the issue could be related to this :  https://bugs.freedesktop.org/show_bug.cgi?id=55213

Offline

Board footer

Powered by FluxBB