You are not logged in.

#1 2012-09-12 22:40:35

zmbmartin
Member
Registered: 2009-06-18
Posts: 43

MacBook Pro 8,3 Graphics and Power Consumption

Just wondering if anyone else with a MacBook Pro 8,3 or 8 series has some thoughts or things to share with me. I am able to install Arch but I can only get the fbdev graphics driver working. I can not get ati, fglrx, or the intel driver to work. I would prefer to have the intel driver working for less power consumption. And on that note I notice that battery life is cut in 1/2 to 1/3 of what I get in OS X. Anyone else having this problem or have some thoughts I what I can do to make this better?

Thanks

Offline

#2 2012-09-14 12:32:56

zmbmartin
Member
Registered: 2009-06-18
Posts: 43

Re: MacBook Pro 8,3 Graphics and Power Consumption

Anyone here with some insight?

Just to give a little more information on the graphics problem. I can boot fine with KMS enabled for i915 and I see all the tty boot information fine and can use the tty consoles fine, but when I startx with the intel driver it looks like it is going to start fine for a second and then tty7 is just blank/black. I can go back to other tty's and when I look at /var/log/Xorg.0.log there are no errors that I can see. From the log it appears that the driver loaded fine but tty7 is just blank/black.

Offline

#3 2012-09-14 12:39:22

Gusar
Member
Registered: 2009-08-25
Posts: 3,472

Re: MacBook Pro 8,3 Graphics and Power Consumption

I've seen development regarding Intel graphics on newest Macs on the kernel mailing list recently. You'll probably have to wait for the 3.6 kernel, or you compile the rc versions yourself.

As for power consumption, that one is obvious - the discrete graphic card is drawing power all the time, while in OSX it's off when not used. It should be possible to turn it off in Linux, but that's an area I don't have experience in. And even here you might need the 3.6 kernel.

Online

#4 2012-09-23 22:07:28

elahav
Member
From: Ottawa, ON
Registered: 2005-04-18
Posts: 90

Re: MacBook Pro 8,3 Graphics and Power Consumption

Same here, so far, on a MBP 8,2. I booted with no kernel options for i915 (had to use radeon.modeset=0 to solve a boot hang). If I try booting with an out-of-the-box Xorg configuration (or rather lack of), X will try to use the VESA driver. To get the Intel driver recognized I added a file to /etc/X11/xorg.conf.d, so now X seems to happily load the Intel driver. However, all that is displayed is a small underscore at the top right of the screen.

Offline

Board footer

Powered by FluxBB