You are not logged in.

#1 2012-09-21 15:11:55

boast
Member
Registered: 2010-09-28
Posts: 219

[SOLVED] suspend stopped working with dbus

If I run pm-suspend as root, it resumes fine. If I suspend using

qdbus org.freedesktop.PowerManagement /org/freedesktop/PowerManagement Suspend

as either user or root, I resume to an uninitialized screen, and I can't even ping the system so the network doesn't initialize either.

Last edited by boast (2012-10-07 22:54:44)


Asus M4A785TD-V ;; Phenom II X4 @ 3.9GHz ;; Ripjaws 12GB DDR3-1600 ;; 128GB Samsung 830 ;; MSI GTX460 v2 w/ blob ;; Arch Linux + KDE 4.x

Offline

#2 2012-09-24 01:37:45

johni
Member
Registered: 2012-02-03
Posts: 102

Re: [SOLVED] suspend stopped working with dbus

I had the exact same problem after the latest KDE update.  I worked around it by changing KDE to do nothing when I closed the lid, and started using acpid to run pm-suspend when the lid closed.  It works fine like that.

Offline

#3 2012-09-24 05:31:04

archie0
Member
Registered: 2012-02-26
Posts: 144

Re: [SOLVED] suspend stopped working with dbus

I'm up to date and everything seems to work. Are you guys using systemd?

Offline

#4 2012-09-24 14:43:58

boast
Member
Registered: 2010-09-28
Posts: 219

Re: [SOLVED] suspend stopped working with dbus

I updated the OP, the chakra wiki showed the command kde uses to suspend, and it seems dbus is the one not working.


Asus M4A785TD-V ;; Phenom II X4 @ 3.9GHz ;; Ripjaws 12GB DDR3-1600 ;; 128GB Samsung 830 ;; MSI GTX460 v2 w/ blob ;; Arch Linux + KDE 4.x

Offline

#5 2012-09-24 18:15:22

dejavu
Member
Registered: 2008-05-26
Posts: 103

Re: [SOLVED] suspend stopped working with dbus

I experience some similar problem in the last weeks by using Gnome and systemd.
Sometimes the computer resumes with a black screen and nothing is working (also no vt switch).
Suspend did work since a long time perfectly.

Offline

#6 2012-10-03 12:50:43

mjlion
Member
Registered: 2012-10-03
Posts: 1

Re: [SOLVED] suspend stopped working with dbus

I have the same problem after switching to systemd.
Just only pm-suspend works, 'systemct suspend' and others have problem.
I worked around it by changing /usr/lib/systemd/system/systemd-suspend.service:

[Service] 
from:
ExecStart=/usr/lib/systemd/systemd-sleep suspend

to:
ExecStart=/usr/sbin/pm-suspend

This is temporary solution for KDE settings (suspend, close lid) to have it work.

Offline

#7 2012-10-07 22:55:02

boast
Member
Registered: 2010-09-28
Posts: 219

Re: [SOLVED] suspend stopped working with dbus

well, I'm not sure what update did it, but it seems to be working again. *shrug*


Asus M4A785TD-V ;; Phenom II X4 @ 3.9GHz ;; Ripjaws 12GB DDR3-1600 ;; 128GB Samsung 830 ;; MSI GTX460 v2 w/ blob ;; Arch Linux + KDE 4.x

Offline

#8 2012-10-11 20:40:16

dejavu
Member
Registered: 2008-05-26
Posts: 103

Re: [SOLVED] suspend stopped working with dbus

dejavu wrote:

I experience some similar problem in the last weeks by using Gnome and systemd.
Sometimes the computer resumes with a black screen and nothing is working (also no vt switch).
Suspend did work since a long time perfectly.

Suspend works fine again since the last updates. So for me it's solved.

Offline

Board footer

Powered by FluxBB