You are not logged in.

#1 2012-09-24 23:39:16

Quicken2k
Member
Registered: 2011-04-05
Posts: 12

[Solved] No Internet on new installer live cd

Hi All.

I just recently bought a new pc (Gateway DX4860). I have recently download the latest archlinux iso (with the new install method). I have the partitions setup, but I can't seem to get my dsl working at all. My setup is simple just an Ethernet cable from PC to modem (no router), so I should just be able to do a pppoe-setup and be on my way. Setup works, but I get no connectivity. What am I missing?. I also have a ralink wireless card in this PC if that means anything.

Quicken2k

Last edited by Quicken2k (2012-09-26 20:30:43)

Offline

#2 2012-09-25 04:36:22

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,406

Re: [Solved] No Internet on new installer live cd

I would start with ip link to see if the system (a) sees your card and instantiates an network device for it, and to see if it thinks there is a cable attached.
(BTW, there is a cable attached, right? --- I cannot tell you how often that is the problem tongue )
Check that the link lights are on at the computer and the modem.

Are you sure your modem uses PPPoE?  Any chance it is mini-router providing NAT translation and running its own little DHCP server?  Have you just tried using dhcpcd ?  Can't hurt.

Last edited by ewaller (2012-09-25 04:36:47)


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

#3 2012-09-25 08:14:06

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: [Solved] No Internet on new installer live cd

Did you type "server" ? Does it say "Connected!" ? Can you ping Google ?

https://wiki.archlinux.org/index.php/Be … em_or_ISDN


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#4 2012-09-26 01:28:54

Quicken2k
Member
Registered: 2011-04-05
Posts: 12

Re: [Solved] No Internet on new installer live cd

Nope just a standard modem  suipra 2400. There are times when it says connected and there are times when it says. connect > NULL. If I try ping -c 3 www.Google.com if says can't find host. If I ping 8.8.8.8. it works but no still no internet.dhcpd refers to ipv6. I'm sure mine doesn't use that. What else can I do.

Offline

#5 2012-09-26 01:36:37

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,501
Website

Re: [Solved] No Internet on new installer live cd

Quicken2k wrote:

If I ping 8.8.8.8. it works but no still no internet

Did I read that right?  If you can ping ip addresses then you most certainly do have internect connectivity.  You just may not have a proper DNS.

Also, while I'm well outside my expertise (and ewaller can correct or clarify) dhcp is not just for ipv6 (is it??).  AFAIK dhdcpcd or dhclient will get DNS info and put it in /etc/resolve.conf which is needed.  That is a bit 'handwavy' as if some magic happens, which is basically is to me, but I know that those are the relevant players and the roles they play.  So, I'd say check your resolve.conf, and try out dhcpcd.

Last edited by Trilby (2012-09-26 01:39:31)


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#6 2012-09-26 02:48:38

progandy
Member
Registered: 2012-05-17
Posts: 2,146

Re: [Solved] No Internet on new installer live cd

If you have an IP, but the nameserver is missing, just put "nameserver 8.8.8.8" in your resolv.conf.

Last edited by progandy (2012-09-26 02:49:15)

Offline

#7 2012-09-26 07:11:19

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: [Solved] No Internet on new installer live cd

progandy wrote:

If you have an IP, but the nameserver is missing, just put "nameserver 8.8.8.8" in your resolv.conf.

Exactly. Like it says in the Beginners' Guide:

https://wiki.archlinux.org/index.php/Be … em_or_ISDN

And because most ISPs have moved to IPv6, you may need to adjust your resolv.conf:

# echo nameserver 8.8.8.8 > /etc/resolv.conf

PS: Don't forget to mark it as solved (by editing the first post).

Last edited by DSpider (2012-09-26 08:32:12)


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#8 2012-09-26 20:29:43

Quicken2k
Member
Registered: 2011-04-05
Posts: 12

Re: [Solved] No Internet on new installer live cd

Got it thanks.

Offline

Board footer

Powered by FluxBB