You are not logged in.

#1 2012-09-27 13:45:34

Linkas
Member
Registered: 2011-12-28
Posts: 25

[solved]Gratuitous Space Battles - Humble I. B. 6. Old libcurl requred

Hi
I need libcurl.so.3 to run the game. In pacman repository there is libcurl.so.4 (curl package). Anybody know the easiest way to have both libs? I even can't find libcurl.so.3.

Last edited by Linkas (2012-09-28 07:47:18)

Offline

#2 2012-09-27 13:53:54

mzneverdies
Member
Registered: 2012-02-04
Posts: 147

Re: [solved]Gratuitous Space Battles - Humble I. B. 6. Old libcurl requred

don't know how much has changed, but you can always try:

sudo ln -sf /usr/lib/libcurl.so.4 /usr/lib/libcurl.so.3

not ideal, and might not work, but worth the try

Offline

#3 2012-09-27 13:55:57

Linkas
Member
Registered: 2011-12-28
Posts: 25

Re: [solved]Gratuitous Space Battles - Humble I. B. 6. Old libcurl requred

thanks for your reply mzneverdies. I've tried this already. It leads the game to segmentation fault at startup.

Last edited by Linkas (2012-09-27 13:56:48)

Offline

#4 2012-09-27 13:58:06

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 5,888
Website

Re: [solved]Gratuitous Space Battles - Humble I. B. 6. Old libcurl requred

Seriously? As far as I can tell, libcurl.so.3 was obsoleted on October 30 2006.

You can still get the source for 7.15.5 here: http://curl.haxx.se/download/

No idea whether it'll compile though. If you can get it to compile, I recommend writing a PKGBUILD so you can install it with pacman (take care not to conflict with the up-to-date curl though)

Good luck!


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Making lemonade from lemons since 2015.

Offline

#5 2012-09-27 17:54:28

whoops
Member
Registered: 2009-03-19
Posts: 852

Re: [solved]Gratuitous Space Battles - Humble I. B. 6. Old libcurl requred

It runs fine in wine. Might not be an ideal solution, but a lot easier.

Edit: Wait a second, 2006? That's not possible, the native version of the game ran fine the last time it was part of a humble bundle... you sure it's not something else?

Last edited by whoops (2012-09-27 17:56:42)

Offline

#6 2012-09-27 19:52:17

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 5,888
Website

Re: [solved]Gratuitous Space Battles - Humble I. B. 6. Old libcurl requred

I've had time to investigate a little further, and yes, 7.16.0 creates libcurl.so.4, and 7.15.5 creates libcurl.so.3.

So maybe GSB's devs decided to do a spot of trolling by compiling against 6 year old libraries this time around?

Ubuntu still provides libcurl.so.3 in an aptly named libcurl3 package, so perhaps you played it on that before?


If anything, my investigation has shown that 7.15.5 compiles fine. If you've found an alternative solution (wine), or just don't feel up to creating it, I might knock up an AUR package myself at some point.


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Making lemonade from lemons since 2015.

Offline

#7 2012-09-27 22:01:03

whoops
Member
Registered: 2009-03-19
Posts: 852

Re: [solved]Gratuitous Space Battles - Humble I. B. 6. Old libcurl requred

Found my old copy of GSB. It's version 1.56.0 of the game and it still runs fine.

libcurl.so.3 is included in the lib64 subfolder of the game. No idea why yours isn't working, haven't downloaded the game since it got added to this HIB again - mine's from a previous one.

$ ls /usr/lib/libcurl*
/usr/lib/libcurl.a   /usr/lib/libcurl.so.4
/usr/lib/libcurl.so  /usr/lib/libcurl.so.4.2.0
$ ls
data  lib64        GSB.bin.x86_64  GSB.png       version.txt
lib   GSB.bin.x86  GSBManual.pdf   README.linux
$ ls lib64
libcurl.so.3   libogg.so.0     libpng12.so.0    libSDL_image-1.2.so.0  libvorbis.so.0
libjpeg.so.62  libopenal.so.1  libSDL-1.2.so.0  libvorbisfile.so.3
$ cat version.txt 
1:56:0

oooh, even still had the original archive on my HD:

221add4aefd4da39e965b987b9f57fb5  gsb.tar.gz

According to the HIB page, that should still be the file (unless they forgot to update the md5)


Hmm... did you set the right file permissions for the subfolders + libs?

Last edited by whoops (2012-09-27 22:13:29)

Offline

#8 2012-09-28 07:46:17

Linkas
Member
Registered: 2011-12-28
Posts: 25

Re: [solved]Gratuitous Space Battles - Humble I. B. 6. Old libcurl requred

Thank you whoops. My archive has exactly the same md5sum so I exported LD_LIBRARY_PATH to lib64 in game catalog (I extracted the game in home directory) and now game runs.

Offline

#9 2012-09-28 08:08:22

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 5,888
Website

Re: [solved]Gratuitous Space Battles - Humble I. B. 6. Old libcurl requred

*just realised he's been talking to a different person for half the thread*

Glad you got it sorted, Linkas.


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Making lemonade from lemons since 2015.

Offline

Board footer

Powered by FluxBB