You are not logged in.

#1 2012-09-23 08:20:01

takiaine
Member
Registered: 2012-09-23
Posts: 3

MythTV 0.25.2-2 segfaults in libc after update

Hi,

I just updated my htpc and seems like it broke my mythtv setup. I had not updated the system for a while, so I had the glibc /lib -> /usr/lib update among others. I had some problems with the update but finally managed to get the system working exept for the mythtv part.

Every time I start myhtbackend with /etc/rc.d/mythbackend start, I get a segfault line to kernel.log

Sep 23 10:39:50 localhost kernel: [   80.803648] mythbackend[1340]: segfault at ffffffffffffffff ip 00007ff268315a71 sp 00007fffe8c5ecc8 error 6 in libc-2.16.so[7ff26828a000+19e000]

I also tried starting mythfronted(I normally use XBMC as a frontend) and it is also segfaulting. mythtv-setup and mythwelcome are working normally.

Backtrace of mythbackend

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff363ba71 in __memcpy_sse2 () from /usr/lib/libc.so.6
(gdb) bt
#0  0x00007ffff363ba71 in __memcpy_sse2 () from /usr/lib/libc.so.6
#1  0x00007ffff5b604cb in ?? () from /usr/lib/libQtScript.so.4
#2  0x00007ffff5b75d2f in ?? () from /usr/lib/libQtScript.so.4
#3  0x00007ffff5b720b3 in ?? () from /usr/lib/libQtScript.so.4
#4  0x00007ffff5bbee88 in ?? () from /usr/lib/libQtScript.so.4
#5  0x00007ffff5bbf53c in ?? () from /usr/lib/libQtScript.so.4
#6  0x00007ffff5c5fcc0 in ?? () from /usr/lib/libQtScript.so.4
#7  0x00007ffff5c60cb6 in QScriptEngine::QScriptEngine() () from /usr/lib/libQtScript.so.4
#8  0x00007ffff6fde9c0 in ServerSideScripting::ServerSideScripting() () from /usr/lib/libmythupnp-0.25.so.0
#9  0x00007ffff6fdc165 in HtmlServerExtension::HtmlServerExtension(QString, QString) () from /usr/lib/libmythupnp-0.25.so.0
#10 0x00007ffff6fa6a82 in HttpServer::HttpServer(QString) () from /usr/lib/libmythupnp-0.25.so.0
#11 0x00000000004e7e59 in ?? ()
#12 0x000000000050157d in ?? ()
#13 0x0000000000423bbb in ?? ()
#14 0x00007ffff35d1725 in __libc_start_main () from /usr/lib/libc.so.6
#15 0x00000000004247e5 in ?? ()

Is anyone else having problems with mythtv?

Last edited by takiaine (2012-09-23 09:05:14)

Offline

#2 2012-09-24 06:24:18

takiaine
Member
Registered: 2012-09-23
Posts: 3

Re: MythTV 0.25.2-2 segfaults in libc after update

I tested few things and it seems that the latest code in MythTV git(branch fixes/0.25) works without segfault. How ever I have not been able to get it working because it is not co-operating with my current mysql database. I think I may have broken something while trying to get mythtv working... Currently mythtv cannot connect to mysql database and when I try to connect to it from command line with

mysql -u root -p

I get

>ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)

After googling aroung I found out couple of things that I need to check when I get home(One issue might be that mysql is out of space...).

Offline

#3 2012-09-24 08:27:39

sultanoswing
Member
Registered: 2008-07-23
Posts: 286

Re: MythTV 0.25.2-2 segfaults in libc after update

Check mysqld is running. Check your passwords are correct. Try logging in without using a password, and check your login syntax.

That's usually been my problem when I've seen that error.

As to your mythtv error - that's an odd one. My mythtv 0.25.2-2 is working jus' fine. Sorry I can't be of more use, hopefully someone else will chime in. Another option would be to check the gossamer archives: http://www.gossamer-threads.com/lists/mythtv/


Arch 4.4.13-lts (x86_64) w/Gnome 3.20.2
ASUS P7P55-E-Pro, Geforce GT430, i5-750, 8GB, Samsung 830 SSD | Intel NUC 5i5RYK | ASUS ux303ua | HP Folio 13

Offline

#4 2012-09-27 10:35:39

takiaine
Member
Registered: 2012-09-23
Posts: 3

Re: MythTV 0.25.2-2 segfaults in libc after update

The mysql problem came from filled root partition. I erased some old pacman cache packages and mysql started working again.

However the mythtv that I compiled from git segfaults the same way as before. During earlier tests, because mysql was not running, the program just never made to the same point where it segfaulted. Because no one else seem to have the same kind of problems as I am facing, I believe that I managed to brake something related to glibc during the update. So I decided to do a fresh install and after few days of reinstalling and reconfiguring I have mythtv working again with the latest updates.

Now all I need to do is to make some backups, in case the next time when I brake the system...

Offline

#5 2012-09-28 21:25:44

sultanoswing
Member
Registered: 2008-07-23
Posts: 286

Re: MythTV 0.25.2-2 segfaults in libc after update

takiaine wrote:

The mysql problem came from filled root partition. I erased some old pacman cache packages and mysql started working again.

However the mythtv that I compiled from git segfaults the same way as before. During earlier tests, because mysql was not running, the program just never made to the same point where it segfaulted. Because no one else seem to have the same kind of problems as I am facing, I believe that I managed to brake something related to glibc during the update. So I decided to do a fresh install and after few days of reinstalling and reconfiguring I have mythtv working again with the latest updates.

Now all I need to do is to make some backups, in case the next time when I brake the system...


Good to read, although I think you mean "break" not "brake" - you wouldn't want your system slowing down unnecessarily!


Arch 4.4.13-lts (x86_64) w/Gnome 3.20.2
ASUS P7P55-E-Pro, Geforce GT430, i5-750, 8GB, Samsung 830 SSD | Intel NUC 5i5RYK | ASUS ux303ua | HP Folio 13

Offline

Board footer

Powered by FluxBB