You are not logged in.

#1 2012-09-29 15:33:46

darthpenguin
Member
Registered: 2011-09-16
Posts: 77

[SOLVED] System 76 Gazelle Pro odd suspend behavior.

Hi All,

I have Arch running on a System76 Gazelle Pro using Gnome-Shell (in case that's relevant). When I close the lid the laptop suspends to RAM. When I open the lid the laptop attempts to wake, I see the lock screen, but then the computer suspends again. I can wake the laptop by pressing the power button. Any thoughts on why the computer goes back to suspend mode when I open the lid?

Thanks.

Last edited by darthpenguin (2012-10-04 07:36:05)

Offline

#2 2012-09-29 15:48:37

teateawhy
Member
From: GER
Registered: 2012-03-05
Posts: 1,059
Website

Re: [SOLVED] System 76 Gazelle Pro odd suspend behavior.

There are 3 programs competing to do the same. The powermanager of the DE like gnome/Kde , systemd , and acpid.
Choose one of them for suspending and disable the others completely or you will end up with strange behaviour like here.

Offline

#3 2012-09-29 16:09:40

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] System 76 Gazelle Pro odd suspend behavior.

Wow, this issue is so simple, yet is f-ing up so many people.  I think people need to learn the google a bit better.

Offline

#4 2012-09-29 17:07:50

darthpenguin
Member
Registered: 2011-09-16
Posts: 77

Re: [SOLVED] System 76 Gazelle Pro odd suspend behavior.

So, forgive me if this is a dumb question. Which powermanager should I choose? how do I 'disable' the others?

Offline

#5 2012-09-29 18:50:14

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] System 76 Gazelle Pro odd suspend behavior.

man acpid
man logind
man (whatever the heck you call the gnome power manager)

Offline

#6 2012-09-29 19:32:47

darthpenguin
Member
Registered: 2011-09-16
Posts: 77

Re: [SOLVED] System 76 Gazelle Pro odd suspend behavior.

Not helpful man.

I removed acpid with pacman but that didn't make any change. I removed gnome-power-manager and that had no effect. I figured out how to disable acpi by adding acpi=off to my kernal line in grub.cfg (that little trick was fond in a forum *not* in the man pages). But when I rebooted Xorg failed to start. Finally I disabled systemd by removing it from my kernel line and removed the 'acpi=off' as well. Now I am just running acpi (no systemd) and suspend works as intended. Frankly, I'd be happy to not use systemd at all but I remember the only reason I switched to systemd is because my damn clock would keep the right time. If I have to go back to systemd I'll need to figure out this suspend issue.

Offline

#7 2012-09-29 22:03:39

darthpenguin
Member
Registered: 2011-09-16
Posts: 77

Re: [SOLVED] System 76 Gazelle Pro odd suspend behavior.

As I suspected, I need systemd. Without it my computer's date and time settings have locked the location to London, England and I can't enable network time. Any changes I make in the date and time settings in Gnome-Control-Center do not save after I close the control panel. With init=/bin/systemd added to my kernel line the date and time can be properly set. With the help of the wiki I have determined that I can disable systemd suspend by adding "HandleLidSwitch:ignore" to the /etc/systemd/logind.conf file. Now I am using only acpi to suspend the laptop and it sleeps and wakes as expected when I open/close the lid, well... mostly. I noticed that if I try to suspend while a video is running in Totem the system crashes. I'd like to test to see which handles suspend better. Is there anyway to disable acpi to I can test systemd?

Offline

#8 2012-09-29 22:42:34

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] System 76 Gazelle Pro odd suspend behavior.

Offline

#9 2012-09-30 05:10:17

darthpenguin
Member
Registered: 2011-09-16
Posts: 77

Re: [SOLVED] System 76 Gazelle Pro odd suspend behavior.

Dude, I appreciate that you are replying to this tread. I know you are trying to help and I'm sorry if I come across as a Linux novice. But you really aren't helping. ACPI and acpid are not the same thing, cool, thanks for the info, I'll file that information away somewhere for later. But right now, what I really need (and please don't tell me to read the man pages or the wiki... I've done that or I wouldn't be here) what I really, truly, need is a simple straightforward answer to this very simple question. *How can I set acpi to not handle suspend to ram?*

Offline

#10 2012-09-30 05:31:51

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 5,078

Re: [SOLVED] System 76 Gazelle Pro odd suspend behavior.

*How can I set acpi to not handle suspend to ram?*

You can't, really. ACPI is the interface everything uses for power functions. This is why WonderWoofy gave you the links. If you disable ACPI, none of the tools will work.

This really is straight forward, you choose one of the three tools and use it, disabling the others. Systemd handles it with logind, you can tell it what you want it to do in logind.conf, including ignoring the power functions. If you want that to handle it, just uninstall acpid and either uninstall or turn off the Gnome applet. If you want to use acpid, disable the functions in logind.conf and Gnome and configure acpid to your hearts content. If you want to use the Gnome app, turn off the logind options and uninstall acpid.

WonderWoofy is getting frustrated with you because this issue has been discussed half a dozen times over the last two days on this forum alone, and it's really not complicated enough to warrant that.

Last edited by Scimmia (2012-09-30 05:40:20)

Offline

#11 2012-10-04 02:53:07

shinasha
Member
Registered: 2012-08-04
Posts: 19

Re: [SOLVED] System 76 Gazelle Pro odd suspend behavior.

So give the guy the links. I'm sure we've all missed things before. If posts frustrate you don't reply. I get the feeling that some posters enjoy insulting/putting people down more than giving a meaningful post. I'm sure it makes people feel better about themselves but it is less useful than repeating a question. Let's not be hipocrytes.

Offline

#12 2012-10-04 02:59:47

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] System 76 Gazelle Pro odd suspend behavior.

The problem with this thread is that this issue has been raised in these very forums maybe ten times in the past week.  So any search would have yeilded results.

Offline

#13 2012-10-04 07:35:44

darthpenguin
Member
Registered: 2011-09-16
Posts: 77

Re: [SOLVED] System 76 Gazelle Pro odd suspend behavior.

Well, any search did *not* yield results. If it had I wouldn't have opened a thread. I appreciate the reply from teateawhy which got me looking in the right direction. After a lot of tweaking and a little help from the wiki I found the solution. The problem is with systemd. Don't use systemd or -- if you have to use systemd -- add this to the /etc/systemd/logind.conf file.

HandlePowerKey:ignore
HandleSuspendKey:ignore
HandleHibernateKey:ignore
HandleLidSwitch:ignore

I can't 'choose' a program for suspending. I have no choice in the matter. gnome-power-manager is *not* controlling sleep mode and I can't remove acpi without breaking the system.

Offline

#14 2012-10-04 13:14:07

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] System 76 Gazelle Pro odd suspend behavior.

But you can remove acpid

Offline

#15 2012-10-05 12:17:54

shinasha
Member
Registered: 2012-08-04
Posts: 19

Re: [SOLVED] System 76 Gazelle Pro odd suspend behavior.

@WonderWoofy
I understand being frustrated at seeing questions that have already been answered. However, I think some people browse the forums for no particular reason and see posts they can relate to. So, seeing an answer helps. I know you help answer a lot of questions so thanks for that.

Offline

Board footer

Powered by FluxBB