You are not logged in.

#1 2012-09-29 08:36:53

tim91
Member
Registered: 2012-02-16
Posts: 7

[SOLVED] Upgrading after four month (version `GLIBC_2.16' not found)

Hi all!
After some time I decide to upgrade and starting with read the manual at the site.
Firstly, I run

pacman -Syu --ignore glibc,curl

this exit successfully

Secondly,

pacman -Su

but this give me error

pacman: /lib/libc.so.6: version `GLIBC_2.16' not found (required by /usr/lib/libarchive.so.12)

pacman always return this error, so I don't install glibc manually

help me, pls smile

i tried to untar glibc-2.16.0-4

 tar -xvf glibc-2.16.0-4-i686.pkg.tar.xz -C / 

it exit with

tar: lib: Cannot create symlink to `usr/lib': File exists
tar: lib64: Cannot create symlink to `usr/lib': File exists
tar: Exiting with failure status due to previous errors

ok, glibc untared(symlinks created with my hands in ramfs mode), but nothing happens (only kdm not start, but startx works) and error while i'm trying to use pacman is same

pacman: /lib/libc.so.6: version `GLIBC_2.16' not found (required by /usr/lib/libarchive.so.12)

Last edited by tim91 (2012-09-29 15:36:07)

Offline

#2 2012-09-29 10:43:58

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,837

Re: [SOLVED] Upgrading after four month (version `GLIBC_2.16' not found)

Offline

#3 2012-09-29 10:51:25

tim91
Member
Registered: 2012-02-16
Posts: 7

Re: [SOLVED] Upgrading after four month (version `GLIBC_2.16' not found)

@tomk, thanx, i lost step where allan install glibc 2.16 before uograding, at this moment i can't install anymore, because pacman don't work sad

Offline

#4 2012-09-29 15:34:52

tim91
Member
Registered: 2012-02-16
Posts: 7

Re: [SOLVED] Upgrading after four month (version `GLIBC_2.16' not found)

ok, i solve it by reinstalling pacman (untar openssl, libarchive, pacman) and after this pacman -S glibc --force

Offline

#5 2012-09-29 22:27:45

jfnichols
Member
Registered: 2011-05-11
Posts: 2

Re: [SOLVED] Upgrading after four month (version `GLIBC_2.16' not found)

tim, can you explain more how you re-installed pacman? I am having this same issue

Offline

#6 2012-09-29 23:06:29

karol
Archivist
Registered: 2009-05-06
Posts: 25,424

Re: [SOLVED] Upgrading after four month (version `GLIBC_2.16' not found)

jfnichols wrote:

tim, can you explain more how you re-installed pacman? I am having this same issue

This is an old thread, but https://bbs.archlinux.org/viewtopic.php … 8#p1044458

Offline

Board footer

Powered by FluxBB