You are not logged in.

#1 2012-09-29 21:56:45

Dans564
Member
From: New Jersey, USA
Registered: 2011-02-04
Posts: 109

[SOLVED] error while building broadcom-wl

Hey all,

Im getting this error when attempting to build the broadcom-wl drivers from the aur:

make: Entering directory `/usr/src/linux-3.5.4-1-ARCH'
/usr/src/linux-3.5.4-1-ARCH/arch/x86/Makefile:96: CONFIG_X86_X32 enabled but no binutils support
make: *** No rule to make target `Builds/broadcom-wl/src'.  Stop.
make: Leaving directory `/usr/src/linux-3.5.4-1-ARCH'
==> ERROR: A failure occurred in build().
    Aborting...

Any ideas what is going wrong here?

-Dan

Last edited by Dans564 (2012-09-30 19:26:21)

Offline

#2 2012-09-29 22:54:48

Dans564
Member
From: New Jersey, USA
Registered: 2011-02-04
Posts: 109

Re: [SOLVED] error while building broadcom-wl

The answers to a couple of questions people have asked in the IRC:
- yes, I have base-devel installed
- yes, my multilib repo is enabled

Offline

#3 2012-09-30 15:47:56

Dans564
Member
From: New Jersey, USA
Registered: 2011-02-04
Posts: 109

Re: [SOLVED] error while building broadcom-wl

So it's something to do with this line in particular:

/usr/src/linux-3.5.4-1-ARCH/arch/x86/Makefile:96: CONFIG_X86_X32 enabled but no binutils support

  I have looked everywhere and have asked in the IRC, but I can not figure out what is going wrong here

Offline

#4 2012-09-30 17:54:19

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 4,006

Re: [SOLVED] error while building broadcom-wl

What wifi chip do you have and which version of broadcom-wl are you trying to install?


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#5 2012-09-30 18:01:04

Dans564
Member
From: New Jersey, USA
Registered: 2011-02-04
Posts: 109

Re: [SOLVED] error while building broadcom-wl

My WiFi chip is BCM4321. And its broadcom-wl 5.100.82.112-6

Offline

#6 2012-09-30 18:31:11

Dans564
Member
From: New Jersey, USA
Registered: 2011-02-04
Posts: 109

Re: [SOLVED] error while building broadcom-wl

here is my makepkg.conf

and here is my Makefile

I think they might be relevant

Last edited by Dans564 (2012-09-30 18:36:50)

Offline

#7 2012-09-30 18:33:10

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 4,006

Re: [SOLVED] error while building broadcom-wl

4321 usually works with the free b43 driver, I would give it a try.


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#8 2012-09-30 18:38:06

Dans564
Member
From: New Jersey, USA
Registered: 2011-02-04
Posts: 109

Re: [SOLVED] error while building broadcom-wl

OK I'll give it a shot, although historically broadcom-wl has been the only one to work with my setup.  I'll try b43 right now.

Offline

#9 2012-09-30 18:47:11

Dans564
Member
From: New Jersey, USA
Registered: 2011-02-04
Posts: 109

Re: [SOLVED] error while building broadcom-wl

get an error while building b43-firmware as well...

Offline

#10 2012-09-30 18:54:15

Dans564
Member
From: New Jersey, USA
Registered: 2011-02-04
Posts: 109

Re: [SOLVED] error while building broadcom-wl

Other packages, for example google-chrome, build without any errors.  I am baffled.

Offline

#11 2012-09-30 18:58:55

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,110
Website

Re: [SOLVED] error while building broadcom-wl

"Building" google-chrome doesn't involve a compiler. Find a package that actually requires more than repackaging a .deb file.

Offline

#12 2012-09-30 19:04:17

headkase
Member
Registered: 2011-12-06
Posts: 1,842

Re: [SOLVED] error while building broadcom-wl

If I may suggest, build Cower:

https://aur.archlinux.org/packages.php?ID=44921

It is a great program for handling AUR packages.

See some documentation for it here:

https://bbs.archlinux.org/viewtopic.php?id=97137

If you find yourself using AUR packages I greatly recommend using Cower to manage them! smile

Last edited by headkase (2012-09-30 19:06:44)

Offline

#13 2012-09-30 19:04:29

Dans564
Member
From: New Jersey, USA
Registered: 2011-02-04
Posts: 109

Re: [SOLVED] error while building broadcom-wl

sorry, I wasn't aware there was a difference.  could you suggest a package?

EDIT: never mind lol

Last edited by Dans564 (2012-09-30 19:04:57)

Offline

#14 2012-09-30 19:11:48

Dans564
Member
From: New Jersey, USA
Registered: 2011-02-04
Posts: 109

Re: [SOLVED] error while building broadcom-wl

thanks for the suggestion headkase, but makepkg -s fails on cower as well

Offline

#15 2012-09-30 19:17:02

headkase
Member
Registered: 2011-12-06
Posts: 1,842

Re: [SOLVED] error while building broadcom-wl

You should not use the "-s" option (Sync Dependencies), try with just "makepkg" when you are in the PKGBUILD folder?

Offline

#16 2012-09-30 19:18:48

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,110
Website

Re: [SOLVED] error while building broadcom-wl

Heh... build in path that doesn't have spaces in it, i.e. "/home/dan/AURBuilds" not "/home/dan/AUR Builds".

Offline

#17 2012-09-30 19:26:06

Dans564
Member
From: New Jersey, USA
Registered: 2011-02-04
Posts: 109

Re: [SOLVED] error while building broadcom-wl

wow... laugh it up falconindy... it was the space... haha
TWO DAYS! I FEEL SO DUMB!
Thanks guys!
marking as solved....

Offline

#18 2012-10-02 10:52:14

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 4,006

Re: [SOLVED] error while building broadcom-wl

Sanely written PKGBUILDs should work even if the build dir has spaces in them though. But noone ever quotes $srcdir etc sad


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#19 2012-10-02 11:48:26

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,110
Website

Re: [SOLVED] error while building broadcom-wl

This broke in the Makefile, not in the PKGBUILD.

Offline

#20 2013-06-28 22:19:03

karachungen
Member
Registered: 2013-06-28
Posts: 1

Re: [SOLVED] error while building broadcom-wl

Lol, have same problem!

Offline

#21 2013-06-28 22:43:22

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 28,156
Website

Re: [SOLVED] error while building broadcom-wl

Please don't necrobump, especially with an empty post:
https://wiki.archlinux.org/index.php/Fo … Bumping.27


Closing


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

Board footer

Powered by FluxBB