You are not logged in.

#1 2012-10-02 11:34:16

mark-o-solo
Member
Registered: 2012-03-19
Posts: 57

Thinkfan not starting on Lenovo T420

Hi,
After installing thinkfan from AUR, I could not find the /etc/modprobe.d/thinkfan.conf. I then downloaded the default config from the sourceforge package and tried running it via:
rc.d start thinkfan      ...      [FAIL]
I tried:
modprobe thinkpad_acpi
which returns:
libkmod: kmod_config_parse: /etc/modprobe.d/thinkfan.conf line 44: ignoring bad line starting with 'sensor'
The same goes for every uncommented line in thinkfan.conf, which looks like:

sensor /sys/devices/platform/coretemp.0/temp1_input
sensor /sys/devices/platform/coretemp.2/temp1_input
sensor /sys/devices/virtual/hwmon/hwmon0/temp1_input

(0,    0,    55)
(1,    48,    60)
(2,    50,    61)
(3,    52,    63)
(4,    56,    65)
(5,    59,    66)
(7,    63,    3276)

What am I doing wrong ?

Offline

#2 2012-10-02 12:14:45

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,368
Website

Re: Thinkfan not starting on Lenovo T420

Thinkfan.conf should be in /etc not in /etc/modprobe.d.  You need an entry in /etc/modprobe.d/modprobe.conf:
https://wiki.archlinux.org/index.php/Le … kPad_T420s


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#3 2012-10-02 12:15:06

teateawhy
Member
From: GER
Registered: 2012-03-05
Posts: 1,001
Website

Re: Thinkfan not starting on Lenovo T420

You did not read the wiki for Thinkpad T420.
Edit: D'ouh too slow.

Last edited by teateawhy (2012-10-02 12:15:37)

Offline

#4 2012-10-02 12:32:36

mark-o-solo
Member
Registered: 2012-03-19
Posts: 57

Re: Thinkfan not starting on Lenovo T420

Alright, thanks, I did the suggested. It sounds as though thinkfan is running, is there a way for me to check that, the same for tlp ?
Also, on bootup, tp_smapi reports an error, it does not start. Do I need to recompile things like tp_smapi or phc-intel specifically for the ck kernel, or should the standard  modules work just fine ?
Thanks

Offline

#5 2012-10-02 15:34:38

teateawhy
Member
From: GER
Registered: 2012-03-05
Posts: 1,001
Website

Re: Thinkfan not starting on Lenovo T420

https://aur.archlinux.org/packages.php?ID=48087
Modules made for the arch kernel need to be rebuilt. I advise against using an alternative kernel, if you did not know that already.
Also you can check the tlp status with
# tlp-stat
Thinkfan should turn up as a process in ps. Also start it manually to see what happens !

Last edited by teateawhy (2012-10-02 15:35:33)

Offline

#6 2012-10-02 20:53:25

mark-o-solo
Member
Registered: 2012-03-19
Posts: 57

Re: Thinkfan not starting on Lenovo T420

After following all the instructions, thinkfan still is not running. The fan is spinning at 40 degrees (which it shouldent), and I cannot find any entry for thinkfan in htop or ps. However thinkapad_acpi starts without problems.
One other thing: my modprobe.d is empty,I assume this is the result of some recent update, but I had to create a modprobe.conf inside it which now only contains the lines:
options thinkpad_acpi fan_control=1
options snd-hda-intel model=thinkpad
Could this have anything to do with my problem ?
Any further advice is appreciated.
Thanks

Last edited by mark-o-solo (2012-10-02 21:10:50)

Offline

#7 2012-10-04 08:05:32

mark-o-solo
Member
Registered: 2012-03-19
Posts: 57

Re: Thinkfan not starting on Lenovo T420

Anyone ?

Offline

Board footer

Powered by FluxBB