You are not logged in.

#1 2012-10-02 13:11:04

Technicolor
Member
From: Earth
Registered: 2012-09-05
Posts: 32

[SOLVED] Cannot change the lightdm-unity-greeter background

Hi.
So I installed the lightdm-ubuntu and lightdm-unity-greeter (which needed lightdm-ubuntu) from the AUR, and when I read both the wiki and the web, they said that I needed to install the lightdm package, not lightdm-ubuntu (when I install lightdm-ubuntu, it conflicts with lightdm, forcing me to remove it). So I installed it, used it, saw the nice login screen, but I would like to remove the dots showing up over the background AND change the background. I read that there is a config in the /etc/lightdm folder, but when I tried finding it, it was not there.

ls /etc/lightdm showed me:

keys.conf             lightdm-gtk-greeter.conf          users.conf
lightdm.conf          lightdm-gtk-greeter.conf~
lightdm.conf.pacsave  lightdm-gtk-greeter.conf.pacsave

I do not want to have the background of the login the same as my background when I'm logged in, so I don't think gnome-settings-daemon-ubuntu and accountsservice-ubuntu should be needed. And even if they are, I would like to find a way to change it without installing those packages, since I can't install them easily -- this computer is a school computer and is connected through a filter, which unnecessarily blocks many sites (like say, eclipse.org and gnu.org, but that is not the point), and freedesktop.org is one of them.
I would appreciate if anyone knows how to do that.
Thanks.

EDIT: Solved. faidoc's answer was priceless.

Last edited by Technicolor (2012-10-04 13:54:05)

Offline

#2 2012-10-03 22:32:49

faidoc
Trusted User (TU)
From: Spain
Registered: 2009-02-18
Posts: 32
Website

Re: [SOLVED] Cannot change the lightdm-unity-greeter background

You have to edit /usr/share/glib-2.0/schemas/com.canonical.unity-greeter.gschema.xml

And then execute

glib-compile-schemas /usr/share/glib-2.0/schemas/

...to apply the changes

Offline

#3 2012-10-04 13:23:07

Technicolor
Member
From: Earth
Registered: 2012-09-05
Posts: 32

Re: [SOLVED] Cannot change the lightdm-unity-greeter background

faidoc wrote:

You have to edit /usr/share/glib-2.0/schemas/com.canonical.unity-greeter.gschema.xml

And then execute

glib-compile-schemas /usr/share/glib-2.0/schemas/

...to apply the changes

Okay, I did that, I double-checked everything, I rebooted, and now lightdm does not start, nor does slim. I tried startx, but nothing is working. I don't think it did it, but I am simply saying that that's what happened when I rebooted. I am now doing a full system upgrade, so the new catalyst-utils and catalyst-daemon will install. Will reply again if it does not work.

Offline

#4 2012-10-04 13:52:51

Technicolor
Member
From: Earth
Registered: 2012-09-05
Posts: 32

Re: [SOLVED] Cannot change the lightdm-unity-greeter background

faidoc wrote:

You have to edit /usr/share/glib-2.0/schemas/com.canonical.unity-greeter.gschema.xml

And then execute

glib-compile-schemas /usr/share/glib-2.0/schemas/

...to apply the changes

Okay, it was not the change, it was the drivers. I reinstalled them, and now it all works.
Thanks for helping.

Offline

#5 2014-11-05 18:18:26

carongangoo
Member
Registered: 2014-10-22
Posts: 58

Re: [SOLVED] Cannot change the lightdm-unity-greeter background

hi everybody from the Indian Ocean , especially Rodrigues Island-Republic of Mauritius !

I am now running a Archlinux Vm with 3 desktop environemnts such as Gnome, Mate and Xfce4 . I am encounting a conflict file issue between lightdm , lightdm-Ubuntu and lightdm-gtk-greeter.conf !
The system says that lightdm-gtk-greeter.conf creates a conflict and , when installing Unity as per " chenxiaolong :https://github.com/chenxiaolong/Unity-for-Arch" or through the Wiki method I am always stuck ! I don't even have the " /usr/share/glib-2.0/schemas/com.canonical.unity-greeter.gschema.xml" ! The nearest I've got is " com.canonical.unity-gtk-module.gschema " ! This means that even lightdm-ubuntu-greeter cannot be installed ......What must I do ?

Offline

Board footer

Powered by FluxBB