You are not logged in.

#1 2012-10-03 19:22:32

gabe.benson
Member
Registered: 2011-08-16
Posts: 36

[SOLVED] Can't Enable gdm.service in systemd Setup

I'm migrating my system over to a pure systemd setup, and I've run into a snare.  Everything starts just fine, except for gdm.  When I issue "systemctl enable gdm.service", I'm met with "Failed to issue method call: File exists".  If I reboot, it loads everything up and drops me at the tty login prompt.  I can log in to root and issue systemctl start gdm.service and it'll load up gdm and everything will proceed as normal.  I just can't get it to automatically start it up.  Any ideas?

Last edited by gabe.benson (2012-10-04 02:51:59)

Offline

#2 2012-10-03 20:05:12

cbowman57
Member
Registered: 2011-08-21
Posts: 72

Re: [SOLVED] Can't Enable gdm.service in systemd Setup

Can I assume you used sudo or were root when you issued the 'systemctl enable gdm.service' ?

Pretty certain gdm.service comes in systemd-arch-units so make sure that installed.  Beyond that I don't have anything to suggest.

Offline

#3 2012-10-03 20:05:13

rscholer
Member
From: Gelsenkirchen, Germany
Registered: 2008-07-03
Posts: 48

Re: [SOLVED] Can't Enable gdm.service in systemd Setup

What is the output of

systemctl status gdm.service

directly after a reboot?

Offline

#4 2012-10-03 20:13:54

65kid
Member
From: Germany
Registered: 2011-01-26
Posts: 663

Re: [SOLVED] Can't Enable gdm.service in systemd Setup

"systemctl enable" will try to symlink gdm.service to /etc/systemd/system/display-manager.service. My guess is this symlink already exists and systemd fails to overwrite this for some reason (maybe the link is dead?). Just remove display-manager.service and try again.

and gdm.service has already been merged into gdm, no need to install systemd-arch-units.

Offline

#5 2012-10-03 20:57:24

gabe.benson
Member
Registered: 2011-08-16
Posts: 36

Re: [SOLVED] Can't Enable gdm.service in systemd Setup

systemctl status gdm.service output:

gdm.service - Gnome Display Manager
	  Loaded: loaded (/usr/lib/systemd/system/gdm.service; disabled)
	  Active: inactive (dead)
	  CGroup: name=systemd:/system/gdm.service

Last edited by gabe.benson (2012-10-03 20:57:47)

Offline

#6 2012-10-04 02:52:35

gabe.benson
Member
Registered: 2011-08-16
Posts: 36

Re: [SOLVED] Can't Enable gdm.service in systemd Setup

Issue resolved.  I manually removed the display-manager.service symlink, then issued systemctl enable gdm.service again.  Worked just fine.

Offline

#7 2012-10-04 09:01:15

zebulon
Member
Registered: 2008-10-20
Posts: 231

Re: [SOLVED] Can't Enable gdm.service in systemd Setup

You could also use:

systemctl -f enable gdm.service

See the switch -f in the systemd man page or in the output of

systemctl -h

Issue added to the systemd wiki page.

Last edited by zebulon (2012-10-04 09:11:23)

Offline

Board footer

Powered by FluxBB