You are not logged in.

#1 2012-10-03 13:27:02

rnarch
Member
Registered: 2012-03-17
Posts: 292

aasaver not building

I tried building aasaver using PKGBUILD from https://aur.archlinux.org/packages.php?ID=16522 but I am getting following error:

==> Entering fakeroot environment...
==> Starting build()...
  File "./configure", line 27
    '''.replace('%s', PROGRAM_NAME)
      ^
SyntaxError: invalid syntax
==> ERROR: A failure occurred in build().
    Aborting...

I tried removing the '.' at this line in src/aasaver-0.3.2/configure file but it keeps coming back since the tar file is untarred everytime. Also I am not sure if removing '.' will work. Please help.

Last edited by rnarch (2012-10-03 13:27:56)

Offline

#2 2012-10-04 09:09:07

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,151

Re: aasaver not building

That package is rather old and intended for KDE3 .

from aasaver homepage

NOTE This content is the KDE 3 version of the screensaver. I have not uploaded the KDE 4 port here because it is now included with KDE 4 in the kdeartwork module.

Edit :

While it may be interesting / a learning experience to solve the problem, if all you want is the functionality using the native kde4 aasaver would be  much easier.

Last edited by Lone_Wolf (2012-10-04 09:10:55)


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2012-10-04 11:48:54

rnarch
Member
Registered: 2012-03-17
Posts: 292

Re: aasaver not building

Thanks for this important information. I agree that there is no point in persuing this package.

Offline

Board footer

Powered by FluxBB