You are not logged in.

#1 2012-10-02 21:22:01

postino87
Member
Registered: 2012-05-07
Posts: 13

Trackpoint speed/sensitivity

Hi everyone.

I want to be able to permanently set the speed and the sensitivity of my trackpoint.
With the command:
# echo -n xxx > /sys/devices/platform/i8042/serio1/serio2/speed
# echo -n xxx > /sys/devices/platform/i8042/serio1/serio2/sensitivity
I can change the parameters on the fly, but after every reboot the system will reset it.

According to this article  i've added the two line with my settings into rc.local, but nothing seems change. The values are always resetted to the default value.

What can i do to set it as default value, or just to run the command on every startup ?


Thanks to all

Offline

#2 2012-10-02 21:23:31

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Trackpoint speed/sensitivity

Udev rule would be my choice.

Offline

#3 2012-10-04 06:11:21

hunterthomson
Member
Registered: 2008-06-22
Posts: 794
Website

Re: Trackpoint speed/sensitivity

If you are using systemd. You could write a bash script and put it in like /usr/local/bin  then write a unit file

This is what I did to run a script to setup a complex tap, br0 network for VM's (though it seems I should be doing this with netcfg, as I use netcfg anyway, Note: I freaking love netcfg)

/usr/lib/systemd/system/virt-network.service

[Unit]
Description=This runs the script to setup the bridge network, down-virt-network.sh to take down

[Service]
Type=oneshot
ExecStart=/usr/local/bin/up-virt-network.sh

[Install]
WantedBy=multi-user.target

Then enable it

systemctl enable virt-network.service

Last edited by hunterthomson (2012-10-04 06:12:49)


OpenBSD-current Thinkpad X230, i7-3520M, 16GB CL9 Kingston, Samsung 830 256GB
Contributor: linux-grsec

Offline

#4 2012-10-04 08:18:35

moetunes
Member
From: A comfortable couch
Registered: 2010-10-09
Posts: 1,013

Re: Trackpoint speed/sensitivity

The trackpoint parameters won't be used until X starts. Somewhere in /etc/X11/xorg.conf.d would be a better place to set them afaik.
Maybe this will help http://www.thinkwiki.org/wiki/How_to_co … org.conf.d


You're just jealous because the voices only talk to me.

Offline

#5 2012-10-04 13:39:21

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Trackpoint speed/sensitivity

moetunes wrote:

The trackpoint parameters won't be used until X starts.

Hey, that is really interesting.  I guess I never thought to look at whether or not it was acutally changing.  I just made a udev rule and went about my business.  But after a reboot, it is definitely still at 128.  Guess I will have to find a better way.


Edit: further down the page on that link, it mentions the "WAIT_FOR" udev parameter.  That should do the trick.

Last edited by WonderWoofy (2012-10-04 13:45:01)

Offline

Board footer

Powered by FluxBB