You are not logged in.

#4301 2012-09-27 23:11:55

jfernyhough
Member
Registered: 2012-09-26
Posts: 5

Re: The AMD/ATI Bar & Grill

I'm not sure if this will be useful to Arch but the Ubuntu package has just been given some juice that should (apparently, just about to test) let it work  gets it working on xserver 1.13:

* debian/rules:
    - Make it possible to set the xserver ABIs in debian/substvars.

https://launchpad.net/ubuntu/quantal/+s … 0-0ubuntu1

Last edited by jfernyhough (2012-09-27 23:53:17)


1) Dell Studio 1749: i5 540 (2.5GHz), 8GB, ATi 5650, Intel 5300AGN, XFCE@U13.10x64
2) IBM X61: C2D T7200, 2GB, Intel Centrino, XFCE@U13.10x64
3) Compaq Mini 311c: Atom N270 (OC@2.0GHz), 3GB, Nvidia ION, Broadcom G+BT, KDE@U13.10x32
Comms: HTC Desire Z@JB4.2 (Flinny Andromadus CM10.1)

Offline

#4302 2012-09-27 23:41:01

12eason
Member
Registered: 2010-07-20
Posts: 98

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

Generator creates single fglrx module for each kernel. That's different story.
I never heard about anyone even trying to do what you want to do...

My little brain can't imagine how it would be possible to load two fglrx modules, separatelly for two different gpus - i'm not saying that it's impossible, but it would be very hard
Try to ask @ phoronix forums smile

Okay, I'll give them a go. The problem seems to be that ATI are using the same flgrx module for 2 distinct sets of cards, so it seems we have two versions of the same module. It's utterly retarded if you ask me. We should be getting dedicated kernel modules for each driver. I can now run an nvidia card and an ATI card on the same box, yet not two ATI cards that are a few years apart.

Last edited by 12eason (2012-09-27 23:41:45)

Offline

#4303 2012-09-28 06:35:28

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

jfernyhough wrote:

I'm not sure if this will be useful to Arch but the Ubuntu package has just been given some juice that should (apparently, just about to test) let it work  gets it working on xserver 1.13:

* debian/rules:
    - Make it possible to set the xserver ABIs in debian/substvars.

https://launchpad.net/ubuntu/quantal/+s … 0-0ubuntu1

Looks like ubuntu dev didn' test it and blindly put xserver abi 13 into depends... (maybe dev though it would work because amd said it's initially supports xserver 1.13 ubuntu 12.10)

Anyhow i tested it, others (also ubuntu users) tested it and it's not working.
Also: i haven't seen a community patch that brings support of new xserver; believe that to bring such a thing you need to patch and recompile whole driver,not only fglrx module - so imho only amd could do it.


Edit: Strange... one guy on ubuntu said it's working...
Looks like i had to test xserver 1.13, i didn't actually test it on beta - just on 12.9 for emb devs, but since it's almost the same i assumed (correctly i believe) that those 3 changed files won't change a thing so won't bring support, though i would like to be surprised smile
I would be able to test it within 6 hours

tro lo lol - looks like it's working also for you, jfernyhough @ ubuntu smile

If some tester have time now (s)he can compile Det's xorg-server-dev @ AUR, change xorg-server dep of catalyst-test + rebuild it and try to run it :>
Maybe those three files are actually changing things (fingers crossed), i really would like to see that my assumption was wrong here :>

Last edited by Vi0L0 (2012-09-28 09:50:40)

Offline

#4304 2012-09-28 09:50:45

Xemertix
Member
Registered: 2009-04-09
Posts: 66

Re: The AMD/ATI Bar & Grill

I have a problem with catalyst 12.8:  I cannot use VT consoles they are filled with test,pc doesnt do reboot/shutdown properly,the monitor remains filled with test...
3D and 2D work OK instead.
Can I do something? or is it a bug of 12.8 series?

http://imageshack.us/photo/my-images/40/p9280013d.jpg/

I have an ati 6670,linux  3.5.3,xorg-server 1.12.4,kde 4.9.1

Offline

#4305 2012-09-28 11:10:35

Cdh
Member
Registered: 2009-02-03
Posts: 1,098

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

If some tester have time now (s)he can compile Det's xorg-server-dev @ AUR, change xorg-server dep of catalyst-test + rebuild it and try to run it :>

I use catalyst-test -2 from aur and on HD 6550M I still have the unsupported hardware watermark.

With xorg git master I get

[     2.379] (EE) Failed to load /usr/lib/xorg/modules/drivers/fglrx_drv.so: /usr/lib/xorg/modules/drivers/fglrx_drv.so: undefined symbol: noXFree86DRIExtension

฿ 18PRsqbZCrwPUrVnJe1BZvza7bwSDbpxZz

Offline

#4306 2012-09-28 16:18:42

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

Cdh wrote:
Vi0L0 wrote:

If some tester have time now (s)he can compile Det's xorg-server-dev @ AUR, change xorg-server dep of catalyst-test + rebuild it and try to run it :>

With xorg git master I get

[     2.379] (EE) Failed to load /usr/lib/xorg/modules/drivers/fglrx_drv.so: /usr/lib/xorg/modules/drivers/fglrx_drv.so: undefined symbol: noXFree86DRIExtension

Same here with -dev 1.13

i asked @ phoronix forums #22:

Vi0L0 wrote:

Got some question to non-ubuntu (maybe non-debian) users:
are you able to use this driver with xorg-server 1.13?

As an Arch user i'm not able to start X, still getting Xorg.log' error: (...)

I can see that also Mageia user is getting same error.


I did some quick research but don't see anything special in ubuntu's fglrx...
Although ubuntu's xserver 1.13 is patched with "tons" of patches.
Question: is it possible that 12.9 beta supports only ubuntu's xserver



EDIT:
Kano was right! 12.9 beta and driver for ubuntu differs.
I wasn't able to start X with xserver 1.13 using ubuntu driver, but maybe you will succed (?) - for me there's no error in Xorg.log now, just black screen (read mentioned phoronix forum for details), maybe my gpu sin't supported (?)

Here's the source to build catalyst-test package from ubuntu's one: http://catalyst.apocalypsus.net/files/c … src.tar.gz

Last edited by Vi0L0 (2012-09-28 19:39:09)

Offline

#4307 2012-09-28 21:14:47

Cdh
Member
Registered: 2009-02-03
Posts: 1,098

Re: The AMD/ATI Bar & Grill

Your catalyst-test-12.9-3.src.tar.gz works for me.
xorg git master, just compiled:

X.Org X Server 1.13.0

$ fglrxinfo
display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Mobility Radeon HD 5000 Series 
OpenGL version string: 4.2.11903 Compatibility Profile Context

I also discovered:

[   288.510] (==) fglrx(0): board vendor info: third party graphics adapter - NOT original AMD
...
[   288.595] (WW) fglrx(0): board is an unknown third party board, chipset is supported

Dear AMD, why would you allow oems to modify your boards? Do you want to create problems?

Well, the unsupported hardware watermark is gone and it seems to run.

edit: also,
if you install the new catalyst and don't reboot you're gonna have a bad time.
Somehow reloading the fglrx kernel module and xorg is not enough?
On X start without reboot after the catalyst update I got

[ 4792.449000] <6>[fglrx] ATIF platform detected with notification ID: 0x81
[ 4792.449819] <3>[fglrx:firegl_get_vbios_image] *ERROR* Invalid image size requested

I didn't get it after a reboot.

Last edited by Cdh (2012-09-28 21:16:47)


฿ 18PRsqbZCrwPUrVnJe1BZvza7bwSDbpxZz

Offline

#4308 2012-09-29 22:18:41

Commander
Member
Registered: 2011-02-12
Posts: 36

Re: The AMD/ATI Bar & Grill

Hm the Catalyst-test is working better than the old beta. Only few rendering issues in EVE-Online (portraits and few other things are not rendered properly) kwin and rest of the game is rendered OK so will probably stick with these.

Offline

#4309 2012-09-30 15:30:26

arutemus
Member
Registered: 2012-09-30
Posts: 2

Re: The AMD/ATI Bar & Grill

Vi0L0, You have to edit the "catalyst-PKGBUILD" file in all your packages for using patches. Since new package the patch-2.7.1-1 released, you need to use an option "--follow-symlinks" for working with symlinks or you can just change all "ln -s" to "cp" OR better just make normal PKGBILD with source=()

Last edited by arutemus (2012-09-30 22:27:12)

Offline

#4310 2012-10-01 06:18:09

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

arutemus wrote:

Vi0L0, You have to edit the "catalyst-PKGBUILD" file in all your packages for using patches. Since new package the patch-2.7.1-1 released, you need to use an option "--follow-symlinks" for working with symlinks or you can just change all "ln -s" to "cp" OR better just make normal PKGBILD with source=()

Thanks for this important info!
Unfortunatelly i'm away from my pc and i won't be able to perform update atm... I will try to do this asap but could be that i will be afk for 6 days sad

Offline

#4311 2012-10-01 18:59:00

coproduct
Member
Registered: 2011-09-30
Posts: 22

Re: The AMD/ATI Bar & Grill

I get the following error when trying to build it using:

$ catalyst_build_module 3.5.4-1-ARCH
...
File Makefile is not a regular file -- refusing to patch
1 out of 1 hunk ignored -- saving rejects to file Makefile.rej
==> Error: A failure occurred in build().
Aborting..

This is with catalyst-hd234k x86_64.

Offline

#4312 2012-10-01 20:00:26

Radioactiveman
Member
From: Germany
Registered: 2010-05-13
Posts: 376

Re: The AMD/ATI Bar & Grill

Read the post above yours...

Offline

#4313 2012-10-01 22:42:42

lordheavy
Developer
From: France
Registered: 2010-04-01
Posts: 200

Re: The AMD/ATI Bar & Grill

I've pushed a package 'catalyst-dkms' in the community-testing repo that should replace catalyst one, that doesn't respect the AMD licence.

Please test.

Offline

#4314 2012-10-02 08:16:34

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,471
Website

Re: The AMD/ATI Bar & Grill

lordheavy wrote:

I've pushed a package 'catalyst-dkms' in the community-testing repo that should replace catalyst one, that doesn't respect the AMD licence.

Please test.

I might have missed it, but how will you deal with holding back Xorg versions?


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Offline

#4315 2012-10-02 12:10:33

lordheavy
Developer
From: France
Registered: 2010-04-01
Posts: 200

Re: The AMD/ATI Bar & Grill

Unia wrote:
lordheavy wrote:

I've pushed a package 'catalyst-dkms' in the community-testing repo that should replace catalyst one, that doesn't respect the AMD licence.

Please test.

I might have missed it, but how will you deal with holding back Xorg versions?

Let's hope that AMD will release  drivers that support Xorg 1.13, Otherwise, bad luck!

Offline

#4316 2012-10-02 12:13:25

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 672

Re: The AMD/ATI Bar & Grill

lordheavy wrote:
Unia wrote:
lordheavy wrote:

I've pushed a package 'catalyst-dkms' in the community-testing repo that should replace catalyst one, that doesn't respect the AMD licence.

Please test.

I might have missed it, but how will you deal with holding back Xorg versions?

Let's hope that AMD will release  drivers that support Xorg 1.13, Otherwise, bad luck!

On the  long run this approach will provide you many headaches, lordheavy. I think catalyst is not ready for official repos, and it will not be until AMD commits itself to prompt support for new kernels and xorg servers.

Offline

#4317 2012-10-02 17:17:11

Cdh
Member
Registered: 2009-02-03
Posts: 1,098

Re: The AMD/ATI Bar & Grill

lordheavy wrote:

Let's hope that AMD will release  drivers that support Xorg 1.13, Otherwise, bad luck!

At the moment I run the ubuntu fglrx with xorg git (20120928-1). It works.

 grep -i version /var/log/Xorg.0.log
[     2.290] X Protocol Version 11, Revision 0
[     2.290] Current version of pixman: 0.26.2
        to make sure that you have the latest version.
[     2.295] (II) Module ABI versions:
[     2.308]    compiled for 6.9.0, module version = 1.0.0
[     2.371]    compiled for 1.4.99.906, module version = 9.0.2
[     2.376]    compiled for 1.4.99.906, module version = 9.0.2
[     2.376] (II) AMD Proprietary Linux Driver Version Identifier:9.00.2
[     2.596]    compiled for 1.13.0, module version = 0.1.0
[     2.596]    ABI class: X.Org Video Driver, version 13.0
[     2.596]    compiled for 1.4.99.906, module version = 9.0.2
[     2.796]    compiled for 1.13.0, module version = 1.1.0
[     2.796]    ABI class: X.Org Video Driver, version 13.0
[     2.796] (II) fglrx(0): VESA VBE Version 3.0
[     2.797]    compiled for 1.13.0, module version = 1.0.0
[     2.797]    ABI class: X.Org ANSI C Emulation, version 0.4
[     2.947] (II) fglrx(0): EDID Version: 1.3
[     2.947] (II) fglrx(0): EDID Version: 1.3
[     2.948] (II) fglrx(0): [uki] DRM interface version 1.0
[     2.948] (II) fglrx(0): Kernel Module Version Information:
[     2.948] (II) fglrx(0):     Version: 9.0.2
[     2.948] (II) fglrx(0): Kernel Module version matches driver.
[     2.948] (II) fglrx(0):     Build-Kernel MODVERSIONS:        no
[     2.969]    compiled for 1.4.99.906, module version = 1.0.0
[     2.972]    compiled for 1.4.99.906, module version = 2.0.0
[     4.871]    compiled for 1.13.0, module version = 2.7.0
[     4.871]    ABI class: X.Org XInput driver, version 18.0
[     4.903]    compiled for 1.13.0, module version = 1.6.99
[     4.903]    ABI class: X.Org XInput driver, version 18.0

AMD Proprietary Linux Driver Version Identifier:9.00.2
compiled for 1.13.0, module version = 1.0.0
ABI class: X.Org Video Driver, version 13.0


฿ 18PRsqbZCrwPUrVnJe1BZvza7bwSDbpxZz

Offline

#4318 2012-10-03 04:09:49

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 672

Re: The AMD/ATI Bar & Grill

Catalyst hit the community repo. Let's see what happens when new kernel/xorg-server is released. BTW, is there any plan to support old HD 2000/3000/4000 with a legacy driver, lordheavy? Thanks

Offline

#4319 2012-10-04 15:12:00

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,471
Website

Re: The AMD/ATI Bar & Grill

Lordheavy, I just switched to Catalyst from [community] instead of from AUR. It seems to work great (system runs for ~5minutes now tongue), however, I did need to install linux-headers for dkms. I have some questions, too;

1. Will you also provide xvba-video? (https://aur.archlinux.org/packages.php?ID=31723) I vaguely remember you saying you planned on doing this, but I'm not sure. If so, can you give us an estimation for when this will be ready?
2. I guess that by saying bad luck!, you will drop Catalyst once a new, incompatible xorg package comes down? If so, will you pick Catalyst up again when a new version comes that is compatible?

EDIT: @everyone: The Wiki article on Catalyst is a complete mess. Should I try to clean it up a bit and add the new info that's not there yet?

Last edited by Unia (2012-10-04 15:26:28)


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Offline

#4320 2012-10-04 15:52:34

lordheavy
Developer
From: France
Registered: 2010-04-01
Posts: 200

Re: The AMD/ATI Bar & Grill

snack wrote:

Catalyst hit the community repo. Let's see what happens when new kernel/xorg-server is released. BTW, is there any plan to support old HD 2000/3000/4000 with a legacy driver, lordheavy? Thanks

If the catalyst-legacy can work with xorg-xserver 1.13 it will be in the community repo too.

Offline

#4321 2012-10-04 15:58:36

lordheavy
Developer
From: France
Registered: 2010-04-01
Posts: 200

Re: The AMD/ATI Bar & Grill

Unia wrote:

Lordheavy, I just switched to Catalyst from [community] instead of from AUR. It seems to work great (system runs for ~5minutes now tongue), however, I did need to install linux-headers for dkms. I have some questions, too;

1. Will you also provide xvba-video? (https://aur.archlinux.org/packages.php?ID=31723) I vaguely remember you saying you planned on doing this, but I'm not sure. If so, can you give us an estimation for when this will be ready?
2. I guess that by saying bad luck!, you will drop Catalyst once a new, incompatible xorg package comes down? If so, will you pick Catalyst up again when a new version comes that is compatible?

EDIT: @everyone: The Wiki article on Catalyst is a complete mess. Should I try to clean it up a bit and add the new info that's not there yet?

You need kernel-(lts-)headers, because dkms compile the fglrx module when needed (on installation, kernel upgrade).

1. Yes, it's planned. I've already tested it on my E450 laptop.
2. If no solutions (from AMD or third party) are available, it will stay broken until one is available. There is the Mesa drivers as a fallback available.
3. No catalyst-legacy until it can work with xorg-server 1.13, i don't want a package that will stay permanently broken.

Offline

#4322 2012-10-04 15:59:26

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 672

Re: The AMD/ATI Bar & Grill

lordheavy wrote:
snack wrote:

Catalyst hit the community repo. Let's see what happens when new kernel/xorg-server is released. BTW, is there any plan to support old HD 2000/3000/4000 with a legacy driver, lordheavy? Thanks

If the catalyst-legacy can work with xorg-xserver 1.13 it will be in the community repo too.

It currently does, but what if you put it in the repo, then a new xorg-server is released and legacy driver doesn't work with it? You'll remove the driver? Then maybe AMD will update it to work with the new xorg-server (it usually take months, but it happens), maybe you put it back in the repo and maybe next xorg-server breaks compatibility again... I think the only sane way to deal with this is Vi0l0's way of having unofficial catalyst repo and backward-compatibility repos for xorg-servers...

Offline

#4323 2012-10-04 21:21:58

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,471
Website

Re: The AMD/ATI Bar & Grill

lordheavy wrote:

You need kernel-(lts-)headers, because dkms compile the fglrx module when needed (on installation, kernel upgrade).

I know this, it's just that I think this should be installed as a dependency with dkms. There's no other use for dkms than building kernel modules, is there?

lordheavy wrote:

1. Yes, it's planned. I've already tested it on my E450 laptop.
2. If no solutions (from AMD or third party) are available, it will stay broken until one is available. There is the Mesa drivers as a fallback available.
3. No catalyst-legacy until it can work with xorg-server 1.13, i don't want a package that will stay permanently broken.

1. Great! If you need another tester, feel free to send me the packages and I'll test wink I don't know if it matters, but I have a Mobility Radeon HD5470.
2. So, you will leave the package in the repo's? In combination with Vi0L0's backported Xorg repositories, this could be a solution. Perhaps you can even instruct users to use this by mentioning it in the install file.
3. Same for option 2: if we can combine this with Vi0L0's Xorg repo's and a note in the install file, this could work.

Last edited by Unia (2012-10-04 21:23:02)


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Offline

#4324 2012-10-04 22:35:01

nomorewindows
Member
Registered: 2010-04-03
Posts: 2,980

Re: The AMD/ATI Bar & Grill

I've tried catalyst for my ATI radeon 7K visiontek which is a dual monitor card and it doesn't recognize it (using ati-config), so it is back to xf86-video-ati.  Trying to get this to work with a onboard intel.  Yes, one monitor on the onboard, and two on the ATI add-in.  I can't get it to all work out at the same time.  The graphics get all choppy if I think I've got all three going at the same time.  I think that changing the virtual desktop might help, because the resolutions go past the standard 4096x4096 by just a little bit.  Maybe I can resize the virtual desktop so that it fits the same 4096x4096 but increasing x, and I'm not going that far into y.  The best I've been able to do lately is get the intel on one screen, and the two monitors to duplicate the same screen.

Last edited by nomorewindows (2012-10-05 00:35:22)


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#4325 2012-10-05 05:18:03

32reg
Member
Registered: 2012-08-06
Posts: 23
Website

Re: The AMD/ATI Bar & Grill

Vi0L0, could you rename catalyst-utils and lib32-catalyst-utils packages in your catalyst-234hd repo, please? Because packages with same names now is in community repo. Yesterday i tried do:

pacman -Syu

and got error:

aticonfig --initial
aticonfig: device not found (or something like this)

because these packages are updated from 12.6 to 12.8 version, which is unsupported my ATI HD 4870.


http://linux32.ru - blog about linux

Offline

Board footer

Powered by FluxBB