You are not logged in.

#1 2012-10-05 02:02:06

graysky
Member
From: /run/user/1000
Registered: 2008-12-01
Posts: 8,423
Website

Newbie zsh question: why does hitting ENTER product an "M"

Embarrassing that I can't find out the answer to this one... why does hitting the ENTER key cause my zsh to display the letter M at the prompt?

My configuration files:
Link to ~/.zshrc
Link to ~/.zsh


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#2 2012-10-05 02:05:14

karol
Archivist
Registered: 2009-05-06
Posts: 25,424

Re: Newbie zsh question: why does hitting ENTER product an "M"

A wild guess: there are some issues with the hostname: https://bugs.archlinux.org/task/31765

Offline

#3 2012-10-05 02:38:12

ataraxia
Member
From: Pittsburgh
Registered: 2007-05-06
Posts: 1,537

Re: Newbie zsh question: why does hitting ENTER product an "M"

Possibly related, is that Ctrl-M is a newline character. Something might be screwing up the state of your terminal.

Offline

#4 2012-10-05 08:11:26

graysky
Member
From: /run/user/1000
Registered: 2008-12-01
Posts: 8,423
Website

Re: Newbie zsh question: why does hitting ENTER product an "M"

@karol - Thanks for the suggestion; no initscripts installed... I finally turned to the darkside smile
@ataraxia - Not sure... if I totally remove the scriptlets in ~/.zsh from getting sources I do not have this problem so I'm thinking that it is SOMETHING in one of them.  If I remove them all, then source ~/.zshrc I don't have the problem.  If I add them back one-by-one and resource ~/.zshrc, the problem seems to return somewhat sporadically.  Which confuses the piss out of me.  This is why I am appealing to higher powers smile

Please keep the suggestions coming.

Last edited by graysky (2012-10-05 08:11:47)


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#5 2014-06-15 22:08:02

deltaecho
Member
From: Seattle, Washington (USA)
Registered: 2008-08-06
Posts: 182

Re: Newbie zsh question: why does hitting ENTER product an "M"

The issue may be related to your stty settings.  Try mapping carriage returns to newlines with the following command:

stty icrnl

If that works, add it to your .zshrc

You can check whether you have this mapping set already by running

stty -a

If you see the option, "-icrnl", then the mapping is currently disabled.  If it is not prefixed with "-" (i.e. "icrnl") then the option is currently enabled.  Also be mindful that you do not map newlines to carriage returns with the option "inlcr".

For more info:

man stty

Edit (2014-06-15)

I know the topic's old, but was unanswered.

Last edited by deltaecho (2014-06-15 22:09:31)


Dylon

Offline

#6 2014-06-15 22:55:07

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,354
Website

Re: Newbie zsh question: why does hitting ENTER product an "M"

I'm guessing graysky has long since solved this.
https://wiki.archlinux.org/index.php/Fo … Bumping.27



Closing


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Online

Board footer

Powered by FluxBB