You are not logged in.

#1 2012-10-05 12:22:34

arkhon
Member
Registered: 2012-10-05
Posts: 4

[SOLVED] suspend issue after update

Hey Archers,

i've installed arch 2 weeks ago on my t400. its a systemd only system and worked very well.

since an update a few day ago i have a weird problem with suspend.
If i close the lid the laptop suspends as expectet. After opening the lid the laptop resumes and i get a glimpse at the gnome lock screen but now  the laptop suspends again. if i hit the power button it resumes and i can use the laptop normaly.

ive no clue what could have caused the change because i installed nothing new and didnt fiddle with any config files.

maybe some has any idea what could cause this strange behavior.

Last edited by arkhon (2012-10-05 13:47:23)

Offline

#2 2012-10-05 13:22:07

bwat47
Member
Registered: 2009-10-07
Posts: 637

Re: [SOLVED] suspend issue after update

This is due to a systemd update adding some new features to logind, and the defaults conflicts a bit with gnome.

edit /etc/systemd/logind.conf and set HandleSuspendKey=ignore and HandleLidSwitch=ignore. This will stop systemd from handling events from the suspend key or lid switch, leaving it only up to gnome.

On my machine I also had to set HandlePowerKey=ignore, because hitting the power button was immediately shutting my system down, instead of suspending (which is the gnome default)

Last edited by bwat47 (2012-10-05 13:23:20)

Offline

#3 2012-10-05 13:48:22

arkhon
Member
Registered: 2012-10-05
Posts: 4

Re: [SOLVED] suspend issue after update

Thank you very much. Exactly the the help i needed!

marked as solved.

Offline

#4 2012-10-05 20:07:26

nixpunk
Member
Registered: 2009-11-23
Posts: 268

Re: [SOLVED] suspend issue after update

Just an FYI for anyone else searching for help; the issue can/will occur with Xfce4 as well.

Offline

Board footer

Powered by FluxBB