You are not logged in.

#1 2012-10-05 20:50:05

dhavalparmar
Member
Registered: 2012-10-05
Posts: 8

[Solved] Permission issues for automounted devices in Gnome 3

I am unable to write into any device after it has been automounted in Gnome 3. I get the following error:

There was an error copying the file into /run/media/dhaval/3C2E3A4E2E3A0206. Permission denied.

I set up Gnome 3 according to the instructions in the wiki. Searching through the forums did not lead to any results.

This happens with all external devices and also with my internal secondary hard drive.

Last edited by dhavalparmar (2012-10-07 00:40:32)

Offline

#2 2012-10-05 22:58:00

mariusmeyer
Member
From: Norway
Registered: 2009-04-25
Posts: 244

Re: [Solved] Permission issues for automounted devices in Gnome 3

What specific things have you tried to fix the issue?

Offline

#3 2012-10-05 23:25:47

dhavalparmar
Member
Registered: 2012-10-05
Posts: 8

Re: [Solved] Permission issues for automounted devices in Gnome 3

I have no idea what to try. If you could give me a list of things I should try, or point me to any relevant forum link, it would be very helpful.

Offline

#4 2012-10-06 00:07:13

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,740

Re: [Solved] Permission issues for automounted devices in Gnome 3

What filesystem?

Last edited by Mr.Elendig (2012-10-06 00:07:40)


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Online

#5 2012-10-06 00:19:21

dhavalparmar
Member
Registered: 2012-10-05
Posts: 8

Re: [Solved] Permission issues for automounted devices in Gnome 3

Happens with NTFS and FAT32

Offline

#6 2012-10-06 09:02:00

mariusmeyer
Member
From: Norway
Registered: 2009-04-25
Posts: 244

Re: [Solved] Permission issues for automounted devices in Gnome 3

What groups is your user part of? Do you have the partitions of your second internal drive in fstab? If so, cope the line here.

Offline

#7 2012-10-06 10:50:52

pomhg
Member
Registered: 2010-12-17
Posts: 19

Re: [Solved] Permission issues for automounted devices in Gnome 3

Maybe you need ntfs-3g.

Offline

#8 2012-10-07 00:37:56

dhavalparmar
Member
Registered: 2012-10-05
Posts: 8

Re: [Solved] Permission issues for automounted devices in Gnome 3

Solved!!
Installed ntfs-3g and ntfsprogs. Everything works now.

Thank you so much everyone for helping me out! smile

Offline

Board footer

Powered by FluxBB