You are not logged in.

#1 2012-10-01 07:35:39

Expez
Member
Registered: 2012-03-31
Posts: 9

MPD won't play AAC files from Streamripper

I'm having some problems playing AAC files created by streamripper.  The files play just fine in Mplayer. This is the output I get in .mpd/log:

faad: error decoding AAC stream: Invalid number of channels

After googling I got the impression this might be a DRM issue.  I'm ripping a service I'm paying for (I only like about 80% of the music so I want to be able to skip tracks), so this seemed likely. On #mpd I was informed that mplayer wouldn't have played these files if they were DRM protected, so I've abandoned this line of investigation.

If I try to run one of these files through faad I get:

Error: Bitstream value not allowed by specification

Is this fixable?

Offline

#2 2012-10-01 08:18:56

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: MPD won't play AAC files from Streamripper

Did you google the error? You can't be the only one with this problem. Try converting it to something else, or rip it in some other format (OGG/Vorbis, MP3).

Also, see: https://wiki.archlinux.org/index.php/Fo … e#Legality


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#3 2012-10-01 09:32:44

arutemus
Member
Registered: 2012-09-30
Posts: 2

Re: MPD won't play AAC files from Streamripper

It seems you just need to rebuild your mdp package, because mpd supports AAC via ffmpeg but  new ffmpeg libs released yesteraday and you still have mpd built for old ffmpeg's libs.

Use ABS for this and if all will be ok then report bug.

I have the same problem from yesterday but with the moc  https://bugs.archlinux.org/task/31743

Last edited by arutemus (2012-10-01 09:33:26)

Offline

#4 2012-10-06 10:23:39

Expez
Member
Registered: 2012-03-31
Posts: 9

Re: MPD won't play AAC files from Streamripper

arutemus wrote:

It seems you just need to rebuild your mdp package, because mpd supports AAC via ffmpeg but  new ffmpeg libs released yesteraday and you still have mpd built for old ffmpeg's libs.

Use ABS for this and if all will be ok then report bug.

I have the same problem from yesterday but with the moc  https://bugs.archlinux.org/task/31743

Doesn't the log message indicate that MPD uses faad to decode AAC file and not ffmpeg? A new version of MPD came right out after your post; it did not solve my problem.  For now I'm manually converting the files from AAC to ogg in order to play them, using the latest version of ffmpeg.

Last edited by Expez (2012-10-06 10:24:02)

Offline

Board footer

Powered by FluxBB