You are not logged in.

#1 2012-10-06 23:28:37

Registered: 2011-06-14
Posts: 16

[SOLVED] Borderless URXVT/Awesome WM

Hello friends and expatriates,

I use Windows 95....err, I mean Arch with Awesome WM with urxvt.  When I attempt to make urxvt borderless, the terminal only opens up in the upper left hand corner and any and all other urxvt terminals open up on top of that terminal in the left had corner.  When I comment out urxvt*borderLess or just put urxvt*borderless (no capital L) I have borders and all my terminals open up nice and tiled and all that neat stuff.  Here is my .Xresources.  And help, suggestions, guidance or outright insults would be appreciated.

urxvt*colorMode: on
urxvt*cursorBlink: true
urxvt*cursorUnderline: false
!urxvt*cursorColor: #ff6233
urxvt*cursorColor: #8ebdde
urxvt*underlineColor: #8ebdde
urxvt*highlightColor: #8ebdde
urxvt*highlightTextColor: #070707

*background: #000000
*foreground: #ffffff

*color0: #343639
*color8: #404040
*color1: #2f4d80
*color9: #7791e0
*color2: #424242
*color10: #828a8c
*color3: #6b8ba3
*color11: #8ebdde
*color4: #273a87
*color12: #3955c4
*color5: #74637d
*color13: #927d9e
*color6: #556c85
*color14: #6e98b8
*color7: #b2b2b2
*color15: #bdbdbd

urxvt*scrollBar: false
urxvt*borderLess: true
urxvt*geometry: 60x30
urxvt*saveLines: 1000000000
urxvt*buffered: true
URxvt.depth: 32
URxvt.background: [40]#000000

Xft.dpi: 96
Xft.antialias: true
Xft.rgba: rgb
Xft.autohint: false
Xft.hinting: true
Xft.hintstyle: hintslight
Xft.lcdfilter: lcddefault

urxvt*font: xft:tamsyn:pixelsize=11
URxvt*perl-lib: /usr/lib/urxvt/perl
URxvt*perl-ext-common: default,matcher,keyboard-select
URxvt.keysym.M-Escape: perl:keyboard-select:activate
URxvt.keysym.M-s: perl:keyboard-select:search
urxvt*urlLauncher: /usr/bin/firefox
urxvt.underlineURLs: false
urxvt*matcher.button: 1
URxvt*matcher.pattern.1: \\bwww\\.[\\w-]\\.[\\w./?&@#-]*[\\w/-]
URxvt*matcher.rend.0: fg15

Xcursor.theme: Adwaita
Xcursor.size: 12

Last edited by Comfortably_Dumb (2012-10-07 20:34:58)


#2 2012-10-06 23:43:00

From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] Borderless URXVT/Awesome WM

Use code blocks.  I am not an awesome user... I am rather lame actually.... so I cannot help you I don't think.

This may be off putting to some though:

I use Windows 95....err, I mean Arch with Awesome WM with urxvt.


#3 2012-10-07 00:48:48

From: .nz
Registered: 2009-05-09
Posts: 25,099

Re: [SOLVED] Borderless URXVT/Awesome WM

The Wiki page has details on how to configure Urxvt.

You might want to start by fixing the case of your first two blocks--as you have found with your own experiments, it does matter.

Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438


#4 2012-10-07 01:31:09

From: 'Murica
Registered: 2012-04-24
Posts: 49

Re: [SOLVED] Borderless URXVT/Awesome WM

I am unfamiliar with the urxvt*borderless entry in the Xresources file, however if you are referring to the thin colored border of the window that comes with a default awesome install, it is controlled by the default theme.lua. The setting I believe you are looking for is in usr/share/awesome/themes/default/theme.lua


"Think for yourself and question authority." -T. Leary


#5 2012-10-07 02:24:10

Registered: 2010-02-03
Posts: 56

Re: [SOLVED] Borderless URXVT/Awesome WM

Forcing urxvt to be borderless when wm has a hint for that,afaik is risky. The way to remove borders is from your theme.lua.


#6 2012-10-07 20:23:24

Registered: 2011-06-14
Posts: 16

Re: [SOLVED] Borderless URXVT/Awesome WM

Thank you, everyone,f or your suggestions.  I will look into them and see what where it leads me. smile

Edited to add:  The problem was my ignorance.  As it ends up, BluMongoose and ganastasiou were correct.  I simply needed to edit my theme.lua.  Many thanks again for helping with this.

Last edited by Comfortably_Dumb (2012-10-07 20:34:05)


Board footer

Powered by FluxBB