You are not logged in.

#1 2012-10-07 13:34:37

baren
Member
Registered: 2012-10-07
Posts: 6

[SOLVED] BCM4313 (14e4:4727) - Can't get wireless working

dmesg result

[    5.439784] Linux media interface: v0.10
[    5.442295] bcma: Found chip with id 0x4313, rev 0x01 and package 0x08
[    5.442325] bcma: Core 0 found: ChipCommon (manuf 0x4BF, id 0x800, rev 0x24, class 0x0)
[    5.442351] bcma: Core 1 found: IEEE 802.11 (manuf 0x4BF, id 0x812, rev 0x18, class 0x0)
[    5.442407] bcma: Core 2 found: PCIe (manuf 0x4BF, id 0x820, rev 0x11, class 0x0)
[    5.470533] bcma: Bus registered
...
[    5.755510] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
[    5.755665] r8169 0000:13:00.0: >irq 48 for MSI/MSI-X
[    5.755839] r8169 0000:13:00.0: >eth0: RTL8102e at 0xffffc9001109e000, b8:ac:6f:e7:ac:5d, XID 04e00000 IRQ 48

I believe I have no other drivers installed and wanted to used the default brcmsmac

What I think could be happening, is that I don't have the brcmsmac for whatever reason.

More information: I have no wireless drivers blacklisted, since I've read brcmsmac needs bcma since kernel 3.2 or so (and I am on kernel 3.5.5-1). And anyway, even if I blacklist bcma, I can't get it to work.

If any more info is needed, please tell me.

Thank you.

EDIT: Well, I guess an ifconfig and iwconfig would be relevant, so here it it.

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.116  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::baac:6fff:fee7:ac5d  prefixlen 64  scopeid 0x20<link>
        ether b8:ac:6f:e7:ac:5d  txqueuelen 1000  (Ethernet)
        RX packets 25446  bytes 28487107 (27.1 MiB)
        RX errors 0  dropped 6  overruns 0  frame 0
        TX packets 17860  bytes 2083635 (1.9 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 16436
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 1464  bytes 107000 (104.4 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1464  bytes 107000 (104.4 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
eth0      no wireless extensions.

lo        no wireless extensions.

Last edited by baren (2012-10-07 17:47:16)

Offline

#2 2012-10-07 15:36:14

baren
Member
Registered: 2012-10-07
Posts: 6

Re: [SOLVED] BCM4313 (14e4:4727) - Can't get wireless working

>/lib/modules/3.5.5-1-ARCH/kernel/drivers/staging

No brcm80211/brcmsmac/brcmsmac.ko

So, indeed, I don't have brcmsmac installed.
What now? I can't seem to find it anywhere

Offline

#3 2012-10-07 15:48:10

Gusar
Member
Registered: 2009-08-25
Posts: 3,409

Re: [SOLVED] BCM4313 (14e4:4727) - Can't get wireless working

brcmsmac isn't in staging anymore. You for sure have it. Post the entire dmesg, the part you posted is just the bcma part. Also check with lsmod that brcmsmac is loaded.

Offline

#4 2012-10-07 15:52:30

baren
Member
Registered: 2012-10-07
Posts: 6

Re: [SOLVED] BCM4313 (14e4:4727) - Can't get wireless working

dmesg (bcma blacklisted): http://pastebin.com/VCGnkLKg


lsmod (bcma blacklisted): http://pastebin.com/XEK9UHup

Offline

#5 2012-10-07 15:55:09

Gusar
Member
Registered: 2009-08-25
Posts: 3,409

Re: [SOLVED] BCM4313 (14e4:4727) - Can't get wireless working

Why did you blacklist bcma? You said correctly in your first post that it shouldn't be blacklisted anymore. Well, it doesn't matter, because blacklists don't matter for manually loaded modules, which is what I seed you did. Remove the blacklist though, so that brcmsmac will be loaded automatically.

Anyway, the module got loaded without errors, at least I can't see any. So what exactly is the problem now?

Last edited by Gusar (2012-10-07 15:57:25)

Offline

#6 2012-10-07 15:57:03

baren
Member
Registered: 2012-10-07
Posts: 6

Re: [SOLVED] BCM4313 (14e4:4727) - Can't get wireless working

Gusar wrote:

Why did you blacklist bcma? You said correctly in your first post that it shouldn't be blacklisted anymore. Well, it doesn't matter, because blacklists don't matter for manually loaded modules, which is what I seed you did.

I wasn't quite sure about it and, until someone responded to my thread, I decided to trial and error.

I will unblacklist it and return in some minutes with a new dmesg and lsmod

Offline

#7 2012-10-07 16:03:46

baren
Member
Registered: 2012-10-07
Posts: 6

Re: [SOLVED] BCM4313 (14e4:4727) - Can't get wireless working

Okay, everything works perfectly now!

I will tell what I think happened, for people who may find this problem in the future.

I believe that is you update your kernel with bcma un-blacklisted, brcmsmac is deactivated or something like that.
So, I downgraded linux and linux-headers
Blacklisted bcma
Upgraded (this time, with bcma blacklisted, I think brcmsmac got activated or something like that)
Unblacklisted bcma, since brcmsmac needs it to funtion.
Done!

So, from my research, here is my proposed solution:

1) Downgrade the kernel
2) Blacklist bcma
3) Upgrade the kernel
4) Unblacklist bcma

Thank you for all the help, Gusar, by the way. I accidentally got it working by your tip!

EDIT: now that I think about it, it would be a hassle to blacklist/unblacklist bcma every time the kernel is to be updated. Is there a way to tell a developer to solve this? I don't know any technical aspect of linux in order to patch the kernel myself, unfortunately.

Last edited by baren (2012-10-07 16:10:20)

Offline

#8 2012-10-07 17:04:02

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,429

Re: [SOLVED] BCM4313 (14e4:4727) - Can't get wireless working

If this is working, go ahead and edit your original post and add [SOLVED] to the beginning of the title.  The moderators don't do that because only you know whether it is really solved smile


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

#9 2012-10-07 17:48:00

baren
Member
Registered: 2012-10-07
Posts: 6

Re: [SOLVED] BCM4313 (14e4:4727) - Can't get wireless working

ewaller wrote:

If this is working, go ahead and edit your original post and add [SOLVED] to the beginning of the title.  The moderators don't do that because only you know whether it is really solved smile

What a lovely and respectful practice.
Done.

Offline

Board footer

Powered by FluxBB