You are not logged in.

#1 2012-10-07 18:14:53

jdc2172
Member
Registered: 2012-10-07
Posts: 2

brcms_c_prec_enq_head: No where to go, prec == 4

After a little while (10 min-ish) of using wireless, connection becomes completely unresponsive. However, stills says im connected - things like 'ping' just simply hang. Restarting network services fix it for another few minutes (I've tried this under NetworkManager and netcfg).

Looking at journalctl logs, there is "brcms_c_prec_enq_head: No where to go, prec == 4", which appears repeatedly until I restart wireless.

Additionally, I get some kind of kernel warning after a bunch of the queue warnings:

------------[ cut here ]------------
WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:7998 brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]()
Hardware name: MacBookAir5,2
Modules linked in: fuse btusb bluetooth hid_generic usb_storage uas joydev hid_apple usbhid hid bcm5974 snd_hda_codec_hdmi snd_hda_codec_cirr ...
Pid: 85, comm: kworker/u:5 Not tainted 3.6.0-rc4-min #1
Call Trace:
[<ffffffff81055bff>] warn_slowpath_common+0x7f/0xc0
[<ffffffff81055c5a>] warn_slowpath_null+0x1a/0x20
[<ffffffffa04b8879>] brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]
[<ffffffffa04ab1bb>] brcms_ops_flush+0x3b/0x60 [brcmsmac]
[<ffffffffa044b19a>] ieee80211_scan_work+0x31a/0x610 [mac80211]
[<ffffffffa02bfe01>] ? snd_pcm_period_elapsed+0x31/0x100 [snd_pcm]
[<ffffffff81073369>] process_one_work+0x139/0x500
[<ffffffffa044ae80>] ? ieee80211_run_deferred_scan+0x90/0x90 [mac80211]
[<ffffffff81073d9e>] worker_thread+0x15e/0x440
[<ffffffff8145f2c9>] ? preempt_schedule+0x49/0x70
[<ffffffff81073c40>] ? manage_workers.isra.21+0x2a0/0x2a0
[<ffffffff81079623>] kthread+0x93/0xa0
[<ffffffff81468784>] kernel_thread_helper+0x4/0x10
[<ffffffff81079590>] ? kthread_freezable_should_stop+0x70/0x70
[<ffffffff81468780>] ? gs_change+0x13/0x13
---[ end trace 2d525b70c42e6f27 ]---

Offline

#2 2012-10-22 04:27:52

dront78
Member
From: Moscow
Registered: 2010-11-24
Posts: 38

Re: brcms_c_prec_enq_head: No where to go, prec == 4

bug still here for mee too
uptime for an one day and no traffic at all

Offline

#3 2012-10-22 04:49:59

dront78
Member
From: Moscow
Registered: 2010-11-24
Posts: 38

Re: brcms_c_prec_enq_head: No where to go, prec == 4

[83753.526546] ieee80211 phy0: >brcms_ops_bss_info_changed: arp filtering: enabled true, count 1 (implement)
[83753.531636] ieee80211 phy0: >brcms_ops_bss_info_changed: arp filtering: enabled true, count 0 (implement)
[83753.533017] ieee80211 phy0: >brcms_ops_bss_info_changed: arp filtering: enabled true, count 1 (implement)
[85024.834839] ------------[ cut here ]------------
[85024.834839] WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:7968 brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]()
[85024.834839] Hardware name: Satellite A660
[85024.834839] Modules linked in: brcmsmac cordic brcmutil bcma mac80211 cfg80211 fuse aes_x86_64 cryptd aes_generic tun rfcomm bnep zram(C) snd_hda_codec_hdmi nvidia(PO) ir_lirc_codec lirc_dev ir_mce_kbd_decoder arc4 joydev ir_sanyo_decoder uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev ir_sony_decoder ir_jvc_decoder snd_hda_codec_realtek media snd_hda_intel snd_hda_codec snd_hwdep ir_rc6_decoder serio_raw i2c_i801 acpi_cpufreq sdhci_pci intel_agp ir_rc5_decoder snd_pcm toshiba_acpi sparse_keymap r8169 microcode lpc_ich btusb bluetooth wmi mii snd_page_alloc rfkill sdhci coretemp mei mfd_core i2c_core intel_gtt crc32c_intel mperf jmb38x_ms psmouse ir_nec_decoder mmc_core intel_ips toshiba_bluetooth evdev battery video processor memstick rc_rc6_mce ac button ene_ir rc_core loop kvm_intel kvm snd_hrtimer snd_seq_midi_emul snd_seq snd_seq_device snd_timer snd soundcore cpuid cpufreq_stats cpufreq_userspace cpufreq_conservative cpufreq_powersave ext4 crc16 jbd2 mbcache
[85024.834839]  sr_mod
[85024.834839]  cdrom sd_mod ahci libahci libata scsi_mod ehci_hcd usbcore usb_common [last unloaded: cordic]
[85024.834839] Pid: 11388, comm: kworker/u:2 Tainted: P        WC O 3.5.6-1-ARCH #1
[85024.834839] Call Trace:
[85024.834839]  [<ffffffff81051a3f>] warn_slowpath_common+0x7f/0xc0
[85024.834839]  [<ffffffff81051a9a>] warn_slowpath_null+0x1a/0x20
[85024.834839]  [<ffffffffa043ed29>] brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]
[85024.834839]  [<ffffffffa04311bb>] brcms_ops_flush+0x3b/0x60 [brcmsmac]
[85024.834839]  [<ffffffffa100f19a>] ieee80211_scan_work+0x31a/0x610 [mac80211]
[85024.834839]  [<ffffffff8106ef1a>] process_one_work+0x12a/0x440
[85024.834839]  [<ffffffffa100ee80>] ? ieee80211_run_deferred_scan+0x80/0x80 [mac80211]
[85024.834839]  [<ffffffff8106f77e>] worker_thread+0x12e/0x2d0
[85024.834839]  [<ffffffff8106f650>] ? manage_workers.isra.26+0x1f0/0x1f0
[85024.834839]  [<ffffffff81074e73>] kthread+0x93/0xa0
[85024.834839]  [<ffffffff8148aa64>] kernel_thread_helper+0x4/0x10
[85024.834839]  [<ffffffff81074de0>] ? kthread_freezable_should_stop+0x70/0x70
[85024.834839]  [<ffffffff8148aa60>] ? gs_change+0x13/0x13
[85024.834839] ---[ end trace 2e5d7a7871237cc8 ]---

Offline

#4 2012-10-22 08:33:29

Aximand
Member
From: Russia
Registered: 2009-11-15
Posts: 15

Re: brcms_c_prec_enq_head: No where to go, prec == 4

The very same thing on Asus EeePc 1018P with Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller on board

ieee80211 phy0: >brcms_c_prec_enq_head: No where to go, prec == 4

countless amount of times

Offline

#5 2012-10-27 19:03:58

Aximand
Member
From: Russia
Registered: 2009-11-15
Posts: 15

Re: brcms_c_prec_enq_head: No where to go, prec == 4

Switched to broadcom-wl

Offline

#6 2012-12-25 09:46:14

Cheesecake Charlie
Member
Registered: 2011-09-08
Posts: 94

Re: brcms_c_prec_enq_head: No where to go, prec == 4

Did switching to Broadcom-wl help at all ?

Offline

#7 2012-12-25 22:15:57

Aximand
Member
From: Russia
Registered: 2009-11-15
Posts: 15

Re: brcms_c_prec_enq_head: No where to go, prec == 4

Cheesecake Charlie wrote:

Did switching to Broadcom-wl help at all ?

Well, yeah. But recently I got back on brcmblabla and for me it's working again.

Linux 3.6.8-1-ARCH x86_64

Offline

#8 2013-01-08 18:37:27

dront78
Member
From: Moscow
Registered: 2010-11-24
Posts: 38

Re: brcms_c_prec_enq_head: No where to go, prec == 4

brcms_c_prec_enq_head: No where to go, prec == 4

3.6.11-1-ARCH #1 SMP PREEMPT Tue Dec 18 08:57:15 CET 2012 x86_64 GNU/Linux

with torrent or 3 hours web online

Offline

#9 2013-02-14 22:24:40

Canha
Member
Registered: 2011-12-16
Posts: 7

Re: brcms_c_prec_enq_head: No where to go, prec == 4

I'm getting this as well, with Broadcom BCM4313 WLAN.

Last edited by Canha (2013-02-14 22:41:07)

Offline

#10 2013-02-22 00:27:20

oliveiranathan
Member
Registered: 2013-02-22
Posts: 1

Re: brcms_c_prec_enq_head: No where to go, prec == 4

Looks like it happens when the Access Point is configured as 802.11n.

Try changing the AP to 802.11b/g and see if the problem persists.
Stopped crashing here. I have a BCM4313 too...

Offline

Board footer

Powered by FluxBB