You are not logged in.

#1 2012-10-07 21:19:14

techwiz
Member
Registered: 2012-01-26
Posts: 48

[Solved]nvidia and nvidia-utils seem to be out of sync

There's an update for nvidia (304.51-3 I believe) but no corresponding update for nvidia-utils which lead to my system's X getting shot to hell as a result. Anyone else having trouble with the update? Normally nvidia and nvidia-utils have the same version number.

Last edited by techwiz (2012-10-09 20:40:01)

Offline

#2 2012-10-07 21:45:41

karol
Archivist
Registered: 2009-05-06
Posts: 25,432

Re: [Solved]nvidia and nvidia-utils seem to be out of sync

nvidia needs nvidia-utils=304.51 so nvidia-utils 304.51-1 should be OK. '-1' is the release number, both packages are version 304.51.

What exactly is wrong, can you post some logs etc.?

Offline

#3 2012-10-07 21:50:41

techwiz
Member
Registered: 2012-01-26
Posts: 48

Re: [Solved]nvidia and nvidia-utils seem to be out of sync

I upgraded nvidia to 304.51-3 and X just died saying it couldn't load the nvidia module. I tried manually and got "exec format error" and then realize that nvidia and nvidia-utils were not the same "version" and assumed that was the problem (downgrade of nvidia fixed the problem).

Maybe it was just a bad binary or something. I'll look a little further into it later and see if I can find the actual cause.

Thanks for the reply.

Offline

#4 2012-10-07 21:51:28

graysky
Member
From: /run/user/1000
Registered: 2008-12-01
Posts: 8,646
Website

Re: [Solved]nvidia and nvidia-utils seem to be out of sync

Pacman would not install from a corrupt archive.


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#5 2012-10-07 22:02:42

techwiz
Member
Registered: 2012-01-26
Posts: 48

Re: [Solved]nvidia and nvidia-utils seem to be out of sync

Yea that's what I thought... pacman does like what 2-3 completely separate quality checks on the packages before installing? I tried re-creating the xorg.conf on the broken nvidia setup and that didn't do much either, not that it mattered since I couldn't load the module manually anyway.

Offline

#6 2012-10-07 22:35:41

gabx
Member
From: Geneva, Switzerland
Registered: 2011-11-20
Posts: 91
Website

Re: [Solved]nvidia and nvidia-utils seem to be out of sync

Did you get the message from pacman when upgrading:

libgl and nvidia-utils are in conflict

When choosing to upgrade, pacman ask if you want to remove nvidia-utils. What did you answer?
What is the result of this command?

#pacman -Q | grep nvidia

Last edited by gabx (2012-10-07 22:39:09)

Offline

#7 2012-10-09 00:23:54

techwiz
Member
Registered: 2012-01-26
Posts: 48

Re: [Solved]nvidia and nvidia-utils seem to be out of sync

nvidia has been installed and running perfectly on my system for a while now, the trouble came from an update to the package to which pacman didn't say a word but the package broke somehow. nvidia-utils is also installed and working fine, the problem is with nvidia which was oddly the only package of the duo that got an update.

Offline

#8 2012-10-09 20:39:46

techwiz
Member
Registered: 2012-01-26
Posts: 48

Re: [Solved]nvidia and nvidia-utils seem to be out of sync

Found out what the problem was.. Turns out it was actually the linux kernel update that was delayed. Nvidia's new binary is compiled with the latest kernel and headers which were not on my system, and thus the failure.

Offline

Board footer

Powered by FluxBB