You are not logged in.

#1 2012-10-08 12:04:23

vheon
Member
Registered: 2010-04-08
Posts: 21

Xresources not use Xft settings

Hi,
I have this in my .Xresources

!-------------------------------------------------------------------------------
! Xft settings
!-------------------------------------------------------------------------------

Xft.dpi:                    96
Xft.antialias:              true
Xft.rgba:                   rgb
Xft.hinting:                true
Xft.hintstyle:              hintslight

and this is in my .xinitrc

[[ -f ~/.Xresources ]] && xrdb -merge ~/.Xresources

and this is the result for

$ xrdb -q | grep Xft
Xft.antialias:	1
Xft.autohint:	0
Xft.dpi:	96
Xft.hinting:	1
Xft.hintstyle:	hintfull
Xft.lcdfilter:	lcddefault
Xft.rgba:	rgb

How is that possible? something overrides my settings? where should I look?
Maybe is useful to know that I use the infinality fontconfig and freetype2.

Offline

#2 2012-10-08 12:18:14

mariusmeyer
Member
From: Norway
Registered: 2009-04-25
Posts: 244

Re: Xresources not use Xft settings

What (if any...) DE are you using? Do you use a login manager?

Offline

#3 2012-10-08 12:22:20

RaisedFist
Member
From: Romania
Registered: 2007-01-30
Posts: 553
Website

Re: Xresources not use Xft settings

I think this happens to me too. I'm using Openbox.

Offline

#4 2012-10-08 12:56:38

vheon
Member
Registered: 2010-04-08
Posts: 21

Re: Xresources not use Xft settings

mariusmeyer wrote:

What (if any...) DE are you using? Do you use a login manager?

no DE (I use awesome) and no login manager...

Offline

#5 2012-10-08 13:22:32

2ManyDogs
Member
Registered: 2012-01-15
Posts: 1,631

Re: Xresources not use Xft settings

vheon wrote:

How is that possible? something overrides my settings? where should I look?
Maybe is useful to know that I use the infinality fontconfig and freetype2.

Maybe it is useful to know this... what's in your infinality.conf file?

Online

#6 2012-10-08 13:58:06

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: Xresources not use Xft settings

2ManyDogs wrote:

Maybe it is useful to know this... what's in your infinality.conf file?

Better yet: what's in the /etc/profile.d/infinality-settings.sh?


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#7 2012-10-08 19:07:29

vheon
Member
Registered: 2010-04-08
Posts: 21

Re: Xresources not use Xft settings

bohoomil wrote:
2ManyDogs wrote:

Maybe it is useful to know this... what's in your infinality.conf file?

Better yet: what's in the /etc/profile.d/infinality-settings.sh?

You're right smile inside the infinality-settings.sh there was the incriminated line wich overrides the Xft settings. Remains only to tweak the config to have an acceptable font in Urxvt.

Many thanks

Offline

Board footer

Powered by FluxBB