You are not logged in.

#1 2012-10-08 23:36:39

hoschi
Member
From: Ulm (Germany)
Registered: 2008-11-03
Posts: 352
Website

[Solved] Systemd - Overrides settings of Gnome-Power-Manager?

Hello!
I've always used the following to lines to tell Gnome-Power-Manager not to suspend my laptop, when the lid is closed:

org.gnome.settings-daemon.plugins.power lid-close-ac-action 'blank'
org.gnome.settings-daemon.plugins.power lid-close-battery-action 'blank'

I remember a huge (and regular...) discussion around Gnome 3, because the developers resisted to re-implemented a button for this in the UI of Gnome3. Well, the two lines above done their job all the time. Since the last update of Systemd this seems to be ignored:

Oct 09 01:19:58 cupcake systemd-logind[273]: Lid closed.
Oct 09 01:19:58 cupcake systemd-logind[273]: Suspending...
Oct 09 01:19:58 cupcake systemd[1]: Starting Sleep.
Oct 09 01:19:58 cupcake systemd[1]: Reached target Sleep.
Oct 09 01:19:58 cupcake systemd[1]: Starting Suspend...

Is anyone other affected? Looks like a real problem for me. If I close the lid I want to close my lid, nothing more an especially not suspend smile

/var/log/pacman.log

[2012-10-08 21:59] upgraded systemd (193-1 -> 194-1)
[2012-10-08 21:59] upgraded systemd-sysvcompat (193-1 -> 194-1)

Last edited by hoschi (2012-10-08 23:53:06)

Offline

#2 2012-10-08 23:39:48

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [Solved] Systemd - Overrides settings of Gnome-Power-Manager?

Did you disable it in /etc/systemd/logind.conf?  See man 5 logind.conf

Offline

#3 2012-10-08 23:52:50

hoschi
Member
From: Ulm (Germany)
Registered: 2008-11-03
Posts: 352
Website

Re: [Solved] Systemd - Overrides settings of Gnome-Power-Manager?

Nope. Found it five minutes ago. My shame! Thank you smile

https://wiki.archlinux.org/index.php/Sy … th_systemd

Offline

#4 2012-10-09 10:53:22

RaisedFist
Member
From: Romania
Registered: 2007-01-30
Posts: 553
Website

Re: [Solved] Systemd - Overrides settings of Gnome-Power-Manager?

whoa! thanks for this.... I'm using xfce4-power-manager and everytime I opened my lid it would wake up from sleep and suddenly go back... I'll look on this when I get home. Thanks a lot!

Offline

#5 2012-10-10 21:33:46

pablox
Member
From: /home/chile/curico/
Registered: 2008-05-14
Posts: 169
Website

Re: [Solved] Systemd - Overrides settings of Gnome-Power-Manager?

hoschi wrote:

Nope. Found it five minutes ago. My shame! Thank you smile

https://wiki.archlinux.org/index.php/Sy … th_systemd

This is driving me crazy. I've read the article, but I still don't understand what I'm supposed to do. I have tried changing values from logind.conf *IgnoreInhibited to yes to no, but the laptop still suspend when the lid is closed sad.


Geeks & Linux Atelier
An eye for an eye ... ends in making everybody blind -- Mahatma Gandhi
dotfiles

Offline

#6 2012-10-10 21:37:35

D.
Member
Registered: 2012-05-15
Posts: 64

Re: [Solved] Systemd - Overrides settings of Gnome-Power-Manager?

You uncomment the lines Handle*{Key,Switch} in logind.conf and set them to ignore.

Offline

#7 2012-10-10 21:57:35

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,686

Re: [Solved] Systemd - Overrides settings of Gnome-Power-Manager?

pablox wrote:
hoschi wrote:

Nope. Found it five minutes ago. My shame! Thank you smile

https://wiki.archlinux.org/index.php/Sy … th_systemd

This is driving me crazy. I've read the article, but I still don't understand what I'm supposed to do. I have tried changing values from logind.conf *IgnoreInhibited to yes to no, but the laptop still suspend when the lid is closed sad.

That article doesn't even mention the "IgnoreInhibited" options. It very explicitly states the relevent options in a bulleted list. Are you certain you read it?

Online

#8 2012-10-10 22:02:41

bwat47
Member
Registered: 2009-10-07
Posts: 637

Re: [Solved] Systemd - Overrides settings of Gnome-Power-Manager?

pablox wrote:
hoschi wrote:

Nope. Found it five minutes ago. My shame! Thank you smile

https://wiki.archlinux.org/index.php/Sy … th_systemd

This is driving me crazy. I've read the article, but I still don't understand what I'm supposed to do. I have tried changing values from logind.conf *IgnoreInhibited to yes to no, but the laptop still suspend when the lid is closed sad.

All you need to do is set HandleLidSwitch=ignore in logind.conf, this will make systemd ignore the lid switch completely, and leave gnome to handle it. Its pretty self explanatory... You can also set the other similar options to ignore, like HandlePowerKey, HandleSuspendKey, HandleHibernateKey if you want only gnome to handle them.

Last edited by bwat47 (2012-10-10 22:02:54)

Offline

#9 2012-10-11 02:13:42

pablox
Member
From: /home/chile/curico/
Registered: 2008-05-14
Posts: 169
Website

Re: [Solved] Systemd - Overrides settings of Gnome-Power-Manager?

bwat47 wrote:
pablox wrote:
hoschi wrote:

Nope. Found it five minutes ago. My shame! Thank you :)

https://wiki.archlinux.org/index.php/Sy … th_systemd

This is driving me crazy. I've read the article, but I still don't understand what I'm supposed to do. I have tried changing values from logind.conf *IgnoreInhibited to yes to no, but the laptop still suspend when the lid is closed :(.

All you need to do is set HandleLidSwitch=ignore in logind.conf, this will make systemd ignore the lid switch completely, and leave gnome to handle it. Its pretty self explanatory... You can also set the other similar options to ignore, like HandlePowerKey, HandleSuspendKey, HandleHibernateKey if you want only gnome to handle them.

I read it and I understood... maybe I had to reboot to make the changes work? I changed everything to ignore (I want to control that via xfce4-power-manager).


Geeks & Linux Atelier
An eye for an eye ... ends in making everybody blind -- Mahatma Gandhi
dotfiles

Offline

#10 2012-10-11 02:16:33

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [Solved] Systemd - Overrides settings of Gnome-Power-Manager?

Maybe just a daemon-reload might do the trick... not sure though.

Offline

#11 2012-10-11 02:26:13

pablox
Member
From: /home/chile/curico/
Registered: 2008-05-14
Posts: 169
Website

Re: [Solved] Systemd - Overrides settings of Gnome-Power-Manager?

Well, after rebooting it worked so I'm happy again =P


Geeks & Linux Atelier
An eye for an eye ... ends in making everybody blind -- Mahatma Gandhi
dotfiles

Offline

#12 2013-08-16 06:32:15

fallen00sniper
Member
Registered: 2013-03-07
Posts: 27

Re: [Solved] Systemd - Overrides settings of Gnome-Power-Manager?

i realize this is an old post, but all i seem to find are old and older posts, this is not working for me, nor gnome-tweak-tools or command line options i have found...

driving me nuts trying to get this resolved.

has anyone else experienced this recently and found a solution that works?

maybe if i used a different wm...?

Last edited by fallen00sniper (2013-08-16 06:32:52)

Offline

#13 2013-08-16 11:45:38

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,709

Re: [Solved] Systemd - Overrides settings of Gnome-Power-Manager?

fallen00sniper wrote:

i realize this is an old post, but all i seem to find are old and older posts, this is not working for me, nor gnome-tweak-tools or command line options i have found...

driving me nuts trying to get this resolved.

has anyone else experienced this recently and found a solution that works?

maybe if i used a different wm...?

Don't ever do this. Make a new thread instead of bumping an old one. Please read the forum rules.


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

Board footer

Powered by FluxBB